15:01:05 <quaid> #startmeeting
15:01:05 <ovirtbot> Meeting started Wed Jan 11 15:01:05 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:38 <quaid> I forgot if my duties included sending out a reminder and agenda, so of course I didn't
15:01:55 * pmyers is here
15:01:59 <quaid> #topic Hello & who is here
15:02:10 * rharper is here
15:02:11 * jimjag is here
15:02:13 * mestery is here.
15:02:43 * oschreib here
15:03:20 * flash is here
15:03:28 * ovedo is here
15:03:36 * sgordon is here -_-
15:03:43 <miki1> here
15:04:07 <quaid> #topic Setting today's agenda
15:04:19 <quaid> * Release status
15:04:22 <quaid> * Test day
15:04:32 <quaid> * Event promotion
15:04:36 <quaid> anything else?
15:05:27 <rharper> quaid: I wanted to bring up gmane indexing of ovirt mailing lists
15:05:51 * MarkBaker is here
15:06:08 <quaid> rharper: ok, got it
15:06:42 <quaid> anythingn else?
15:07:03 <quaid> ok then!
15:07:10 <quaid> #topic Release status
15:07:30 <oschreib> I guess it's my turn :)
15:07:30 <quaid> oschreib & others - how are we doing?
15:07:35 <oschreib> all good.
15:07:38 <oschreib> soooo
15:07:52 <oschreib> tomorrow is ovirt-engine branching day
15:08:05 <quaid> #info Thu 12 Jan is ovirt-engine branching day
15:08:21 <oschreib> we have some massive effort to stabilize it a bit before.
15:08:33 <oschreib> and we want to push the JBoss AS7 support
15:08:45 <cctrieloff> is here -- late
15:08:47 <oschreib> this might happen today. depends on some engine-core patches.
15:09:13 <oschreib> vdsm have an official package, so ovirt-node can take it.
15:09:25 * itamar in
15:09:33 <oschreib> although I think they have a bug with setting some spice certificates.
15:09:33 <quaid> #info ovirt-engine now stable after massive effort; want to push JBoss AS8 support, perhaps today
15:09:38 <oschreib> anyone from vdsm here?
15:09:39 * jb_netapp in
15:09:46 <oschreib> quaid: AS7
15:09:49 <quaid> #info VDSM has an official package! ovirt-node can use it
15:09:49 <rbergeron> hey guys :) /me waves from a plane
15:09:57 <pmyers> mburns: since vdsm official package is out will oVirt Node ISO build happen today (and 2.0.1 release)?
15:10:02 <oschreib> quaid: and it's not stable :) it will be, we hope
15:10:09 <quaid> #info ovirt-engine now stable after massive effort; want to push JBoss AS7 support, perhaps today <CORRECTION
15:10:26 <pmyers> if we're blocked on EFI still with jboggs, I suggest we build today and incorporate EFI changes later this month
15:10:27 <mburns> pmyers: depends on our stabilization efforts and the last couple bugs that we have for 2.2.1
15:10:27 <quaid> rbergeron: I forget how to clear last command to bot
15:10:37 <pmyers> er 2.2.1, sorry I got version messed up
15:10:46 <quaid> oschreib: I'll let you do your own #info so I don't mess it up :)
15:11:03 <mburns> pmyers: that's my main task for today, getting this stuff out
15:11:03 <oschreib> next time?
15:11:17 <pmyers> mburns: ok thx
15:11:21 <jboggs> pmyers, its working other than 2 small issues, my vfat fs is getting overwritten somehow and console isnt displaying anything,  otherwise all ducks in a row
15:11:33 <pmyers> jboggs: xlnt
15:11:33 <rbergeron> quaid: #undo does it
15:11:44 <quaid> #undo
15:11:44 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x997c8cc>
15:11:49 <quaid> #undo
15:11:49 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9a19a0c>
15:12:02 <jboggs> build away but id prefer to test it more heavily before releasing it so we dont break mbr booting
15:12:13 <quaid> #info ovirt-engine nearing stability after massive effort; want to push JBoss AS7 support, perhaps today
15:12:25 <oschreib> that's better
15:12:46 * quaid picked a bad day to stop sniffing glue
15:12:47 <oschreib> shame no one from vdsm is here
15:13:21 <quaid> who on the channel is from vdsm?
15:13:27 <oschreib> I guess I'll have to talk with them before next meeting.
15:13:32 <quaid> is danken?
15:13:56 <oschreib> I'm not sure he's listening..
15:14:48 <oschreib> oh, we uploaded a new releases of ovirt-engine and ovirt-guest-agent to ovirt.org
15:15:12 <quaid> #info new releases of ovirt-engine and ovirt-guest-agent on ovirt.org
15:15:42 <oschreib> new builds for ovirt-engine-cli and ovirt-engine-sdk.
15:15:53 <oschreib> ovirt-engine-sdk is in the middle of fedora-review
15:15:57 <quaid> #info EFI hsa two small bugs - vfat fs getting overwritten, console isn't displaying anything; mburns working on this today
15:15:58 <oschreib> that's it :)
15:16:03 <sgordon> can i make another request that we flag some of the bugs/features for release noting?  the query is still empty: http://tinyurl.com/7gs9ojt
15:16:24 <sgordon> unfortunately it appears non redhat contributors wont be able to edit the tech notes field in bugzilla :(
15:16:25 <quaid> #info new builds for ovirt-engine-cli and ovirt-engine-sdk, the latter is in the middle of a Fedora package review
15:16:41 <sgordon> but the flag ovirt_requires_release_note? should be accessible
15:16:42 <oschreib> sgordon: I think we should flag bugs fixed after the test day
15:17:05 <quaid> #info bugs/features still need ovirt_requires_release_note flagging
15:17:16 <quaid> #link http://tinyurl.com/7gs9ojt
15:17:22 <sgordon> i think that will leave us with a pretty small amount of content for the release notes no?
15:17:34 <quaid> sgordon: who is working on fixing the notes field auth?
15:17:42 <sgordon> nobody quaid
15:17:44 <oschreib> sgordon: well, it's a first release
15:17:48 <sgordon> the bugzilla team says it's a feature
15:18:01 <quaid> sgordon: meaning they don't have a boolean for it?
15:18:05 <rbergeron> sgordon: can we just use a keyword in the whiteboard instead?
15:18:09 <sgordon> no non-RH contributors in any project can edit that field
15:18:21 <sgordon> with the exception of bug reporters
15:18:25 <ovirtbot> 14[[07Category:Multiple storage domains14]]4 !10 02http://www.ovirt.org/w/index.php?diff=1613&oldid=1596&rcid=1660 5* 03Jumper45 5* (+20) 10
15:18:30 <sgordon> as in if you reported the bug then you can edit it
15:18:41 * rbergeron grumbles
15:18:44 <sgordon> rbergeron, not sure, that may be under the same group
15:18:47 <sgordon> would need to test
15:18:55 <quaid> oh my
15:19:03 <sgordon> the problem is that we want the technical notes field for an actual paragraph of text
15:19:05 <quaid> who setup our bugzilla components in the first place?
15:19:07 <sgordon> not really a keyword
15:19:09 <sgordon> not sure
15:19:27 <sgordon> i emailed bugzilla-requests to request this change and had a back and forth with sgreen
15:19:39 <quaid> oic
15:20:00 <quaid> sgordon: can you include me in that discussion now?
15:20:26 <sgordon> lol
15:20:27 <quaid> the problem is, RHT Engineering loves when we use bugzilla for upstreams because it makes sustainable engineering that much easier
15:20:32 <sgordon> i can send you the ticket he closed three times on me
15:20:33 <sgordon> sure
15:20:33 <sgordon> :p
15:20:40 <quaid> but if bugzilla is a contributor-preventative, then it's not good
15:21:08 <quaid> sgordon: sounds like we need to use a little command-and-control to escalate the request :)
15:21:15 <quaid> ok, so ...
15:21:21 <quaid> for this release we can't count on that field being usable?
15:21:36 <quaid> how should we cover the release notes need currently?
15:21:42 <quaid> figuring that stuff will be flagged, etc.
15:21:43 <sgordon> no, i intend to generate a table on the wiki page
15:21:46 <sgordon> that we can then fill in
15:21:48 <quaid> ok
15:21:56 <sgordon> i still intend to use the flag to create that table though
15:22:02 <sgordon> http://www.ovirt.org/wiki/Release_Notes
15:22:06 <sgordon> page will be there^
15:22:28 <quaid> #info oVirt developers will need to fill in release notes for first release on wiki, as well as flag requires_release_note in bugzilla
15:22:39 <quaid> #link http://www.ovirt.org/wiki/Release_Notes
15:22:43 <sgordon> it's ovirt_requires_release_note i believe
15:22:52 * quaid was being laazy
15:23:03 <quaid> #undo
15:23:03 <ovirtbot> Removing item from minutes: <MeetBot.items.Link object at 0x99fd16c>
15:23:05 <quaid> #undo
15:23:05 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x99fd34c>
15:23:12 <quaid> #info oVirt developers will need to fill in release notes for first release on wiki, as well as flag ovirt_requires_release_note in bugzilla
15:23:16 <quaid> #link http://www.ovirt.org/wiki/Release_Notes
15:23:27 <quaid> you can tell it's been a few months since I've run an IRC meeting
15:23:30 <sgordon> as far as what oschreib and i were discussing as far as *which* bugs we should be flagging
15:23:42 <sgordon> my take was that we should be trying to highlight everything achieved since the workshop
15:23:47 <sgordon> but that's just my opinion
15:23:50 <quaid> +1 :)
15:24:04 <mgoldboi1> we have additional one more issue with vdsm configuring libvirt spice - right now sometimes spice wouldn't work cause of vdsm misconfiguration - bug is being opened and investigated now
15:25:01 <quaid> #info One open issue with VDSM configuring libvirt spice, occasionally not working due to VDSM misconfiguration
15:25:05 <quaid> mgoldboi1: bug #?
15:25:25 <quaid> oschreib: how are you on that release notes criteria?
15:25:29 <quaid> any other dev input there?
15:26:00 <mgoldboi1> quaid: bug is being opened
15:26:07 <oschreib> I'm not sure I understood the question
15:26:16 <mgoldboi1> no # yet - there is a workaround anyhow
15:26:35 <oschreib> mgoldboi1: can you file an Urgent BZ on vdsm?
15:26:51 <mgoldboi1> oschreib: on it's way
15:26:59 <quaid> oschreib: sgordon said you were discussing what should be in the release notes ...
15:27:19 <sgordon> oschreib, your suggestion was that we should only flag bugs actioned after the test day
15:27:34 <oschreib> true
15:27:35 <sgordon> mine was that we should be highlighting everything since the workshop
15:27:36 <sgordon> discuss
15:27:37 <sgordon> ;)
15:28:00 <oschreib> well, we did so much since the workshop
15:28:08 <quaid> release notes are for many purposes, one of them is to show "what is different since last release", another is "what is buggy to watch out for", etc.
15:28:21 <oschreib> I though the intention of RN is a list of "known issues" or something like that
15:28:38 <quaid> depends
15:29:04 <quaid> on the Fedora side, known issues is just part of it; it's largely a diff from last release
15:29:15 <quaid> what do we think our community wants and needs?
15:29:40 <quaid> consider the codebase and applications are new to many people, etc. and they may  not know already what was there before
15:29:46 <oschreib> well, we don't have any "last release"
15:30:14 <sgordon> in downstream (rhev) it is mostly known/outstanding issues, but if you have a look at say rhel
15:30:18 <sgordon> it is 99% new features
15:30:24 <sgordon> and the last chapter is all the updates
15:30:52 <oschreib> sgordon: I think we better take it offline and try to generate something that looks good
15:31:09 <sgordon> my problem is there are umpteen bugs in various states in bz
15:31:19 <sgordon> so we need at least *some* developer input to get anywhere with this
15:32:18 <quaid> well, we can evolve the RN over time, if it's early days and feature lists are less important?
15:32:18 <oschreib> I'll try to do some searches in BZ and contact the relevant devs
15:32:40 <quaid> oschreib: I think it's a topic for arch@ since at least some of the audience for the RN are there
15:32:58 <quaid> maybe after we do the first RN and release, we can ask users@ what could be improved in the notes
15:33:05 <sgordon> quaid, sure, but what i am trying to highlight is that if we do a rhev style release note
15:33:11 <sgordon> there will be very little content at this point
15:33:44 <quaid> sorry, I thought you said there -are_ umpteen bugs, so wouldn't that make lots of notes for known/outstanding?
15:34:19 <quaid> oic, developer input on what matters?
15:34:25 <sgordon> yes
15:34:28 <quaid> ok, shall we take this to the mailing list then?
15:34:50 <sgordon> tbh i have taken it to the mailing list twice
15:34:53 <sgordon> they need to buy in
15:34:57 <quaid> unless there is any other input ...
15:35:13 <quaid> sgordon: I thought those were reminders to put in notes, v. a discussion on notes scope?
15:35:23 <sgordon> requests for flagging
15:35:27 <sgordon> which defines the scope
15:35:59 <quaid> sorry, I thought we were discussing if we should include "all since last release", which implies a narrative of sorts derived from bug reports, not just a list of bug reports that close features
15:36:24 <sgordon> i would argue they are one and the same
15:37:08 <quaid> I presume you didn't mean a list = a narrative :)
15:37:26 <sgordon> no, but the narrative in the example i provided (rhel) IS from the list
15:37:35 <quaid> but if you and oschreib see the scope as defined by what bugs are flagged, then ...
15:38:01 <quaid> let's rally team leads to get a plan about what and when the teams will flag bugs?
15:38:06 <itamar> note that not all code/features/bug fixes had bugzilla associated with them.
15:38:33 <itamar> maybe ask each lead for a short release note list of changes rather than assume bugzilla has everything
15:39:27 <sgordon> ok
15:39:34 <sgordon> if that is what we have to do in the first chop so be it
15:39:41 <quaid> #info Each team lead could supply a short list of changes since workshop for release
15:39:57 <quaid> or rather, is that what we agree needs to happen?
15:39:58 <sgordon> but in previous meetings we talked about a goal of being able to automate this as much as possible
15:40:11 <sgordon> which means going forward it really needs to be tracked in bz
15:40:27 <quaid> sgordon: we might need to do a short wiki page that gives specific directions to follow during release cycle
15:40:52 <quaid> ok, we really need to move on
15:41:00 <quaid> but I'm not sure we have an agreement or action here
15:41:19 <quaid> sgordon: can you ask each lead for their team release notes?
15:41:24 <sgordon> sure
15:41:44 <quaid> #action sgordon to ask each team lead for release notes for first release, in addition to what is in BZ
15:41:50 <oschreib> quaid: I want to raise the option to delay the branching  to Sunday
15:42:44 <quaid> ok, does that need to be talked about before test day discussion?
15:43:20 <oschreib> quaid: if we will do it on Sunday, so the test day should be fine (I'm talking only in the context of ovirt-engine)
15:43:43 <oschreib> mgoldboi: still here?
15:43:50 <mgoldboi> oschreib: here
15:44:18 <quaid> #topic Delaying branching to Sunday proposal
15:44:25 <oschreib> mgoldboi: if we will create the new branch on Sunday, do you want to delay the test day? (one day or two)
15:44:47 <mgoldboi> oschreib: we are ok with postponing it a bit
15:45:07 <quaid> oschreib: so are you moving the branching or proposing and waiting for approval?
15:45:27 <oschreib> ok. so I reserve the right to delay the branching day if the JBoss AS7 won't make it today.
15:45:47 <quaid> #info Branching delay may occur depending on JBoss AS7 status
15:46:12 <quaid> #info Delayed branching will cause a postponing of test day for one or two days
15:46:24 <quaid> #topic Test day
15:46:27 <mgoldboi> oschreib: from testing POV  AS7 it's ready after the latest changes
15:46:51 <oschreib> ovedo: ^^ any comment?
15:47:00 <ovedo> oschreib, I'm okay with pushing the jboss 7 changes at the engine side.
15:47:23 <ovedo> oschreib, the only reason I thought to postpone is to ease the developers which will work on the weekend (our weekend).
15:47:23 <itamar> i think it is only a matter of we don't want to push them before the weekend, so postponing to sunday
15:47:50 <ovedo> I agree.
15:48:01 <oschreib> OK. I don't have any problem with that.
15:48:14 <quaid> #undo
15:48:14 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x995a50c>
15:48:16 <ovedo> we will have a better response time in case of issues, or help people setup their environment.
15:48:27 <quaid> darn, that didn't work :)
15:48:44 <quaid> #topic Delaying branching to Sunday
15:48:49 <quaid> #info Delayed branching will cause a postponing of test day for one or two days
15:49:10 <quaid> #info delaying branching to Sunday so we don't push before the weekend
15:49:16 <quaid> anything more on this topic?
15:49:20 <oschreib> no :)
15:49:25 <quaid> if not, let's talk about test day
15:49:31 <quaid> #topic Test day
15:49:39 <quaid> logistics? details? updated wiki pages?
15:50:04 <mgoldboi> wiki page is updated with scenarrios and details
15:50:14 <mgoldboi> has anyone reviewed it?
15:50:31 <mgoldboi> http://www.ovirt.org/wiki/Testing/OvirtTestDay
15:50:58 <quaid> #link
15:51:02 <quaid> #link http://www.ovirt.org/wiki/Release_Notes
15:51:09 <mgoldboi> includes deployment basic test scenarios - and python api examples
15:51:32 <quaid> #info Wiki page includes deployment basic test scenarios and python API examples
15:52:10 <quaid> anyone have any questions?
15:52:20 <quaid> mgoldboi: thanks for your email about test day, btw - reminders are key to participation :)
15:53:11 <mgoldboi> quaid: well, will probably need to send a change the date notification...
15:53:32 <quaid> #action mgoldboi to send a change-the-date of test day notification
15:54:09 <quaid> anything else for today on that topic?
15:55:06 <quaid> #topic Quick comment about using meetbot
15:55:24 <quaid> #info Anyone in channel can use #info & #action & #link
15:55:50 <quaid> #info Engineering management likes the notes we get when we use those well - they are informative and useful
15:55:59 <quaid> #info Also quite useful to anyone not here
15:56:16 <itamar> mgoldboi - test day - what about cli samples?
15:56:17 <quaid> so if you all want to have things go faster, you can save having rbergeron & I be the only ones who do info, action, and links
15:56:23 <itamar> sounds easier than api?
15:56:32 <mgoldboi> itamar: will get there by test day
15:56:41 <quaid> #topic Events
15:56:55 <quaid> #link http://www.ovirt.org/news-and-events/
15:57:11 <quaid> #info The news and events page now has all of the events that I know about, and the details that I have so far
15:57:59 <quaid> #info each event needs a wiki page to track details for participants of the event, and put that in the [[Category:Events]]
15:58:02 <quaid> #link http://ovirt.org/wiki/Category:Events
15:58:10 <itamar> fosdem should probably appear before brno day?
15:58:14 <quaid> let me know if we have any event missing
15:58:27 <quaid> itamar: oh, yeah, thanks
15:58:47 <quaid> fixed
15:58:56 <quaid> any missing events?
15:59:02 <quaid> otherwise, I move to close the meeting
15:59:07 <itamar> and there is a plan for something with kvm forum in linuxcon barcelona
15:59:26 <quaid> ok
15:59:28 <itamar> well, I thought the ovirt brno day will be on the 16th
15:59:30 <rharper> quaid: just wanted to poke on the gmane indexing of the ovirt mailing lists?
15:59:38 <quaid> rharper: right!
15:59:43 <itamar> before the fedora developer days
16:00:02 <quaid> itamar: ok, I'll make those changes
16:00:20 <itamar> well, let's sync with carl before doing them to check they are correct.
16:00:23 <quaid> itamar: who is running the ovirt brno day? I need to get details and a wiki page up
16:00:27 <quaid> itamar: same for kvm forum
16:00:31 <quaid> who is running that?
16:00:54 <quaid> ok, I'll work on these event details after the meeting
16:00:59 <quaid> #topic Gmane indexing
16:01:02 <rharper> I wanted to ask before adding any of the lists, any objections to subscribing ovirt lists into gmane.org indexing?  I was thinking of users@ovirt.org, arch@ovirt.org and engine-devel@ovirt.org
16:01:08 <cctrieloff> I believe robyn will be doing organizing bruno for us
16:01:25 <quaid> rharper: +1 from me, let's do all of them :)
16:01:44 <cctrieloff> +1
16:02:00 <rharper> quaid: ok, do we have a complete lists?  if so, point me at it and I'll push them in via the subscription page on gmane
16:03:04 <quaid> #link http://lists.ovirt.org/mailman/listinfo/
16:03:08 <rharper> perfect
16:03:18 <quaid> ok!
16:03:26 <rharper> thanks!
16:03:29 <quaid> I think that's it for today
16:03:40 <quaid> closing in ten seconds :0
16:03:46 <quaid> 5
16:03:48 <quaid> 4
16:03:49 <quaid> 3
16:03:50 <quaid> 2
16:03:51 <quaid> 1
16:03:54 <quaid> #endmeeting