14:00:12 <mburns> #startmeeting oVirt Node Weekly Sync
14:00:12 <ovirtbot> Meeting started Tue Feb  7 14:00:12 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:25 <mburns> #topic agenda
14:00:37 <mburns> 1.  Action Item Review
14:00:44 <mburns> 2.  Release status
14:00:47 <mburns> 3.  Other topics
14:00:57 <mburns> #topic Roll Call
14:01:00 <mburns> who's here?
14:01:02 * jboggs` here
14:02:03 <mburns> #chair pmyers jboggs
14:02:03 <ovirtbot> Current chairs: jboggs mburns pmyers
14:02:07 * pmyers in
14:02:14 <mburns> #topic Action Item review
14:02:21 <mburns> #link http://ovirt.org/meetings/ovirt/2012/ovirt.2012-01-31-14.00.html
14:02:41 <zwu> Can anyone let me know what is separately the full name of HSM and SPM?
14:03:11 <mburns> #action mburns to incorporate archipel-node stateless design into ovirt-node stateless plan
14:03:21 <jboggs> zwu, storage pool manager? or you looking for something else?
14:03:39 <mburns> #info virt-minimal patch sent by apevec to fedora-devel
14:03:54 <apevec> wha wha?
14:04:00 <apevec> ah yes, working on that
14:04:11 <zwu> jboggs: i am reading some docs about live snapshot, merge, etc.
14:04:12 <apevec> must push it to today, before Fedora freeze
14:04:34 <mburns> #info 2.2.2-2 ovirt-node built and posted to ovirt.org -- needs respin of the iso for iscsi-initiator-fix
14:04:44 <mburns> apevec: ack
14:04:45 <zwu> jboggs: thanks, then what is the full name of HSM?
14:04:54 <mburns> #info virt-minimal patch to be pushed today
14:04:54 <jboggs> zwu, not sure on that one
14:05:11 <zwu> jboggs: OK. anyway, thanks.
14:05:32 <jboggs> thinking its hsm ____ snapshot manager
14:06:05 <mburns> #info backlog page updated with corrected links and release dates
14:06:07 <mburns> #link http://www.ovirt.org/wiki/Node_Backlog
14:06:27 <mburns> #info bug cloning for 2.2.3/2.3.0 not complete
14:06:54 <mburns> #info patch for node registration to engine has been merged into engine
14:07:06 <mburns> jboggs: did you ever sync with dnaori on the installation issues?
14:07:19 <jboggs> mburns, never got back with me, was waiting on ssh access
14:07:33 <jboggs> ill followup again
14:07:38 <mburns> jboggs: thanks
14:07:47 <mburns> #action jboggs to followup with dnaori again
14:07:52 <jboggs> and rglonas patch verified by vdsm folks
14:08:03 <zwu> jboggs: Storage Pool Manager SPM runs on only one RHEV H or RHEL host
14:08:04 <zwu> SPM is the only thing allowed to run LVM commands like changing the size of LVs.
14:08:04 <zwu> SPM can only change the size of an LV in half a gigabyte chunks
14:08:04 <zwu> Host Storage Manager HSM is the local storage manager that runs on all hosts
14:08:04 <zwu> HSM runs validation
14:08:04 <zwu> HSM logs in to iSCSI
14:08:06 <zwu> HSM mounts NFS
14:08:06 <zwu> HSM checks status of iSCSI
14:08:32 <mburns> that's it for action items
14:08:33 <zwu> jboggs: There's more info on http://tannerjc.net/wiki/index.php?title=RHEV
14:08:44 <mburns> #topic release status
14:09:22 <mburns> #info go/no-go for ovirt first release is after this call (10:00 EST) right here
14:09:38 <mburns> node status:  2 issues being tracked
14:09:56 <mburns> 1.  registration to engine (fixed by rgolan 's patch)
14:10:13 <mburns> 2.  vdsm fails to start -- iscsi-initiator-utils bug
14:10:32 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=786174
14:10:57 <mburns> #info iscsi-initiator-tools pushed to testing, running a build now to test it
14:12:20 <mburns> #info ovirt-node should be good to go for first-release pending iscsi-initiator-utils package being verified
14:13:07 <mburns> #topic next release
14:13:27 <mburns> 2.2.3 scheduled for 2012-02-15 release
14:13:32 <mburns> #info 2.2.3 scheduled for 2012-02-15 release
14:14:12 <mburns> very little if any slack in that date
14:15:00 <mburns> that's all i have for release status
14:15:07 <mburns> anyone have anything else?
14:15:20 <mburns> #topic Other Topics
14:15:45 <pmyers> mburns: so I was seeing node registration problems, which the iscsi fix and the engine fix probably take care of
14:15:56 <mburns> pmyers: yes
14:15:57 <pmyers> but that was with the node registering to the engine via the TUI
14:15:59 <pmyers> but...
14:16:03 <pmyers> I also tried it the other way around
14:16:08 <pmyers> by adding the node via the engine UI
14:16:11 <pmyers> and that was not working either
14:16:14 <pmyers> separate problem?
14:16:19 <pmyers> saw someone else on list complain about that
14:16:25 <pmyers> we should test both directions in our smoke tests
14:16:29 <pmyers> to make sure both types of adds work
14:16:31 <mburns> pmyers: the engine fix should handle the node registering from tui
14:16:46 <mburns> pmyers: the iscsi fix blocks vdsm starting which is why it fails to add from the engine
14:16:51 <pmyers> ahhh
14:16:56 <pmyers> ok so two fixes, one fixes each path
14:17:02 <mburns> yes
14:17:03 <pmyers> cool
14:17:07 <mburns> at least that's my understanding
14:17:18 <pmyers> we'll test both paths tho from now on to make sure we don't regress?
14:17:19 <mburns> can't say yet whether there is a third issue masked by these 2
14:17:41 <mburns> pmyers: yes, we should test both paths
14:17:45 <pmyers> xlnt
14:18:43 <mburns> any other topics to cover today?
14:18:44 <teuf> oh iscsi fix, I was having issues exactly with that, cool
14:19:40 <mburns> teuf: yes, a new package is built in koji and i'm building a new node to test it right now
14:19:54 <mburns> but there are comments posted that say it works with vdsm now
14:20:10 <pmyers> jboggs: is UEFI all good with the exception of 'upstream doesn't know how to fix parted properly yet' ?
14:20:37 <teuf> mburns: I'll try installing the package on my node and cross fingers :)
14:20:49 <mburns> #info need to test 2 paths when test registration -- 1. initiate from ovirt-node 2.  initiate from engine
14:21:03 <mburns> #info 1. should be fixed by engine path
14:21:15 <mburns> #info 2.  should be fixed by new iscsi-initiator-utils
14:22:06 <pmyers> jboggs: ^^^
14:22:57 <mburns> pmyers: my understanding is we should be good as long as they don't pull the current patch before they get a true fix
14:23:32 <pmyers> ok
14:24:22 <mburns> ok any other topics?
14:25:18 <mburns> sounds like none
14:25:29 <jboggs> sorry connection dropped reading backchat
14:25:51 <mburns> jboggs: just checking uefi status
14:26:38 <jboggs> pmyers, yes once upstream figures it out, should be ok. I'm gonna try working with the parted commands and adding udev settles to see if that helps
14:26:59 <jboggs> just in case theres a way to fix it w/o having to rely on upstream for a fix
14:28:17 <mburns> jboggs: ok, thanks
14:28:41 <mburns> ok, since no other topics, i'll start the countdown to end the meeting
14:28:54 <mburns> 3...
14:29:03 <mburns> 2..
14:29:09 <mburns> 1.
14:29:13 <mburns> #endmeeting