14:00:28 <mburns> #startmeeting oVirt Weekly Sync
14:00:28 <ovirtbot> Meeting started Wed May 16 14:00:28 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:38 <mburns> #topic agenda and roll call
14:01:02 <mburns> agenda:
14:01:05 <mburns> Status of Next Release
14:01:05 <mburns> Sub-project reports (engine, vdsm, node)
14:01:05 <mburns> Review decision on Java 7 and Fedora jboss rpms in oVirt Engine
14:01:05 <mburns> Upcoming workshops
14:01:05 <mburns> oVirt / Quantum Integration (gkotton)
14:01:23 <mburns> #chair oschreib quaid
14:01:23 <ovirtbot> Current chairs: mburns oschreib quaid
14:01:53 <mburns> who's here?
14:01:57 * ofrenkel here
14:01:57 * lpeer_ is here
14:01:58 * doronf here
14:01:59 * lh is here
14:02:08 * lpeer is here
14:02:15 <cctrieloff> here
14:02:26 <dustins> here
14:02:36 * oschreib here
14:03:05 * mestery_ here
14:03:19 <mburns> #topic Next release status
14:03:35 <mburns> #info GA target:  2012-06-27
14:03:45 <mburns> #info beta target: 2012-05-31
14:03:58 <mburns> #info alpha target:  ASAP
14:04:01 * jb_netapp here
14:04:16 <mburns> oschreib: all yours...
14:04:29 <oschreib> OK
14:04:40 <oschreib> So I've created a new tracker BZ for oVirt 3.1
14:04:49 <oschreib> #info new tracker BZ for 3.1
14:04:53 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=822145
14:05:15 <oschreib> I'm worried about the Java7 and Fedora JBoss, but that's another topic.
14:05:37 <oschreib> about the alpha
14:05:37 <danken> note that it already has a vdsm blocker
14:06:06 <oschreib> #info BZ#821867 is a blocker for VDSM
14:06:10 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=821867
14:06:11 <mburns> oschreib: node build for alpha should be coming this week (hopefully)
14:06:32 <mburns> though we need vdsm build before we can build a node iso
14:06:43 <oschreib> So I'd guess alpha is in risk for next week
14:07:20 <oschreib> I'll open BZs for the Java7 and Fedora17 issues
14:07:25 <mburns> ok
14:07:29 <oschreib> it'd be better to track them that wat
14:07:30 <oschreib> way*
14:07:37 <mburns> oschreib: ack
14:07:46 <danken> (I must thank Shu Ming for finding vdsm's BZ#821867.)
14:07:58 <mburns> #action oschreib to open bzs to track Java7 and Fedora17 issues
14:08:30 <oschreib> danken: can you give us a brief on that bug? how bad is he?
14:09:46 <danken> vdsm configures libvirt's config file
14:10:05 <danken> but in Fedora 17, libvirt uses systemd to read that file
14:10:19 <danken> and systemd does not understand bash comments.
14:10:47 <danken> we will have to change the way we mark configuration lines as owned by vdsm
14:11:05 <oschreib> so, it really breaks libvirt?
14:11:21 <danken> that's going to require some sed'ing on our part, when vdsm removed
14:11:53 <danken> oschreib: on F17, vdsm makes libvirt not listen to anything
14:12:01 <mburns> ok, that's certainly even an alpha blocker
14:12:04 <oschreib> ok, sounds like an issue
14:12:15 <danken> yeah, dougsland is on it
14:12:28 <oschreib> danken: ok, keep us posted.
14:12:56 <mburns> oschreib: are engine rpms ready for alpha?
14:13:07 <oschreib> I'm wondering wheather to do the engine alpha build on Fedora16 (old JBoss) or to wait for the F17 patches
14:13:29 <mburns> oschreib: i'd say f16 for alpha, and f17 for beta
14:13:39 <mburns> or both for beta...
14:13:43 <oschreib> mburns: so yes, I have rpms
14:13:46 <oschreib> another issue
14:13:58 <oschreib> should we change the structure of ovirt.org/releases?
14:14:04 <oschreib> it's not version based right now
14:14:12 <oschreib> only /nightly and /stable
14:14:12 <mburns> oschreib: yes it is
14:14:33 <mburns> oschreib: http://ovirt.org/releases/stable/fedora/
14:14:37 <ofrenkel> danken, is the latest version change in vdsm included on this build? if so its a problem
14:14:37 <mburns> has 16, 17, 18
14:14:55 <oschreib> mburns: that's fedora releases, not ovirt
14:15:51 <oschreib> where to put alpha? in nightly? that's a bit weird
14:15:52 <danken> ofrenkel: yes, I suppose
14:15:58 <mburns> oschreib: perhaps we need a beta location
14:16:12 <mburns> and we can put alpha releases there
14:16:29 <mburns> and then beta will immediately obsolete the alpha
14:16:31 <danken> for the wider audience: since yesterday, vdsm reports its true version/release to Engine
14:16:44 <danken> ofrenkel: Engine does not handle the truth, I'm afraid...
14:17:05 <danken> vdsm has reprorted 4.9-0 due to an unfortunate bug
14:17:32 <ofrenkel> danken, yes, so its another blocker, truth hearts
14:17:44 <mburns> oschreib: so we would have release/{nightly,beta,stable}
14:18:13 <oschreib> sounds good to me
14:18:29 <danken> so please open a blocker Engine bug
14:18:34 <oschreib> #action oschreib to add ovirt.org/releases/beta
14:18:47 <mburns> #agreed add new "beta" section to releases on ovirt.org
14:18:48 <oschreib> mburns: that's it on the build status
14:18:53 <mburns> ok
14:19:01 <mburns> #topic sub-project status -- VDSM
14:19:11 <danken> #action ofrenkel open bug on Engine to handle real vdsm versions/release
14:19:11 <mburns> i think we covered this mostly already
14:19:22 <ofrenkel> danken, i think first a decision on what to do should be taken!
14:19:25 <mburns> 2 major blockers identified already
14:19:28 <mburns> #info 2 major blockers identified already
14:19:44 <ofrenkel> danken, if i am to open a bug it would be to revert that change
14:20:08 <mburns> #info bz821867 and one still to be filed
14:20:15 <danken> ofrenkel: you can open the bug on vdsm. it's summary line would be: lie about your version/release
14:20:21 <danken> it makes no sense at all.
14:20:38 <mburns> danken: any other updates for vdsm's status?
14:20:41 <ofrenkel> danken, i will find another way to say the same truth
14:20:51 <danken> vdsbroker can take the data from vdsm, convert it into floats and do whatever it wants.
14:22:11 <danken> mburns: well, basic networking is now working (that's a huge leap forward!)
14:22:23 <mburns> #info basic networking is working in vdsm
14:22:35 <mburns> danken: excellent
14:22:56 <mburns> ok, moving on unless there is something else vdsm related to report
14:23:05 <mburns> #topic sub-project status -- Engine
14:23:09 <danken> ofrenkel: I see Haim has openedn BugĀ 822158 -      [ovirt] [vdsm] fail to join host to cluster - version is not supported
14:23:09 <danken> on vdsm. this is a joke. I'm moving it to Engine.
14:23:26 <mburns> lpeer: any update on engine status?
14:23:39 <ofrenkel> danken, i really think we need to get an agreement first
14:23:55 <oschreib> ofrenkel: can you take that issue into the mailing list
14:24:15 <ofrenkel> oschreib, you cant get a build without it
14:24:18 <danken> ofrenkel: ok, let's agree.
14:24:56 <danken> we need someone to write a function that takes version/release and converts it to numbers that engine can handle.
14:25:06 <danken> I think that engine should do it.
14:25:13 <mburns> #info engine rpms ready for alpha (on F16)
14:25:28 <mburns> #info no other feedback
14:25:34 <mburns> #topic sub-project status -- Node
14:25:48 <mburns> #info F17 based nodes are running and appear to work correctly
14:25:50 <danken> but if it is too difficult, dougslas can do it on vdsm as a stopgap measure.
14:25:54 <ofrenkel> bazulay, yzaslavs feel free to give your opinions here...
14:26:14 <mburns> #info numerous patches still pending, working on getting those merged prior to alpha build
14:26:30 <mburns> #info only blocker known at the moment is lack of a vdsm build
14:27:03 <mburns> #topic Java 7 and Fedora 17
14:27:33 <oschreib> patches for both of the are avilable
14:27:36 <mburns> oschreib: do we consider having an all in one setup a blocker?
14:27:56 <oschreib> mburns: no. that's a feature. why?
14:27:59 <mburns> #info patches to move to F17 and java 7 are posted
14:28:21 <mburns> oschreib: because if it's a must have feature for this release, then F17 is a must
14:28:27 <mburns> since vdsm requires f17
14:28:33 <yzaslavs> ofrenkel: sorry, was away
14:28:43 <oschreib> IMO it's not a must-have
14:28:47 <mburns> ok
14:28:58 <mburns> ok
14:29:04 <ykaul> oschreib: I disagree.
14:29:49 <oschreib> ykaul: YOU we're the one adding most of the release criteria
14:29:55 <oschreib> ykaul: I didn't see AIO there
14:30:30 <ykaul> oschreib: I don't recall adding features to the release criteria. If we don't want this feature in the coming release, OK. I think it should be there.
14:30:48 <oschreib> ykaul: SHOULD is the right word
14:31:00 <mburns> i think we want the feature, but question is more whether we'll block the release if we don't have it ready
14:31:01 <ykaul> oschreib: should, as in lets not release if it's not there.
14:31:55 <oschreib> ykaul: that's a musty
14:31:57 <mburns> oschreib: are the java7 and f17 patches merged?
14:32:04 <oschreib> mburns: no
14:32:07 <mburns> ok
14:32:16 <mburns> #info patches still in review
14:32:18 <oschreib> http://gerrit.ovirt.org/#change,4315 - > Java7
14:32:23 <ykaul> mburns: is there a FEATURE we block for? I don't see any. None.
14:32:37 <oschreib> http://gerrit.ovirt.org/#change,4416 -> F17 support
14:32:46 <mburns> #link http://gerrit.ovirt.org/#change,4315
14:32:52 <mburns> #link http://gerrit.ovirt.org/#change,4316
14:32:55 <oschreib> both are considered Work in progress
14:32:57 <ykaul> and as for the other MUST items. Who knows their state?
14:33:17 <oschreib> we will know once we will test the 3.1 release
14:33:45 <oschreib> that's part of my job once we have a build
14:33:51 <oschreib> alpha/beta/rc whatever
14:34:01 <ykaul> oschreib: ok. I wasn't aware that someone is going to test all those MUSTs. For example, VLAN over bonded interface support and such.
14:34:05 <mburns> i don't see a reason to not put a feature on the blocker list
14:34:18 <ykaul> mburns: me neither, but I haven't seen a single feature there.
14:34:26 <oschreib> ykaul: someone will have to, or we will drop it
14:34:28 <mburns> is the feature is truly critical for the release, then we should have it on the criteria
14:34:54 <oschreib> guys, can we focus on the Java7 and F17? they are much more critical
14:35:07 <yzaslavs> ofrenkel: we have other bug regarding version , that i think is similar to the above bug - https://bugzilla.redhat.com/show_bug.cgi?id=760546
14:35:42 <mburns> oschreib: i agree, but if we say AIO is a requirement, then that forces F17 support to be a blocker
14:36:40 <oschreib> anyone from backend can update us on the Java7 &  F17 review status?
14:36:55 <mburns> lpeer: ?
14:37:38 <mburns> looks like we'll have to defer to next week again
14:37:52 <mburns> #topic Upcoming Workshops
14:38:01 <mburns> lh: you have the floor
14:38:25 <lh> Nothing much new to report on the workshops front. I've created this wiki page to keep everyone up to date
14:38:33 <lh> http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:38:41 <mburns> #info not much more to report
14:38:47 <mburns> #link http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:38:51 <lh> Most pressing matter is for folks to spread the word about the workshops coming up at LinuxCon Japan
14:39:22 <lh> Once that workshop happens and we get some data on what went well and what can be improved, I'll circle with the list so we can define agenda and instructors for LinuxCon North America
14:39:46 <lh> And thanks to the fine folks at NetApp, I'll be visiting their HQ tomorrow to tour the facilities in anticipation of  workshop to be held there in January 2013
14:40:11 <lh> mburns, that's all I have unless anyone is interested in implementation details of promoting LC Japan
14:40:12 <mburns> #info will get into planning for LinuxCon North America after LinuxCon Japan
14:40:38 <mburns> lh: i think we covered the promotion details on the mailing lists already
14:40:49 <lh> mburns, yes, that's all I had in that regard, as well.
14:40:56 <mburns> lh: do we have dates for the workshop in January?
14:41:00 <mburns> or too early for that?
14:41:19 <lh> mburns, the reservations for the Founders Theatre at NetApp are only bookable 3 months out, so not yet
14:41:31 <mburns> lh: ok
14:41:53 <lh> targeting late January, hoping 22-24th will work well
14:42:12 <mburns> #info workshop planned at NetApp for January.  Can't book firm dates until we're within 3 months
14:42:24 <mburns> #info targeting late January (22-24)
14:42:41 <mburns> ok, anything else for the upcoming workshop schedule?
14:42:53 <lh> mburns, nothing from me
14:43:14 <mburns> ok thanks lh
14:43:22 <mburns> #topic oVirt / Quantum integration
14:44:31 <mburns> this topic was requested by Gary Kotton
14:45:43 <mburns> #link http://www.ovirt.org/wiki/Quantum_and_oVirt
14:45:51 <mburns> not sure what he wanted to cover here though
14:45:58 <mburns> and i don't see him online
14:46:13 <mburns> any comments from anyone on oVirt / Quantum integration?
14:46:57 <mburns> #info requester is not available, deferring the topic
14:47:02 <mburns> #topic Other Topics
14:47:08 <mburns> does anyone have anything else to bring up?
14:47:52 <mburns> going once...
14:48:21 <mburns> twice..
14:48:44 <mburns> gone
14:48:45 <mburns> #info No other topics to discuss
14:48:49 <mburns> Thanks all
14:48:51 <oschreib> sold to the lady in red!
14:48:53 <mburns> #endmeeting