14:00:42 <mburns> #startmeeting oVirt Weekly Sync
14:00:42 <ovirtbot> Meeting started Wed Jun 20 14:00:42 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:46 <mburns> #chair oschreib
14:00:46 <ovirtbot> Current chairs: mburns oschreib
14:01:06 <ykaul> me here
14:01:13 <mburns> #agenda and roll call
14:01:16 <mburns> #topic agenda and roll call
14:01:21 * lh is here
14:01:29 * oschreib is here once again
14:01:42 * Guest571 is here
14:01:48 * rharper is here
14:01:59 * mkolesni_ is here
14:02:06 <mburns> Status of Next Release
14:02:06 <mburns> Sub-project reports (engine, vdsm, node)
14:02:07 <mburns> Upcoming workshops
14:02:07 <mburns> Test Day Post-Mortem
14:02:31 <quaid> heh, 'mortem'
14:02:33 * ofrenkel here
14:02:48 <dneary> Hi all
14:03:13 * masayag here
14:03:29 <mkolesni> hi
14:04:16 <mburns> #topic Status of next release
14:04:23 <mburns> oschreib: the floor is yours
14:04:27 * itamar here
14:04:36 <oschreib> OK, many things to discuses
14:04:55 <oschreib> current GA is the 27th (next week)
14:04:57 * RobertM here
14:05:20 <oschreib> I'm afraid we won't be ready.
14:05:26 * sgordon is late
14:05:29 <sgordon> (situation normal)
14:05:35 <miki> here
14:05:44 * mgoldboi here
14:05:55 <oschreib> currently we have 9 bugs in the 3.1 release tracker
14:06:12 <oschreib> #info 9 bugs in 3.1 release tracker
14:06:16 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=822145
14:06:22 <mburns> #info current targeted GA is 27-June
14:06:51 <oschreib> I suggest voting about delaying the GA after we will review blockers.
14:07:21 <oschreib> or to do a release meeting at Monday
14:07:48 <oschreib> two notes before that:
14:08:06 <oschreib> 1. A new build has been uploaded to ovirt.org, with a fix to create template
14:08:24 <oschreib> 2. I didn't branch ovirt-engine yet, waiting for tonight probably
14:08:42 <ilvovsky> here
14:08:49 <mburns> note:  that's new engine build
14:08:54 <mburns> oschreib: does it include vdsm?
14:08:58 <mburns> i know it doesn't have node
14:09:10 <oschreib> mburns: no vdsm yet
14:09:20 <mburns> ok
14:09:23 <sgordon> can we get the link to the updated build(s) for the minutes
14:09:30 <sgordon> to ensure people are testing the right ones
14:09:47 <oschreib> I'll issue a mail later
14:10:03 <oschreib> http://www.ovirt.org/releases/beta/fedora/17/
14:10:29 <oschreib> ovirt-engine-3.1.0-0.1.20120620git6ef9f8.fc17.noarch.rpm
14:10:34 <mburns> #link http://www.ovirt.org/releases/beta/fedora/17/
14:10:58 <oschreib> #info new beta build (3.1.0-0.1.20120620git6ef9f8.fc17) available
14:11:01 <oschreib> ok
14:11:07 <oschreib> lets review blockers
14:11:36 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=828633
14:11:57 <oschreib> #info libvirt - Sanlock locking failed for readonly devices (MODIFIED)
14:12:00 <RobertM> Will those update show in a yum upgrade?  Or will someone have to un-install ovirt-enginue and reinstall?
14:12:20 <oschreib> RobertM: since we're in beta, I suggest a clean install for now
14:12:36 <oschreib> RobertM: specially, since we change the versioning schema
14:12:51 <oschreib> fsimonce: any updates on the bug above?
14:13:14 <mburns> oschreib: RobertM:  don't we require users to run engine-upgrade?
14:13:19 <fsimonce> oschreib, the branch has been just created I need to review/merge them and build the package
14:13:31 <rharper> oschreib: is an engine-cleanup good enough after yum update? or are you suggesting yum erase ?
14:13:38 <mburns> so yum update doesn't actually do the update?
14:13:46 <oschreib> wait guys
14:13:53 <ilvovsky> fsimonce: please wait for network patches
14:13:59 <oschreib> the right way is to use engine-upgrade to upgrade
14:14:03 <oschreib> but that won't work
14:14:10 <fsimonce> ilvovsky, yeah sorry I was just going to say that :)
14:14:14 <oschreib> just use engine cleanup, yum remove and yum install
14:14:26 <oschreib> lets get back to that issue after the blockers please
14:14:29 <rharper> ok
14:14:43 <yzaslavs> here
14:14:53 <oschreib> fsimonce: I'm asking about https://bugzilla.redhat.com/show_bug.cgi?id=828633
14:16:12 <fsimonce> oschreib, ah sorry I didn't see it... well the discussion is there, I'm waiting for an answer (I pinged danpb several hours ago about that)
14:17:49 <oschreib> fsimonce: so why it's MODIFIED?
14:19:24 <fsimonce> oschreib, that bug is assigned to libvirt... why are you looking there? we should have our own bug
14:19:51 <oschreib> fsimonce: no reason for our own bug, if the libvirt bug is the one which blocks us
14:21:28 <fsimonce> oschreib, the proposed fix is not just requiring a new libvirt, it's adding a change and it has a -1 on gerrit, so whatever status has the libvirt bug doesn't count for us
14:22:04 <oschreib> fsimonce: if we have our own fix about it - so we need our own bug
14:22:10 <oschreib> fsimonce: can you please open one?
14:22:34 <fsimonce> oschreib, I'm saying that it's not our bug... I'd hardly open it :)
14:23:03 <oschreib> fsimonce: again, this issue (can run vm with CD) blocks 3.1 release
14:23:10 <oschreib> iiuc
14:23:17 <oschreib> correct me if I'm wrong
14:24:43 <mburns> oschreib: so we're just waiting on libvirt build to hit fedora repos?
14:25:01 <oschreib> mburns: that's what I'm trying to understand from fsimonce
14:25:01 <fsimonce> oschreib, mburns, we're waiting for danpb's answer
14:25:09 <oschreib> ok
14:25:17 <oschreib> #info waiting on danpb
14:25:17 <mburns> READ10: DV:  anything you can do to help that along?
14:25:34 <mburns> https://bugzilla.redhat.com/show_bug.cgi?id=828633
14:26:12 <mburns> oschreib: ok, let's move on...
14:26:16 <oschreib> yes
14:26:21 <mburns> we can revisit later in the meeting if we get more info
14:26:32 <READ10> mburns: I'm on the phone atm
14:26:37 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=831998
14:26:44 <mburns> READ10: ok
14:26:58 <oschreib> #info VDSM - It's impossible to create bond with setupNetworks (ASSIGNED)
14:27:11 <oschreib> fsimonce: ilvovsky what's the status on this?
14:28:15 <ilvovsky> oschreib: working on it
14:28:29 <oschreib> ilvovsky: time estimation?
14:29:45 <oschreib> #info WIP
14:30:15 <ilvovsky> oschreib: hmmm, I am in PTO tomorrow,so I suppose beginning of the next week
14:30:19 <danken> ilvovsky: for some reason https://bugzilla.redhat.com/show_bug.cgi?id=831998 does not have a link to the gerrit patch
14:30:40 <oschreib> ilvovsky: ok
14:30:45 <oschreib> next issue
14:30:58 <ilvovsky> danken: yep, I'll add it
14:31:02 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832199
14:31:21 <oschreib> #info VDSM - vdsmd init script times out due to lengthy semanage operation (ASSIGNED)
14:31:47 <oschreib> ilvovsky: fsimonce: dougsland - any updates on this once?
14:31:50 <oschreib> one*
14:33:39 <danken> is Adam around, to shed some light?
14:34:33 <oschreib> ok, no updates here
14:34:39 <danken> we do not know why it takes soooo long to semanage on some cases.
14:34:55 <oschreib> danken: is it just a corner case?
14:35:08 <sgordon> how long is the timeout?
14:35:19 <danken> oschreib: no. it reproduces to Adam quite often, I believe
14:35:31 <oschreib> ok
14:35:39 <oschreib> #info WIP
14:35:59 <danken> sgordon: two minutes or so, see the bug for details
14:36:08 <oschreib> next issue (I don't think we have enough time for a long discussion about every bug, sorry)
14:36:19 <danken> I have no idea if we can ask systemd to be less brutal with us.
14:36:43 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832517
14:36:58 <oschreib> #info node - sshd daemon is not starting correctly after complete the installation of oVirt Node (NEW)
14:37:02 <oschreib> mburns: updates?
14:37:13 <mburns> oschreib: wip
14:37:21 <oschreib> time estimation?
14:37:24 <mburns> hopefully have something in the next day or so
14:37:42 <oschreib> #info WIP, fix to be push in the next couple of days
14:37:55 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832539
14:38:06 <oschreib> #info node - iptables blocking communication between node and engine (POST)
14:38:09 <oschreib> mburns: same?
14:38:26 <mburns> oschreib: being reviewed, but will be included in next build
14:38:46 <oschreib> #info in review, should be in next build
14:38:56 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832577
14:39:15 <oschreib> #info vdsm - ovirt-node can't be approved due to missing /rhev/data-center (POST)
14:39:30 <oschreib> danken: ilvovsky: any updates/time estimation ?
14:40:08 <danken> pushed upstream, need to rebase to ovirt-3.1 branch
14:40:29 <oschreib> #info pushed upstream, need to rebase to ovirt-3.1 branch
14:40:39 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=833201
14:40:48 <danken> correction: still waiting Verification upstream.
14:41:09 <oschreib> #info vdsm - Failed to add host - does not accept vdsm 4.10 (POST)
14:41:10 <danken> douglas, please tick http://gerrit.ovirt.org/#/c/5379/
14:41:26 <danken> pushed to ovirt-3.1 branch few seconds ago
14:42:34 <oschreib> ok, I'll appreciate a build including it. otherwise, host installation is broken
14:42:42 <oschreib> #info pushed
14:43:29 <oschreib> ok
14:43:36 <oschreib> that took a while
14:44:04 <oschreib> what do we say about the GA date? postpone it now, or schedule a meeting on Monday?
14:44:23 <mburns> given the number of issues that are still pending, i think we need to postpone a week
14:45:12 <oschreib> +1 from me
14:45:14 <RobertM> I personally think you need beta rpm's out for a lest a week with out major issues.  So it need to be posponded at least a week.
14:46:12 <danken> #action douglas please push http://gerrit.ovirt.org/#/c/5379/ upstream and to ovirt-3.1
14:47:01 <oschreib> danken: I'm not sure you can add actions
14:47:13 <itamar> I'm fine with postponing, but lets make sure we have a fresher set of rpms to get feedback on with the current issues resolved by next week
14:47:31 <oschreib> itamar: we have new engine rpms up
14:47:40 <danken> oschreib: o irc master, pardon my foolishness
14:47:42 <oschreib> itamar: bug without a working vdsm it might be problematic
14:47:52 <oschreib> #action douglas please push http://gerrit.ovirt.org/#/c/5379/ upstream and to ovirt-3.1
14:48:20 <itamar> yes, need a working vdsm, and preferably, node as well (and libvirt/sanlock playing along, which seems to be ok by now iiuc)
14:48:36 <oschreib> ok, sounds like an agreement
14:48:37 <danken> mburns: I suppose you can help with http://gerrit.ovirt.org/#/c/5379/ , too
14:49:05 <mburns> danken: yes, but i need at least scratch rpms to include in a build
14:49:09 <yzaslavs> jhernand:  ping
14:49:33 <oschreib> ok
14:49:38 <oschreib> 5th of July?
14:49:40 <danken> mburns: please ask douglas to as koji to do it ;-)
14:49:43 <ilvovsky> oschreib: do we have pending storage issues in vdsm?
14:49:56 <oschreib> ilvovsky: not that I know of.
14:50:10 <ykaul> oschreib: 5th of July is Thursday, I much rather release on Monday.
14:50:13 <danken> fsimonce: is there something? ^^^
14:50:40 <mburns> perhaps go/no go on 5-July
14:50:47 <mburns> and then release on 9-July?
14:51:04 <ykaul> mburns: if it's a go, you can release right away, no?
14:51:25 <mburns> ykaul: should be able to, but you don't want to release on thursday...
14:52:03 <fsimonce> danken, is there something where/what?
14:52:05 <ykaul> mburns: I prefer release when we have a full week ahead of us to handle urgent issues, that's all.
14:52:14 <mburns> ykaul: understood, and i agree
14:52:14 <oschreib> lets schedule the GA for the 9th
14:52:21 <oschreib> and talk about the go/no go next week
14:52:24 <mburns> you think we should have go/no go on the 9th?
14:52:49 <mburns> ok, we can discuss go/no-go next week
14:53:09 <mburns> oschreib: fyi -- i won't be online for this meeting next week most likely
14:53:14 * mburns will be at Summit
14:53:29 <oschreib> np
14:53:58 <oschreib> #agreed GA will be postponed to the 9th of July
14:54:19 <oschreib> and of-course, we will have a go/no-go meeting before that
14:54:30 <oschreib> anything else release wise?
14:54:35 <mburns> ack
14:54:44 <mburns> nothing from me
14:55:51 <mburns> ok, moving on quickly
14:56:00 <mburns> no need for sub-project reports i don't think
14:56:06 <oschreib> indeed
14:56:08 <mburns> #upcoming workshops
14:56:11 <mburns> #topic upcoming workshops
14:56:18 <mburns> lh: anything to report here?
14:56:43 <lh> We've collected feedback from the workshop at LC Japan, detailed here http://www.ovirt.org/wiki/LC_Japan_Workshop_Post-Mortem
14:57:06 <lh> Based on that feedback, I believe we're ready to being planning the agenda and speakers for the workshop at LinuxCon North America
14:57:35 <lh> I'd like to solicit help from the community to get more instructors for the workshop, as well as help updating the presentations.
14:57:50 <mburns> #info feedback from LC Japan
14:57:56 <mburns> #link http://www.ovirt.org/wiki/LC_Japan_Workshop_Post-Mortem
14:58:09 <lh> Other than these items, nothing new to report.
14:58:34 <mburns> #info time to begin planning for LC North America (San Diego, Aug 29-31)
14:59:11 <mburns> lh: did you see ping requesting an oVirt presentation at linux.conf.au ?
15:00:07 <mburns> lh: probably best to solicit help via mailing list
15:00:12 <lh> mburns, yes.
15:00:43 <lh> mburns, it appears at least two papers will be submitted to the CFP from Red Hat folk, and it would be wonderful to get even more submissions
15:01:16 <mburns> #info linux.conf.au has reached out requesting oVirt related presentations
15:01:24 <lh> mburns, sure
15:01:51 <lh> acathrow, can you help with that? iirc you're working on the CFP for linux.conf.au
15:02:14 <dneary> I noticed that for LC North America the Gluster & oVirt sub-events are the only ones without a website up at this point.
15:02:37 <dneary> Is there any information we can send on the LF right now to place-hold?
15:02:43 <lh> dneary, correct, that's because we need to provide an agenda and speakers.
15:03:01 <dneary> https://events.linuxfoundation.org/events/linuxcon/co-located-events
15:03:02 <lh> dneary, we could send along our existing agenda from the last workshop if folks agree that's how we should proceed.
15:03:07 <mburns> lh: can we send equivalent agenda to LC Japan as a place-holder?
15:03:13 <mburns> with speakers TBD
15:03:19 <lh> mburns, certainly ^^
15:03:27 <dneary> lh: They may be happy with a "scope of event" page
15:03:29 <mburns> and we can tweak later if we change the format
15:03:35 <dneary> Indeed, with speakers TBD
15:04:03 <lh> I'll take care of sending along the agenda with speakers TBD
15:04:23 <mburns> #info lh to send agenda to LinuxCon North America
15:04:37 <mburns> ok, anything else here?
15:04:43 <lh> mburns, nothing from me, thanks
15:04:52 <mburns> #topic other topics
15:05:01 <mburns> any other topics to bring up?
15:05:17 <quaid> dneary: did you want to talk about anything Infra related?
15:05:19 <mburns> final agenda topic (test day post-mortem was mostly covered in the release status)
15:05:32 <sgordon> i'll send an email about release notes in the next day or so
15:05:38 <sgordon> just note it as an action item for me
15:05:50 <mburns> #action sgordon to send email about release notes
15:06:00 <mburns> sgordon: you should be able to #action yourself...
15:06:16 <quaid> what's up with me is that I'm totally on board with getting Infra to act like a proper sub-project, and I'm happy to lead that effort right now - mainly to make it easier for others to help make our infra better
15:06:41 <quaid> I just need to get active on infra@ with all the topics :)
15:07:00 <sgordon> oh i thought a chair had to do it
15:07:10 <dneary> quaid, mburns: I suspected that infra would come up after last week
15:07:29 <quaid> no prob, I walked out of the meeting last week & didn't notice infra was on the agenda
15:07:34 <dneary> quaid, We spoke about it, but couldn't really make any progress since you'd dropped off channel by then
15:07:43 <dneary> It was brought up in AOB :)
15:07:51 <dneary> (we should make that a tradition)
15:07:56 <quaid> heh
15:08:14 * quaid is open for discussion now or can meet folks on infra@
15:08:54 <mburns> quaid: i think infra@ makes more sense
15:09:07 <mburns> other than to get acks for making infra a true sub-project
15:09:12 <mburns> ack from me...
15:09:37 <mburns> quaid: maybe setup a separate irc meeting to discuss infra related topics?
15:11:40 <dneary> mburns, quaid: As I recall, that's what we said last week too
15:11:55 <dneary> So let's make sure we get movement on that this week
15:11:58 <mburns> yes, but no one actually took it to the list
15:12:05 <dneary> Who from ovirt will be in Boston next week?
15:12:17 * mburns will be there
15:12:21 <dneary> mburns, I'll make sure it gets taken to the list this time.
15:12:25 <mburns> dneary: ok
15:12:46 <dneary> #action dneary to ensure that discussion starts on infra@ on the creation of a community infrastructure team
15:12:58 <dneary> Damn. Didn't work
15:13:03 <dneary> My meetbot karma is low
15:13:09 <mburns> #action dneary to ensure that discussion starts on infra@ on the creation of a community infrastructure team
15:13:29 <mburns> ok, anything else to discuss?
15:14:17 <mburns> going once...
15:14:36 <mburns> twice..
15:14:50 <dneary> mburns, Thanks! See you on infra@
15:15:02 <mburns> gone.
15:15:05 <mburns> thanks all!
15:15:08 <mburns> #endmeeting