14:00:22 <mburns> #startmeeting oVirt Weekly Meeting
14:00:22 <ovirtbot> Meeting started Wed Aug  1 14:00:22 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:27 <mburns> #topic agenda and roll call
14:00:53 * oschreib here
14:00:59 <mburns> agenda:  Status of Next Release
14:00:59 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:00:59 <mburns> Upcoming workshops
14:01:12 * RobertM here
14:01:18 * lh is here
14:01:22 <mburns> lh: if you want, we can start with workshops today so you don't need to pay attention to the rest
14:01:43 * rickyh here
14:01:46 <lh> mburns, it's no trouble either way. besides, i enjoy watching the go/no go process
14:01:49 * dustins here
14:01:55 <lh> mburns, but thank you, i appreciate you checking.
14:02:06 * dougsland here
14:02:20 <mburns> lh: makes sense to do it first, then take the rest of the time to discuss release issues
14:02:26 <lh> mburns, works for me
14:02:32 <mburns> #topic Upcoming Workshops
14:02:35 <mburns> lh: all you
14:02:40 <lh> Thank you.
14:02:48 * sgordon is here, belatedly
14:03:19 <lh> Next workshop is LinuxCon North America, please make sure you've registered for the conference because they're getting rather full. (Also co-located with Plumbers and Cloud Open).
14:03:19 <sgordon> anyone having issues with gerrit.ovirt.org
14:03:35 <lh> http://events.linuxfoundation.org/events/linuxcon/
14:04:03 <RobertM> sgordon, Outside my latest patch not yet being reviewed no.
14:04:19 <lh> We've decided a CFP for Bangalore workshop at Red Hat on 16 October is too heavy weight given KVM Forum + oVirt two weeks later, so we're just going to discuss on the mailing list. (users@)
14:04:24 * ofrenkel here
14:04:49 <lh> A few folks from the KVM Forum program committee are working with the oVirt team to create a CFP for the KVM Forum + oVirt workshop at LinuxCon Europe
14:05:00 <mburns> #info next workshop:  LC North America in August -- please register soon, it's getting full
14:05:01 <lh> That will be sent out to the oVirt lists and advertised elsewhere.
14:05:11 <mburns> #chair oschreib
14:05:11 <ovirtbot> Current chairs: mburns oschreib
14:05:29 * ovedo here
14:05:34 <dougsland> #chair dougsland
14:05:41 <lh> As always, you can find information on upcoming workshops here: http://wiki.ovirt.org/wiki/OVirt_Global_Workshops
14:05:42 <mburns> #info CFP for Bangalore workshop is going to be done just over email on users@
14:06:09 <mburns> #info KVM Forum committee is working with oVirt team to do CFP for LC Europe
14:06:18 <mburns> #link Status of Next Release
14:06:18 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:06:18 <mburns> Upcoming workshops
14:06:19 <lh> And as mentioned on the Board lists we are looking for more sponsors for the LCNA and KVM Forum + oVirt workshops; folks can feel free to ping me with questions.
14:06:24 <mburns> #undo
14:06:24 <ovirtbot> Removing item from minutes: <MeetBot.items.Link object at 0x8e6364c>
14:06:26 <lh> mburns, that's all I have
14:06:37 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_Global_Workshops
14:06:58 <mburns> #info still looking for sponsors for LCNA and KVM Forum+oVirt Workshop
14:07:12 <mburns> #info please contact lh if interested
14:07:20 <mburns> lh: thanks
14:07:24 <lh> mburns, my pleasure
14:07:39 <mburns> #topic Release Status
14:07:42 <mburns> oschreib: you're up
14:07:49 <oschreib> cool
14:07:49 <mburns> dougsland: you can't chair yourself
14:07:56 <mburns> #chair dougsland
14:07:56 <ovirtbot> Current chairs: dougsland mburns oschreib
14:08:00 <dougsland> mburns, ah ok :-P
14:08:01 <dougsland> thanks!
14:08:01 * jb_netapp here
14:08:43 <oschreib> Only one blocker left
14:08:59 <oschreib> https://bugzilla.redhat.com/show_bug.cgi?id=842948
14:09:15 <oschreib> #info One blocker left for 3.1
14:09:22 <oschreib> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=822145&hide_resolved=1
14:09:39 <oschreib> dougsland: please move vdsm bugs there to ON_QA or closed
14:09:48 <dougsland> oschreib, sure
14:10:01 <oschreib> #action dougsland to move vdsm bugs to ON_QA/CLOSED
14:10:03 <dougsland> oschreib, done
14:10:35 <oschreib> #info oVirt 3.1 - breth0 still available after registration and manual reboot (VDSM, POST)
14:10:42 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=842948
14:10:49 <oschreib> dougsland: what's the status here?
14:10:49 <dougsland> oschreib, btw, I see that Federico already did the commit into vdsm fedora repo
14:11:02 <dougsland> oschreib, it's merged and federico already did the commit into the fedora repo
14:11:18 <oschreib> oh, you changed it :)
14:11:27 <oschreib> dougsland: do we have a new fedora build?
14:11:38 <dougsland> fsimonce, ^ ?
14:11:50 <oschreib> I see it
14:11:51 <oschreib> vdsm-4.10.0-6.fc17
14:12:01 <fsimonce> yes
14:12:03 <oschreib> #info bug is CLOSED, vdsm-4.10.0-6.fc17 available
14:12:18 <oschreib> ok, sounds like we're covered from the blockers area
14:12:36 <oschreib> and I have some cool update - I've uploded a new engine yesteday
14:12:45 <oschreib> which should fix the upgrade issue
14:12:58 <oschreib> http://wiki.ovirt.org/wiki/OVirt_3.0_to_3.1_upgrade
14:13:02 <mburns> #action to build new ovirt-node with updated vdsm
14:13:45 <oschreib> sgordon: ^^
14:15:03 <ovirtbot> 14[[07OVirt 3.0 to 3.1 upgrade14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4014&oldid=4008&rcid=4110 5* 03Oschreib 5* (+104) 10/* Upgrade Instructions */ 
14:15:13 <mburns> oschreib: so all blockers are fixed, just need new ovirt-node builds with new vdsm
14:15:24 <mburns> then a couple days for testing, then push live
14:16:00 <oschreib> should we do the push before next week's meeting?
14:16:13 <mburns> #info upgrade should be working with latest 3.1 build
14:16:18 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_3.0_to_3.1_upgrade
14:16:26 <mburns> oschreib: maybe have go/no-go on Monday?
14:16:37 <mburns> sgordon: where are we with docs/release notes?
14:17:03 <sgordon> http://wiki.ovirt.org/wiki/OVirt_3.1_release_notes
14:17:19 <sgordon> still some to work through but not to many
14:17:23 <oschreib> mburns: +1 on the go/no go on monday.
14:17:32 <sgordon> i need to flesh out upgrade instructions based on the link oschreib just pasted
14:17:44 <mburns> oschreib: can you send a meeting request for monday?
14:17:47 <oschreib> mburns: can you please build node, and send some sort of announce about the engine as well?
14:17:52 <oschreib> mburns: np
14:18:08 <mburns> oschreib: yes, i'll get node built today, and send notice about latest RC builds
14:18:35 <oschreib> sgordon: I'd like to get some input about my upgrade page
14:19:14 <sgordon> oschreib, do they need to re-add hosts after running engine-setup
14:19:18 <sgordon> or will they be kept?
14:19:26 <oschreib> should be kept
14:20:09 <mburns> fabiand: can you update http://wiki.ovirt.org/wiki/OVirt_3.0_to_3.1_upgrade with quick-start install instructions for ovirt-node?
14:20:52 <oschreib> I'm still want to advise users to do a clean install :)
14:21:32 <RobertM> Are there instructions someplace on exporting and importanting VM's?
14:22:04 <oschreib> no really
14:22:46 <fabiand_> mburns, yep
14:23:08 <sgordon> i think intent of oschreib's method is that they shouldn't need to export / import the VM's, right?
14:23:20 <sgordon> though of course exporting anything important first would be good practice
14:23:30 <RobertM> Then suggesting users export and then import there VM isn't really useful then?
14:23:57 <mburns> #action fabiand_ to update install instructions for ovirt-node
14:24:03 <oschreib> RobertM: the export/import is really easy
14:24:05 <sgordon> RobertM, i dont think we do in http://wiki.ovirt.org/wiki/OVirt_3.0_to_3.1_upgrade ?
14:24:13 <sgordon> oh wait
14:24:22 <sgordon> up the top when talking about clean install
14:24:30 <oschreib> RobertM: create export domain, export vm/template, detach export domainm
14:24:30 <sgordon> im only talking about the upgrade path
14:26:33 <oschreib> I'm only saying:
14:26:34 <oschreib> 1. We have an upgrade path (that should be checked)
14:26:34 <oschreib> 2. We should advise users to do a clean install with an export domain (and some  other sort of backup)
14:26:34 <oschreib> 3. We can create documentation about export, I'm not sure how much info will be there.
14:27:52 <oschreib> ?
14:28:04 <sgordon> i would say minimal
14:28:13 <sgordon> in a pinch i will link to the existing docs.redhat.com material
14:28:21 <sgordon> and/or push it into the wiki
14:29:00 <oschreib> fine by me
14:29:09 <mburns> ok, so that should cover upgrade documentation
14:29:22 <oschreib> #action oschreib to send the release go/no go meeting
14:29:42 <mburns> what about other release communication information?
14:29:55 <oschreib> the announce is almost done
14:29:56 <mburns> the announcement email...
14:30:05 <oschreib> http://openetherpad.org/ovirt-3-1
14:30:06 <mburns> excellent
14:30:16 <mburns> #link http://openetherpad.org/ovirt-3-1
14:30:23 <mburns> #info announcement email^^
14:31:08 <mburns> anything else we need for the release?
14:31:20 <mburns> what about screencasts?
14:31:26 <mburns> RobertM: were you working on those?
14:31:37 <oschreib> jbrooks is not here today
14:33:13 <mburns> ok, anything else we need to cover?
14:33:25 <oschreib> nope
14:33:31 <mburns> ok
14:33:39 <mburns> #topic sub-project status
14:33:44 <mburns> #topic sub-project status (infra)
14:34:00 <mburns> RobertM: eedri:  do you want to summarize infra status?
14:35:06 <mburns> ok, guess not
14:35:12 <mburns> quick summary:
14:35:13 <eedri> sure
14:35:18 <eedri> sorry, was away
14:35:20 <mburns> ahh, ok...
14:35:50 <eedri> rpms sync also done, tbd: script to publish rpms on official ovirt.org/releases
14:35:58 <eedri> also/almost
14:36:37 <eedri> new option for adding headless jenkins slaves, tbd: wiki with instructions
14:36:57 <eedri> new staging jenkins.ovirt.info server, for backup & tests
14:37:35 <eedri> finalizing method for running jenkins jobs per gerrit patch (i.e security concens)
14:38:00 <eedri> and finally, moving jenkins from EC2 to a different hosting provider is also on the table
14:38:15 <mburns> #info rpm sync to nightly releases directory almost done
14:38:21 <RobertM> Jenkins now using the latest LTS release.
14:38:29 <mburns> #info new option for adding headless jenkins slaves coming soon
14:38:53 <mburns> #info jenkins backup and staging server setup jenkins.ovirt.info
14:39:29 <mburns> #info finalizing decision on running gerrit patches automatically in jenkins (security concerns)
14:39:42 <mburns> #info also investigating moving jenkins master out of EC2
14:39:53 <mburns> #jenkins upgraded to latest LTS release
14:40:07 <mburns> anything else?
14:40:49 <eedri> not that i recall, RobertM ?
14:41:12 <RobertM> Nothing else right now.
14:41:34 <mburns> ok, thanks
14:41:37 <mburns> #topic other topics
14:41:43 <mburns> anyone have anything else to bring up?
14:44:21 <oschreib> yes
14:44:59 <oschreib> I'm going to take a long vacation after the 3.1 release (well, I hope we wont' delay it anymore)
14:45:24 <oschreib> I'll need a replacement for 8 weeks (mostly devel phase, not a lot to do)
14:46:26 <mburns> it's probably worth having a second person anyway who knows what you do and how you do it
14:47:05 <mburns> anyone have nominations for a second release manager?
14:47:11 <mburns> or backup release manager?
14:48:12 <mburns> or perhaps volunteers?
14:48:32 * mburns thinks the silence is deafening...
14:49:20 * mburns can do most of the job if necessary, but my time is pretty tight in general...
14:49:35 * mburns thinks we can defer this decision until next week
14:49:36 <oschreib> I'll send an email about it
14:49:41 <oschreib> indeed
14:49:51 <mburns> ok, if nothing else, then we can end the meeting
14:50:13 <mburns> thanks all
14:50:15 <mburns> #endmeeting