15:06:09 <quaid> #startmeeting Infra team weekly
15:06:09 <ovirtbot> Meeting started Mon Dec 17 15:06:09 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:09 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:22 <quaid> #chair dneary eedri_
15:06:22 <ovirtbot> Current chairs: dneary eedri_ quaid
15:08:04 <quaid> #topic Agenda
15:08:14 <quaid> http://www.ovirt.org/Infrastructure_team_meetings#2012-12-17
15:08:33 <quaid> ''Agenda''
15:08:33 <quaid> * How to add new Infra admin members (if not resolved on list)
15:08:33 <quaid> * IRC bot
15:08:33 <quaid> * Hosting
15:08:33 <quaid> * Puppet
15:08:35 <quaid> * Jenkins
15:08:38 <quaid> * Gerrit
15:08:40 <quaid> * Other business?
15:08:43 <quaid> * Trac review
15:09:48 <quaid> ok, I'll just run through this, see where we go
15:09:54 <quaid> #topic Adding new team members
15:10:09 <quaid> looks like I failed to restart that topic last week
15:10:17 <quaid> I'm writing up an email right now
15:10:31 <dcaro|away> good :)
15:11:00 <dneary> IRC bot - we can skip this week. No news, I think
15:11:42 * ewoud here
15:13:24 * eedri_ here
15:13:41 <quaid> ok, howdy
15:13:43 <quaid> email sent
15:13:51 <quaid> #info email sent this week, discussion on list
15:13:59 <quaid> #topic IRC Bot
15:14:17 <quaid> #info no changes since last week, I wasn't able to work on this one
15:14:21 <quaid> do we have a ticket for this?
15:14:31 <dneary> Yup
15:14:36 <dneary> I think it's 15 from memory
15:14:48 <ewoud> Rydekull suggested to use another port than 6667
15:15:04 <ewoud> is only 6667 open or is outgoing blocked?
15:15:19 <quaid> yeah, we can use this one:
15:15:21 <quaid> https://fedorahosted.org/ovirt/ticket/19
15:15:27 <dneary> I was told there's a limitation with OpenShift and accessing "suspicious" ports like 6667
15:15:38 <quaid> right
15:15:48 <dneary> bbias
15:15:57 <quaid> we just need to configure a few locations to use an acceptable port, I think
15:16:00 <ewoud> why not use another? freenode has others
15:16:07 <quaid> #info working the issue on that ticket (now)
15:16:07 <ewoud> All freenode servers listen on ports 6665, 6666, 6667, 6697 (SSL only), 7000 (SSL only), 7070 (SSL only), 8000, 8001 and 8002. Please be aware that the below list is at no time authoritative, and as such our advice is to connect using chat.freenode.net.
15:16:11 <ewoud> https://freenode.net/irc_servers.shtml
15:17:09 <quaid> yeah, I think the problem is getting the data out of the mediawiki instance on a port that the bot is watching
15:17:22 <mburns`> eedri_: pong
15:17:26 <quaid> Rydekull found the spot in the bot code where the port is set
15:17:31 <dneary> quaid, I'll have a look at it after Christmas
15:17:34 <quaid> $info Rydekull found the spot in the bot code where the port is set
15:17:40 <dneary> It's not a high priority item, I think
15:17:43 <quaid> ok, moving along
15:17:46 <dneary> (unlike the next one ;-)
15:18:02 <ewoud> quaid: s/$info/#info
15:18:09 <quaid> #action quaid to update the ticket with all the info we know so far
15:18:16 <quaid> #info Rydekull found the spot in the bot code where the port is set
15:18:17 <eedri_> mburns`, just wanted to ask on rpms put in the 3.2/alpha dir, seems there were lot of versions that that hogged linode
15:18:18 <quaid> thx
15:18:31 <quaid> #topic Hosting
15:18:39 <mburns`> eedri_: i'll look
15:18:58 <dneary> Alter Way - Kévin's back on the case after a busy spell, and he just needs to know what OS we want on our server
15:19:30 <eedri_> dneary, i think centos 6.3 will be fine...
15:19:33 <dneary> #info Kévin Mazière got back to us, and asked what operating system we want on the server. RHEL is OK, but we need to supply a license
15:19:34 <quaid> +1
15:19:43 <quaid> yay, info!
15:19:45 <dneary> #agreed CentOS 6.3
15:19:48 <eedri_> rhel 6.3 is preffarable of coursed
15:19:56 <eedri_> but if we don't have lic, then centos
15:20:06 <quaid> eedri_: actually, I think CentOS might be preferable, too :)
15:20:15 <dneary> quaid, IIRC, you took xcare of license provisioning for old servers, yes?
15:20:17 <eedri_> quaid, sure :)
15:20:18 <quaid> it's the common platform for the oVirt users, right?
15:20:29 <quaid> dneary: Linode runs CentOS
15:20:31 <eedri_> quaid, isn't that fedora?
15:20:32 <dneary> Ah
15:20:39 <dneary> Then let's not lose sleep over it.
15:20:44 <dneary> CentOS 6.3 it is
15:20:50 <ewoud> +1
15:21:13 <quaid> eedri_: not really, people seem to prefer CentOS over Fedora for infrastructure deployments
15:21:23 <quaid> fine with me, all-in-the-family
15:21:31 <eedri_> +1 for centos 6.3
15:22:03 <quaid> #info I have no news about RackSpace account
15:22:16 <quaid> #action quaid to track down and make progress on the RackSpace situation, too
15:22:30 <quaid> do we want to talk about moving Mailman before Jenkins?
15:22:41 <quaid> it will be an easier migration, and getting it off the too-full server ...
15:22:55 <quaid> anyway, we can discuss that on list
15:23:06 <eedri_> don't see why it needs to wait to jenkins migration..
15:23:10 <quaid> #idea maybe moved Mailman first so it's off the too-full server
15:23:14 <quaid> #undo
15:23:14 <ovirtbot> Removing item from minutes: <MeetBot.items.Idea object at 0x8dc5a8c>
15:23:18 <quaid> #idea maybe move Mailman first so it's off the too-full server
15:23:57 <ewoud> I think that should work
15:24:22 <ewoud> eedri_: I think the original reason we wanted to wait was to see if it worked as expected
15:24:49 <ewoud> but given we're running into limits with linode it might be better to speed it up
15:24:52 <quaid> ok, we can resolve that as part of the design discussion
15:25:51 <quaid> ah-ha - which didn't get started yet
15:26:13 <quaid> I think we got stuck on Jenkins
15:26:45 <quaid> #action quaid to kickoff discussion about new infra network design
15:27:12 <quaid> #undo
15:27:12 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x8f4e2cc>
15:27:20 <quaid> #action quaid to kickoff discussion about new infra hosting design
15:27:23 <quaid> ok, anything else here?
15:27:57 <ewoud> maybe we should plan a hacking session where we work together on IRC to implement this?
15:28:38 * ewoud has a week vacation next week
15:29:03 <quaid> ooh, interesting
15:29:31 <quaid> #idea Infra sprint - hacking session on IRC to implement new hosting
15:29:58 <ewoud> there's christmas but for me that's nothing else than dinner with family so I have the days open
15:30:10 <quaid> I might be better a bit later in the week next week, I'm travelling around a bit during my bacation
15:30:23 <vfeenstr> btw who is responsible for accounts on gerrit?
15:30:24 <quaid> 26th might work
15:30:40 <quaid> vfeenstr: Itamar, primarily
15:30:40 <ewoud> quaid: mailing list?
15:30:49 <vfeenstr> quaid: itamar?
15:30:51 <quaid> eedri_: can you make gerrit accounts?
15:30:52 <vfeenstr> really
15:30:59 * vfeenstr needs to get one removed
15:31:10 <vfeenstr> I have one there from my time before RH
15:31:13 <quaid> vfeenstr: yeah, we need to do some knowledge sharing so the rest of Infra can help with gerrit
15:31:24 <quaid> vfeenstr: oh, can't combine them?
15:31:28 <vfeenstr> not sure
15:31:33 <dcaro|away> mmm, I won't be online until 28 at least
15:32:06 <quaid> dcaro|away: yeah, my travel will be weird for all of that, but I'll be home by the 29th and in a better position then
15:32:20 <quaid> so we might want to wait until closer to the New Year to get more people available
15:32:25 <ewoud> we don't have to set it up all at once, maybe spread it over multiple sessions?
15:32:45 <ewoud> let's just sort out the date on the ML
15:32:54 <dcaro> ewoud, ok
15:33:06 <vfeenstr> quaid: I will see
15:33:07 <quaid> just added to the email
15:33:17 <quaid> ok .... ready to move on?
15:34:08 <eedri_> quaid, no
15:34:18 <eedri_> quaid, only itamar
15:34:22 <eedri_> afaik
15:35:00 <quaid> ok
15:35:16 <quaid> #topic Puppet
15:35:34 <quaid> ewoud: can you update us?
15:35:47 <ewoud> haven't had time to do anything
15:36:02 <quaid> np
15:36:13 <ewoud> which is kind of why I suggested a hacking session
15:36:29 <quaid> +1
15:36:37 * quaid in same boat
15:37:01 <quaid> #idea Puppet could be a top priority of holiday hacking session
15:37:31 <vfeenstr> quaid: nope you cannot link them
15:37:40 <vfeenstr> it ends up with this: http://gerrit.ovirt.org/#SignInFailure,LINK_IDENTIY,Contact+site+administrator
15:37:59 <quaid> ok
15:38:40 <quaid> vfeenstr: if you'd like, you can file a ticket at http://fedorahosted.org.ovirt & we'll assign it to Itamar
15:38:47 <quaid> that will help us keep from losing the request, etc.
15:39:17 <quaid> we have at least one new person interested in learning how this works in Gerrit, so having the ticket will help knowledge sharing
15:39:23 <quaid> next topic?
15:39:44 <ewoud> yes
15:39:58 <quaid> #topic Jenkins
15:40:12 <quaid> #info Migration plan submitted:
15:40:14 <quaid> http://lists.ovirt.org/pipermail/infra/2012-December/001625.html
15:40:20 <quaid> http://www.ovirt.org/Jenkins-Migration-Plan
15:40:48 <quaid> #agreed Use CentOS 6.3 for bare metal at Alter Way, meaning we can use CentOS 6.3 for Jenkins, etc.
15:42:03 <eedri_> we'll start the 'prior' testing phase this week
15:42:10 <quaid> eedri_: I didn't see any immediate additions or changes to the plan, looks good to me
15:42:35 <eedri_> might take some time before we can move to the 2nd phase, i'll know better after we start to test it
15:42:52 <eedri_> the migration phase itself shouldn't take long
15:44:33 <doron> amureini: ping?
15:44:36 <quaid> ok
15:45:44 <quaid> next topic?
15:47:16 <quaid> #topic Gerrit
15:47:55 <quaid> nothing new here?
15:48:27 <quaid> #info no news this week
15:48:37 <quaid> #topic Any other business?
15:49:41 <quaid> #topic Trac ticket review
15:49:45 <quaid> https://fedorahosted.org/ovirt/report/1
15:50:10 <quaid> #info skipping the tickets blocked by the Alter Ways migration
15:50:55 <quaid> we've got two tickets in for website theme/PHP tweaks:
15:51:03 <quaid> https://fedorahosted.org/ovirt/ticket/21 Search field made visible when window is slim
15:51:14 <quaid> https://fedorahosted.org/ovirt/ticket/23 Login link missing from footer of www.ovirt.org
15:51:28 <pit> how turn off a debug log on vdsm.log ?? please
15:51:49 <quaid> #info Garrett on vacation until new year, we'll work on those tickets in early 2013
15:52:18 <quaid> https://fedorahosted.org/ovirt/ticket/10 Rename arch@ mailing list to devel@
15:52:39 <quaid> https://fedorahosted.org/ovirt/ticket/11 Mailman is slow as molasses
15:52:59 <quaid> #idea Possibly make migration and improvements in Mailman a holiday hacking task
15:53:18 <quaid> https://fedorahosted.org/ovirt/ticket/13 manual build test
15:53:38 <quaid> hmmm
15:53:53 <quaid> first, I guess it makes sense to take Jenkins test requests as tickets
15:54:36 <eedri_> sounds good
15:54:42 <quaid> eedri_: do you happen to know if that item has been completed?
15:54:48 <eedri_> quaid, unelss it is managed by power user
15:55:15 <quaid> #agreed Jenkins requests not already managed by a power user can be made using Infra Trac instance
15:55:21 <eedri_> quaid, you can close the ticket
15:55:27 <quaid> thx
15:55:32 <eedri_> quaid, it was for moving all rpms build to new mode
15:55:43 <quaid> ok, closed
15:56:18 <quaid> https://fedorahosted.org/ovirt/ticket/16 Check why ConfirmAccount is not working
15:56:44 <quaid> That's one I have been discussing with Dave, we're not clear what the problem is (yet)
15:56:58 <quaid> #info work on ConfirmAccount after holiday break
16:00:14 * quaid had network drop
16:00:28 <quaid> ok, I'm going to just quickly finish going through these and close the meeting
16:00:29 <dneary> quaid, ConfirmAccount needs to put up that little notification
16:00:49 <dneary> quaid, But at this point, it doesn't matter, because it seems like people aren't finding the page any more
16:04:58 <quaid> my network is going flippy-floppy
16:05:08 <quaid> I'm going to close while I have the chance, do rest of the tickets later
16:05:11 <quaid> #endmeeting