15:03:00 <ewoud> #startmeeting
15:03:00 <ovirtbot> Meeting started Mon Mar 25 15:03:00 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:00 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:08 * dcaro is here
15:03:08 <ewoud> #chair Rydekull dneary
15:03:08 <ovirtbot> Current chairs: Rydekull dneary ewoud
15:03:13 <ewoud> #chair dcaro
15:03:13 <ovirtbot> Current chairs: Rydekull dcaro dneary ewoud
15:04:03 <ewoud> The agenda from http://www.ovirt.org/Infrastructure_team_meetings#2013-03-25
15:04:09 <ewoud> Introductions
15:04:09 <ewoud> Hosting
15:04:09 <ewoud> rackspace01 installed?
15:04:09 <ewoud> Puppet
15:04:09 <ewoud> Summarize the ML thread
15:04:12 <ewoud> Jenkins
15:04:14 <ewoud> Other business?
15:04:17 <ewoud> Trac review
15:04:56 <ewoud> I think we should also discuss eedri's progress on alterway02, but he's not online
15:05:10 <ewoud> anything else?
15:06:24 <ewoud> it seems not
15:06:27 <ewoud> #topic introductions
15:06:52 <ewoud> anyone who would like to introduce themselves?
15:07:10 * Rydekull doesnt think so
15:07:30 <ewoud> #topic Hosting
15:07:41 <ewoud> relaying info from quaid (who's on a plane right now)
15:08:03 <ewoud> he's having issues while installing fedora 17 and 18
15:08:39 <ewoud> anaconda crashes and he doesn't know if it's the iDRAC, fedora or his browser/java but working on it with rackspace support
15:09:07 <ewoud> Rydekull suggested to use a kickstart instead of manually installing
15:09:12 <ewoud> so work in progress
15:09:33 <ewoud> eedri mailed he installed ovirt on alterway02
15:09:54 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-March/002486.html
15:10:17 <ewoud> we should decide on a host naming scheme so please respond to it
15:11:04 <ewoud> feels like a bit of a monologue here
15:11:13 <Rydekull> Hehe, im here, all the time
15:11:19 <Rydekull> Just got nothing to comment :-)
15:11:26 <Rydekull> I can comment that, if You want
15:11:36 <ewoud> that reminds me, next week is easter so we should discuss that as well
15:12:01 <ewoud> anything else to add on the hosting front?
15:12:22 <Rydekull> not as far as I know, i've been ill during last week
15:12:38 <ewoud> been a bit busy myself as well
15:12:55 <ewoud> right, moving on to the next point on the agenda
15:12:58 <ewoud> #topic puppet
15:13:15 <ewoud> I haven't seen discussion on the ML thread so little to summarize
15:13:25 <Rydekull> +1
15:13:46 <ewoud> also been too busy to work on my proof of concept puppet repo, but I hope to work on it later today
15:14:01 <ewoud> dcaro: anything to add?
15:15:36 <ewoud> moving on
15:15:39 <ewoud> #topic jenkins
15:15:55 <ewoud> I haven't heard problems about the new jenkins master so I'm assuming it works well
15:16:09 <dcaro> ewoud: no, not yet
15:16:15 <ewoud> dcaro: ok
15:16:43 <Rydekull> I feel... we need to keep track and organize access to Jenkins Slaves
15:16:50 <Rydekull> document them in some way
15:16:57 <dcaro> ewoud: I saw a strange error with a specific patch of vdsm, it was not reproduced but made the job fail
15:17:16 <ewoud> Rydekull: that's a good point
15:17:42 <ewoud> dcaro: is that an issue of a specific slave? all slaves? master?
15:17:44 <outi> ewoud: you fixed /releases/3.2/rpm/EL/6/?
15:17:48 <ewoud> outi: yes
15:17:56 <outi> the same fix is needed for /releases/beta/rpm/EL/6/
15:17:59 <dcaro> ewoud: it happened on both f18 slaves
15:18:09 <ewoud> outi: oh wait, maybe I only fixed the beta
15:18:18 <ewoud> dcaro: ok
15:18:51 <ewoud> outi: it appears the beta is a symlink to 3.2 so both should be fixed
15:19:07 <dcaro> Rydekull: I think that the goal should be to have it in puppet
15:19:08 <ewoud> outi: try a yum clean if it doesn't get picked up
15:19:24 <Rydekull> dcaro: not sure how that's related
15:19:37 <ewoud> dcaro: but what about one time access to debug a build
15:19:46 <Rydekull> dcaro: As with any machine, or service under infrastructure teams control, we should have it documented
15:19:59 <outi> ewoud: oh, yes. sorry. browser refresh fixed it ;)
15:20:00 <ewoud> we've seen that happen as well with for example selinux, do we handle that in puppet as well?
15:20:38 <apuimedo> dcaro: you were talking about my magic patch?
15:20:48 <dcaro> apuimedo: yep :)
15:20:52 <apuimedo> :P
15:21:02 <ewoud> Rydekull: I'm a proponent of code-as-documentation so my preference would be to handle it in puppet (unless it's procedures)
15:21:02 <apuimedo> I still don't know what could it be
15:21:24 <dcaro> Rydekull: ewoud: exactly
15:21:52 <Rydekull> You all speak like developers :-)
15:21:55 <Rydekull> :-P
15:21:59 <ewoud> Rydekull: I am a developer
15:22:01 <Rydekull> I know
15:22:03 <Rydekull> Im not
15:22:23 <ewoud> I feel like we should have a sprint some time to actually work this stuff, but not sure how to organize it
15:22:36 <ovirtbot> 14[[07Intel Workshop May 201314]]4 10 02http://www.ovirt.org/index.php?diff=8107&oldid=7879&rcid=8309 5* 03Theron 5* (+146) 10/* Accommodations */ 
15:23:18 <ewoud> maybe we should start by documenting on the wiki what we have and then move that to puppet code
15:23:36 <dcaro> agree
15:23:48 <Rydekull> I'm all for automating stuff. But we need to know what to automate
15:24:13 <ewoud> #agreed we need to start documenting stuff on the wiki before we can automate it with puppet
15:24:22 <dcaro> ewoud: about selinux, puppet can manage it too... but never used it so I don't know how easy is to be used
15:24:24 <ewoud> I think that's the conclusion then
15:25:03 <ewoud> dcaro: I was refering to a specific example where dan walsh was granted access because a build was failing due to selinux and it needed debugging because it wasn't reproducable
15:25:09 <ewoud> not sure about the details
15:26:08 <ewoud> Rydekull: any good idea how to get started on documentation?
15:26:23 <Rydekull> Who knows the Jenkin Slaves? I know nothing about them
15:26:30 <ewoud> I'm thinking about making a list of machines we have and a list of users that have access
15:27:52 <ewoud> Rydekull: all I know is http://jenkins.ovirt.org/computer/
15:28:26 <ewoud> looking at the clock difference I suspect the master may not be in sync
15:29:03 <ewoud> I'll get started on making that list
15:29:03 <dcaro> I helped migrating them to the new master
15:29:18 <ewoud> then you can add to it
15:29:32 <Rydekull> We ought to have a system for how we accept a new slave, under which conditions, no?
15:29:34 <ewoud> #action ewoud start a list of machines infra has
15:30:21 <dcaro> Rydekull: are you thinking of letting anyone 'donate' new slaves to the master?
15:30:36 <Rydekull> ewoud: well, im already tasked with creating a list of machines and services, so I can finish the backup-ticket in the future :-)
15:30:52 <ewoud> Rydekull: ok
15:30:55 <ewoud> #undo
15:30:55 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0xa3f02ec>
15:31:08 <Rydekull> dcaro: Well, no, im thinking about publicly definining who we allow slaves and under what conditions
15:31:15 <ewoud> Rydekull: let me know if you need any help
15:31:19 <Rydekull> dcaro: what we require in return and what information we want
15:31:23 <Rydekull> ewoud: sir yes, sir
15:31:52 <ewoud> Rydekull: as someone who donates a slave I can confirm there aren't any real guidelines on it
15:32:35 <dcaro> Maybe we can create a vm template or something similar so it's easy to donate slaves
15:32:44 <Rydekull> ewoud: exactly :-)
15:32:52 <Rydekull> dcaro: that might be one option
15:33:04 <ewoud> dcaro: I think he's more refering to the legal requirements around it
15:33:15 <Rydekull> Everything around it
15:33:45 <ewoud> on a technical level I'd prefer if any donated machine runs puppet so we can ensure it's properly installed
15:33:49 <Rydekull> We need to know, to be able to guide other. and by publishing our guidelines, others have easier to adopt
15:34:39 <ewoud> Rydekull: something like https://ring.nlnog.net/ is what you're thinking of?
15:35:48 <Rydekull> haha, funny, yes, that is a excellent example
15:35:49 <ewoud> (not saying we need to copy that list, but the idea of a simple list of requirements)
15:37:21 <ewoud> they even publish their puppet classes on https://github.com/NLNOG/ring-puppet
15:39:10 <ewoud> I think we can move on to the next point on the agenda
15:39:24 * quaid arrives at the airport
15:39:37 * ewoud should learn to use #info more
15:39:47 <ewoud> I realize the minutes will be quite small now
15:39:58 <Rydekull> We live and we learn
15:40:26 * quaid reading the buffer
15:41:11 <ewoud> #action Rydekull add the jenkins slaves to a list ont he wiki
15:41:19 <ewoud> going to go back to hosting for the minutes
15:41:21 <ewoud> #topic hosting
15:42:10 <ewoud> #info quaid is having issues installing fedora on rackspace; may be the iDRAC, fedora or his browser/java but is working on it with rackspace support
15:42:53 <ewoud> #info eedri installed ovirt on alterway02; we now need to start installing VMs and think of a proper naming scheme
15:43:14 <ewoud> #topic other business
15:43:47 <ewoud> as I said earlier, next week is easter so I'm wondering how many are available next monday
15:44:35 * dcaro won't be available
15:44:54 <Rydekull> I will most likely be available
15:45:07 <ewoud> I'm not sure yet but most likely I'm available as well
15:45:31 <ewoud> quaid: dneary ?
15:45:43 <dneary> ewoud, ?
15:45:55 <dneary> Next Monday is a holiday in France
15:46:00 <dneary> I will be offline
15:46:03 <ewoud> that's why I'm asking
15:46:33 <quaid> I could take next Monday off, sure
15:47:17 <quaid> #idea organizing a sprint - put up a whenisgood calendar, look for crossover spots where a few people can be together at a time, with bleed over to the next block of people
15:47:59 <ewoud> so what do we do next week?
15:48:00 <quaid> I also could attend
15:48:06 <quaid> our holiday is Friday this week
15:48:17 <quaid> (I think)
15:48:21 <ewoud> quaid: do you have any experience with setting up such a sprint?
15:48:36 <quaid> I do actually
15:48:44 <quaid> let's give it to me :)
15:48:57 * quaid used to do docs for Fedora etc.
15:49:04 <quaid> #action quaid to setup docs sprint
15:50:58 <ewoud> do we have more or shall we go to the trac review?
15:51:09 <quaid> no more from me thx
15:51:25 <quaid> for Trac review, I stopped mid-way last week, we could start from that point ?
15:51:34 <ewoud> #topic trac review
15:51:36 <ewoud> let's
15:52:23 * quaid looking in minutes for where that was
15:53:05 <quaid> 38 was the last one
15:53:22 <quaid> https://fedorahosted.org/ovirt/report/1
15:53:23 <quaid> in that list
15:53:41 <quaid> oops, closed that one
15:54:03 <quaid> 21 was last before that
15:55:24 <ewoud> btw, I also noticed http://releases.ovirt.org still shows the old wordpress site without CSS so I think we should fix that as well
15:55:52 <quaid> holy moley
15:56:08 <quaid> sounds like a new ticket :) want to file it?
15:56:31 <ewoud> euh, resources.ovirt.org that is
15:56:31 * quaid makes one for upgrading the theme that might solve other tickets
15:57:09 * quaid did the mental transpose, how funny
15:59:49 * ewoud created https://fedorahosted.org/ovirt/ticket/40
15:59:55 <ewoud> I'll take a look
16:01:09 <quaid> https://fedorahosted.org/ovirt/ticket/39
16:02:41 <ewoud> ticket https://fedorahosted.org/ovirt/ticket/10 - Rename arch@ mailing list to devel@
16:02:51 <ewoud> quaid: any idea about a migration plan?
16:03:58 <ewoud> I'm assuming the mediawiki issues depend on #39 now
16:04:18 <quaid> right most likely
16:04:20 <ovirtbot> 14[[07Features/Otopi Infra Migration14]]4 !10 02http://www.ovirt.org/index.php?diff=8108&oldid=8090&rcid=8310 5* 03SandroBonazzola 5* (+39) 10/* engine-setup */ 
16:04:22 <quaid> well, it's openshift
16:04:32 <ewoud> https://fedorahosted.org/ovirt/ticket/29 Add new admins to OpenShift
16:05:24 <quaid> #idea migration by just trying out the upgrade during a window, then rollback if it doesn't work & make a more stepped plan
16:06:00 <ewoud> I have little experience with mailman so I'm of little use
16:06:36 <quaid> oh, that migration
16:06:46 <quaid> this was about mediawiki
16:07:07 <ewoud> quaid: could you give me access to openshift so I can help if there are issues?
16:07:24 <ewoud> quaid: and upgrading the theme during a window sounds fine
16:07:44 <quaid> sure
16:07:51 <quaid> do you want to use the same sshkey as you have otherwise
16:08:42 <ewoud> yes
16:08:54 <quaid> you may be added already checking now
16:09:46 <ewoud> in that case I have to look for the login
16:11:08 <quaid> I'm getting both, you need the long string to login yep
16:11:25 * quaid will paste here for the log in ... one  ... CSS .. moment
16:11:38 <ewoud> I found 847edb45aea84198838f915be6faa066@wiki-ovirt.rhcloud.com in the logs
16:11:51 <quaid> ssh://847edb45aea84198838f915be6faa066@wiki-ovirt.rhcloud.com/~/git/wiki.git/
16:12:12 <quaid> ok, none for you yet, let me add
16:12:46 <quaid> ok, you should be able to checkout now ...
16:13:14 <ewoud> correct
16:15:34 <ewoud> quaid: think we can close #29 now and open new tickets when we need to add more?
16:16:54 <quaid> ok
16:17:02 * quaid heading to gate now
16:17:06 <quaid> ttyl
16:17:06 <ewoud> quaid: ok
16:17:15 <ewoud> then I think we can end the meeting now
16:17:23 <ewoud> thanks all
16:19:00 <dcaro> thanks!
16:19:11 <ewoud> #endmeeting