14:01:00 <ewoud> #startmeeting infra weekly meeting
14:01:00 <ovirtbot> Meeting started Mon Apr 29 14:01:00 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:00 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:02 <Celestar> ovirt doesn't
14:01:16 <ewoud> copy paste from http://www.ovirt.org/Infrastructure_team_meetings#2013-04-29
14:01:25 <ewoud> Introductions
14:01:25 <ewoud> Review of action items
14:01:25 <ewoud> ewoud restart the puppet ML thread
14:01:25 <ewoud> ewoud start a thread on monitoring/trending
14:01:25 <ewoud> Rydekull add the jenkins slaves on a list on the wiki
14:01:28 <ewoud> quaid work on a docs sprint
14:01:30 <ewoud> quaid to bring dcaro & eedri in to the ACLs for RackSpace so they can take it over
14:01:33 <ewoud> Hosting
14:01:36 <ewoud> rackspace01 installed?
14:01:38 <obasan> obasan, here
14:01:38 <ewoud> Puppet
14:01:41 <ewoud> Jenkins
14:01:43 <ewoud> Other business?
14:01:46 <ewoud> Trac review
14:01:51 <ewoud> missing anything on the agenda?
14:02:36 <ewoud> #chair dcaro dneary
14:02:36 <ovirtbot> Current chairs: dcaro dneary ewoud
14:02:42 <ewoud> #topic introductions
14:03:00 <ewoud> any (potential) new infra members would like to introduce themselves?
14:03:37 <ewoud> #topic Review of action items
14:04:07 <ewoud> I have not started the puppet ML thread, nor the monitoring/trending, will do so
14:04:51 <ewoud> dcaro: did quaid give you and/or eedri access to the rackspace machines?
14:05:09 * quaid is here
14:05:21 <ewoud> #chair quaid
14:05:21 <ovirtbot> Current chairs: dcaro dneary ewoud quaid
14:05:25 <dcaro> ewoud: yes, we have access, this week we should start playing with it (last week there was a lot of work)
14:05:36 * knesenko here as well\
14:05:45 * obasan here
14:06:10 <ewoud> #chair obasan knesenko
14:06:10 <ovirtbot> Current chairs: dcaro dneary ewoud knesenko obasan quaid
14:06:17 <ewoud> dcaro: that's good
14:06:28 <ewoud> quaid: any progress on the docs sprint?
14:07:04 <quaid> none, although handing off the rackspace servers clears my way; I'll write up an email now to the list to find a few compatible times for folks
14:07:34 <ewoud> quaid: cool
14:09:07 <ewoud> #action quaid look for compatible times for a docs sprint
14:09:21 <ewoud> #action dcaro eedri install the rackspace servers
14:09:40 <ewoud> #action Rydekull Add the jenkins slaves on a list on the wiki
14:09:46 <ewoud> #action ewoud restart the puppet ML thread
14:09:53 <ewoud> #action ewoud start a thread on monitoring/trending
14:09:59 <ewoud> #topic Hosting
14:10:10 <ewoud> let's start with alterway
14:10:24 <ewoud> I haven't seen a reply on the IP space yet
14:11:02 <ewoud> is it time for a plan B with NAT or do we wait?
14:12:01 <dcaro> ewoud: do you think that it will be hard to migrate from NAT to ips if we finally get them?
14:13:05 <ewoud> dcaro: not sure
14:13:56 <ewoud> but with public facing services such as a webserver I don't like the idea of NAT
14:15:51 <ewoud> anyone else has an opinion here?
14:17:13 <knesenko> nope]
14:18:16 <ewoud> dneary: you've had some more contact with them, any insight?
14:22:02 <ewoud> another possibility is to not virtualize at all on alterway02, but it's not something I'd prefer either
14:24:05 <ewoud> while we let that sink in, let's speak about rackspace
14:24:38 <ewoud> I know dcaro said he had no time yet, but I'd like to avoid a similar situation where we install it but then run into the same problem
14:25:02 <ewoud> we plan to virtualize, but do we have some IP space? can jenkins slaves run without a public IP?
14:25:37 <dcaro> ewoud: yes they can, through the jnpl slave you can connect behind a NAT (I haven't tested it though)
14:28:03 <ewoud> dcaro: ok, is that something you could look into?
14:29:14 <dneary> sorry - was afk for a second
14:29:16 <dcaro> ewoud: yes, I will
14:29:51 <ewoud> #action dcaro look into running jenkins slaves @ rackspace + IP space
14:29:59 <dneary> ewoud, re AlterWay & IPs, I'm missing a little bit of background - is there a Trac ticket I can point them at?
14:30:21 <ewoud> dneary: no, just a ML discussion
14:30:58 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-April/002622.html
14:32:59 <ewoud> dneary: long story short: we need public IPs for our VMs on alterway02
14:35:13 <ewoud> I'll ping on the ML again, maybe my message wasn't clear to alterway
14:35:42 <ewoud> #action ewoud re-ignite the IP space discussion on the ML
14:36:03 <ewoud> anything else on hosting?
14:38:08 <ewoud> #topic Puppet
14:38:53 <ewoud> not sure what we can discuss about this till we can actually get this started with a puppet master and that depends on the alterway IPs
14:40:34 <dneary> ewoud, What do you mean by "alterway IPs" exactly?
14:40:44 <dneary> Excuse me for coming late to the story
14:41:15 <ewoud> dneary: we currently have 2 IPs there: one for each physical host, but if we want to run VMs, they need IPs
14:41:26 <dneary> Right
14:41:40 <dneary> They get them from ovirt-manager when they start up, correct?
14:41:41 <ewoud> the easiest solution is to get extra IPs from alterway
14:42:08 <ewoud> we have 2 dedicated servers, both with static IPs
14:42:16 <dneary> Yes
14:42:39 <dneary> Do the VMs get local dynamic IPs from dhcp when they start?
14:42:52 <ewoud> and I'm not sure how ovirt-manager could give the VMs IPs since we haven't been given an IP pool by alterway AFAIK
14:43:18 <ewoud> or if alterway actually has DHCP running
14:44:13 <ewoud> and if it's the case that we can use DHCP, how much guarantee do we have that they're persistent
14:45:46 <ewoud> dneary: does that make it clear?
14:46:00 <dneary> OK
14:46:05 <dneary> Yes, that clears it up
14:46:10 <dneary> Let me open a trac to track
14:46:38 <dneary> Incidentally, speaking of trac: https://fedorahosted.org/ovirt/ticket/44
14:46:49 <dneary> Anyone have any idea how to get piwik working on OpenShift?
14:47:47 <ewoud> no, but I could look into it
14:48:22 <dneary> just found a link
14:49:25 <ewoud> https://github.com/openshift/piwik-openshift-quickstart looks easy enough
14:50:01 <ewoud> http://www.linuxbsdos.com/2013/03/21/how-to-deploy-piwik-web-analytics-on-openshift-online/ as well
14:50:27 <dneary> https://fedorahosted.org/ovirt/ticket/45
14:50:47 <dneary> ewoud, Do you know how to deploy a quickstart on top of another one?
14:50:59 <dneary> (I'm assuming piwik needs access to logs)
14:51:35 <ewoud> dneary: piwik doesn't need access to logs, you include a snippet of javascript and piwik works from there
14:51:40 <ewoud> so they can run on different servers
14:53:45 <ewoud> #action ewoud look into running piwik on openshift
14:54:00 <ewoud> #topic jenkins
14:54:11 <ewoud> anything new to mention about jenkins?
14:54:20 <ewoud> dcaro: eedri ?
14:55:06 <dcaro> ewoud: we had some problems with gerrit triggers not firing, just fyi, it was solver restarting the poller thread (under jenkins -> management -> gerrit trigger)
14:55:33 <dcaro> I saw no traces that whould be of help in the logs to autodetect that failure though :S
14:56:01 <ewoud> ok
14:56:26 <ewoud> we also discussed that the f17 slave is under a bit of load and it seems java jobs need a lot of memory
14:57:04 <dcaro> yep, I've changed the number of executors to 2, hopefully that will avoid too many jobs rinning at the same time
14:58:31 <ewoud> we should monitor that the amount of jobs doesn't queue up too much
14:58:38 <ewoud> #topic other business
14:59:06 <ewoud> I've noticed that sometihg I'm having a bit of a monologue during the meeting
14:59:34 <ewoud> does that mean the meeting time is bad for a lot of people with double agenda's or is there something else we can do to improve this?
15:02:57 <knesenko> ewoud: no its not
15:03:15 <knesenko> ewoud: I think that because of some people are not in the loop
15:03:27 <knesenko> like me or obasan
15:03:34 <ewoud> knesenko: I can see that, but how can we improve that?
15:04:06 <knesenko> ewoud: its not related to u ... we need talk here to eedri to improve it
15:04:10 <ewoud> I have no experience in working on a non-traditional team where you all work for the same company in the same office
15:05:05 <knesenko> ewoud: I"ll to eedri tomorrow ...
15:05:21 <knesenko> will need to see how can we improve our work in upstream ...
15:05:40 <ewoud> knesenko: keep me in the loop ;)
15:05:49 <knesenko> ewoud: I"ll update u
15:06:07 <ewoud> #action knesenko talk to eedri about making work more transparant
15:07:07 <ewoud> ok, closing then
15:07:08 * knesenko will do
15:07:12 <ewoud> going once
15:07:40 <ewoud> going twice
15:07:45 <ewoud> ok, thanks all
15:07:48 <ewoud> #endmeeting