14:06:33 <ewoud> #startmeeting infra weekly meeting
14:06:33 <ovirtbot> Meeting started Mon May  6 14:06:33 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:33 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:47 * knesenko her
14:06:51 * knesenko here
14:06:51 <ewoud> #chair knesenko eedri
14:06:51 <ovirtbot> Current chairs: eedri ewoud knesenko
14:07:01 * dcaro too
14:07:04 <ewoud> ping dneary quaid
14:07:07 <ewoud> #chair dcaro
14:07:07 <ovirtbot> Current chairs: dcaro eedri ewoud knesenko
14:07:23 <dneary> Ping
14:07:26 <dneary> Pong
14:07:29 <ewoud> #chair dneary
14:07:29 <ovirtbot> Current chairs: dcaro dneary eedri ewoud knesenko
14:07:38 <ewoud> agenda from http://www.ovirt.org/Infrastructure_team_meetings#2013-05-06
14:07:45 * obasan here
14:08:05 <ewoud> #chair obasan
14:08:05 <ovirtbot> Current chairs: dcaro dneary eedri ewoud knesenko obasan
14:08:13 <ewoud> Introductions
14:08:14 <ewoud> Review of action items
14:08:19 <ewoud> Puppet
14:08:19 <ewoud> Jenkins
14:08:19 <ewoud> Other business?
14:08:20 <ewoud> Trac review
14:08:31 <ewoud> and I forgot Hosting in that list
14:08:37 <eedri> new infra memebers proposal
14:09:11 <knesenko> we have a new guy in our team . hope he will join our team as well
14:09:23 <knesenko> I mean infra team :)
14:09:24 <ewoud> ok
14:10:04 <ewoud> #topic introductions
14:10:13 <ewoud> or is it too early for an introduction? :)
14:10:25 <knesenko> ewoud: he is not here yet :)
14:10:48 <ewoud> #topic new infra members proposal
14:11:11 <ewoud> eedri: are you refering to a prior discussion on the ML?
14:12:13 <eedri> ewoud, i'm not sure
14:12:43 <eedri> ewoud, i want to ask/propose knesenko as an infra memeber to join effort as jenkins administrator
14:12:55 <eedri> ewoud, it means having access to jenkins master + slaves
14:13:41 <eedri> ewoud, he has been monitoring jobs for some time now and have extensive knowladge in jenkins already
14:13:53 <dcaro> +1
14:14:14 <obasan> +1
14:14:29 <eedri> ewoud, he also has knowladge in foreman/puppet and is willing to help rolling out these services as well
14:14:42 <ewoud> eedri: I think a vote is sufficient, give it a decent amount of time or sufficient votes
14:15:26 <eedri> #action eedri to send a vote request to list on making knesenko infra memeber for administrating jenkins,foreman,puppet
14:16:18 <ewoud> maybe we can document the process as we go along?
14:16:29 <ewoud> in my experience that's the best method of writing documentation about processes
14:16:41 <eedri> ewoud, do we have an initial wiki on it?
14:17:46 <ewoud> eedri: I thought we had something, but can't find it
14:18:09 * eedri found this http://www.ovirt.org/Becoming_a_maintainer
14:18:33 <eedri> ewoud, so maybe we can add a sub-section on being an infra maintainer
14:19:09 <ewoud> eedri: I wouldn't be against that and we can always move it if needed
14:19:14 <eedri> ewoud, http://www.ovirt.org/Becoming_an_Infrastructure_team_member
14:19:31 <eedri> ewoud, really informative :)
14:19:40 <ewoud> eedri: quite :)
14:19:51 <ewoud> eedri: we did discuss some things on the ML in the past, but that never made it to the wiki
14:20:13 <ewoud> eedri: would you mind documenting steps along the way?
14:20:13 <eedri> ewoud, yes,
14:20:41 <eedri> ewoud, i would add some steps and we can review it on the list
14:21:06 <ewoud> #action eedri document the new infra member process as it goes on
14:21:09 <ewoud> eedri: sounds good
14:21:17 <ewoud> #topic review of action items
14:21:38 <ewoud> quaid look for compatible times for a docs sprint
14:21:38 <ewoud> dcaro eedri install the rackspace servers
14:21:38 <ewoud> Rydekull Add the jenkins slaves on a list on the wiki
14:21:38 <ewoud> ewoud restart the puppet ML thread
14:21:38 <ewoud> ewoud start a thread on monitoring/trending
14:21:40 <ewoud> dcaro look into running jenkins slaves @ rackspace + IP space
14:21:43 <ewoud> ewoud re-ignite the IP space discussion on the ML
14:21:45 <ewoud> ewoud look into running piwik on openshift
14:21:48 <ewoud> knesenko talk to eedri about making work more transparant
14:22:02 <ewoud> dcaro: eedri any luck getting the rackspace servers going?
14:22:25 * ewoud is going to restart the puppet ML thread as he installs the foreman server
14:22:25 <eedri> ewoud, unfourtunately no, had a week full of courses and no free time
14:22:37 <eedri> ewoud, i hope to attend to it this week
14:22:39 <dcaro> Haven't tried, too busy :(
14:22:56 <ewoud> I did start the monitoring/thrending thread, but needs some more input
14:23:03 <ewoud> thanks dcaro for your additions
14:23:11 <dcaro> ewoud: welcome :)
14:23:27 <ewoud> I'll assume you had no time to look at the IP space either?
14:23:56 <ewoud> I did get IPs from alterway so I plan on installing the foreman server tonight
14:24:04 <ewoud> and no time to look in piwik
14:24:15 * ewoud going to re-add action items that weren't completed
14:24:21 <ewoud> #action quaid look for compatible times for a docs sprint
14:24:28 <ewoud> #action dcaro eedri install the rackspace servers
14:24:32 <ewoud> #action Rydekull Add the jenkins slaves on a list on the wiki
14:24:38 <ewoud> #action ewoud restart the puppet ML thread
14:25:03 <ewoud> monitoring will get its own agenda item
14:25:03 <knesenko> ewoud: I would like to help with puppet/foreman installation
14:25:22 <ewoud> knesenko: ok, let's talk about that on the puppet topic
14:25:29 <knesenko> ewoud: k
14:25:31 <ewoud> #action ewoud look into running piwik on openshift
14:25:44 <ewoud> knesenko: did you talk to eedri about making work more transparant?
14:26:08 <ewoud> and if so, does it need to stay as action item?
14:26:17 <knesenko> ewoud: as eedri told - he was on courses last week
14:26:36 <ewoud> knesenko: oh yes
14:26:42 <knesenko> ewoud: I"ll talk to him this week
14:26:52 <ewoud> #action knesenko talk to eedri about making work more transparant
14:26:54 <ewoud> #topic hosting
14:27:04 <ewoud> #info no progress on rackspace hosts
14:27:25 <ewoud> #info we have extra IPs at alterway so we can start installing VMs on alterway02
14:27:51 <ewoud> how's the disk space issue on linode01?
14:28:27 <knesenko> ewoud: we wanted to install ovirt-engine ... or this is another topic ?
14:28:47 <ewoud> knesenko: there's already an ovirt-engine install on alterway02, but until now we lacked IPs to install VMs with
14:29:14 <knesenko> ewoud: do we have all-in-one setup there ?
14:29:18 <ewoud> knesenko: yes
14:29:22 <knesenko> ewoud: k
14:29:54 <ewoud> eedri: dcaro do you know about the linode01 disk space?
14:29:58 <ewoud> is it OK now?
14:30:02 <eedri> ewoud, it's ok
14:30:07 <eedri> ewoud, i did some changes there
14:30:15 <dcaro> he's faster :)
14:30:22 <eedri> ewoud, i think the dropbox in jenkins homedir was not cleaned
14:30:43 <eedri> ewoud, i added a rm -rf to the temp dir for publishing niglies
14:30:44 <ewoud> eedri: ah yes, those I mailed a question about but then never followed up on :P
14:31:01 <ewoud> ok, anything else about hosting?
14:31:08 <eedri> ewoud, and i think we should move all backups to alterway01/2
14:31:41 <ewoud> eedri: not sure, if we plan on hosting gerrit on alterway02 (which I think is the plan), then we need another location
14:31:49 <eedri> ewoud, hmm...
14:31:54 <eedri> ewoud, so rackspace?
14:32:05 <eedri> ewoud, maybe backup to alterway1?
14:32:30 <eedri> ewoud, we also need to add jenkins backups asap, which we currenlyt don't have afaik
14:33:05 <knesenko> eedri: +1
14:33:07 <ewoud> eedri: not sure about alterway01 because I'd like to store them in a physical different location so rackspace would be better, but maybe amazon S3 could work as well
14:33:18 <ewoud> but +1 to adding jenkins backups
14:33:51 <eedri> ewoud, i opened a trac ticket on it, we have a script ready for it
14:34:22 <ewoud> https://fedorahosted.org/ovirt/ticket/47
14:34:44 <ewoud> eedri: btw, please add code tags or whatever trac uses :)
14:35:05 <eedri> ewoud, it has?
14:35:07 <knesenko> eedri: ewoud I will handle jenkins backup and will add backup script to jenkins git repo
14:35:20 <ewoud> knesenko: ok
14:35:29 <ewoud> eedri: I don't see any escaping
14:36:08 <eedri> knesenko, +1 thanks
14:36:23 <ewoud> eedri: if you use {{{ my bash script }}} it will be preformatted
14:36:42 <dcaro> ^good to know
14:37:00 <ewoud> see https://fedorahosted.org/ovirt/wiki/WikiFormatting
14:37:24 <dcaro> added to bookmarks :)
14:37:31 <ewoud> #action knesenko handle jenkins backup and add script to jenkins git repo
14:37:36 <ewoud> ok, I think we can move on to puppet
14:37:44 <ewoud> #topic puppet
14:38:34 <ewoud> this evening I intend to install foreman using the foreman installer and then start a basic setup in a git repo
14:38:41 <dneary> eedri, By the way, I saw http://www.ovirt.org/OVirt_3.3_release-management
14:38:51 <ewoud> #action ewoud install foreman.ovirt.org
14:38:57 <dneary> Looks good! Would love to see it pushed more on the -dev list
14:39:04 <dneary> (rather -arch)
14:39:43 <ewoud> knesenko: you said you want to help
14:39:52 <knesenko> ewoud: sure
14:39:55 <eedri> dneary, it does look good, who wrote it? :)
14:40:14 <ewoud> my first goal is to set up user authentication
14:40:28 <ewoud> so create a user, add the SSH key and setup sudo
14:40:49 <knesenko> ewoud: ok
14:41:12 <knesenko> ewoud: do we want puppet and foreman on the same machine ?
14:41:43 <ewoud> knesenko: I think so
14:42:04 <knesenko> ewoud: ok . good
14:42:10 <ewoud> knesenko: I don't expect that many machines and otherwise we can still split it later
14:42:10 <knesenko> ewoud: when do you want to start ?
14:42:16 <knesenko> ewoud: :)
14:42:19 <dcaro> ewoud: knesenko if you can, use exported resources, it will help reusing code
14:42:34 <ewoud> knesenko: don't have an exact planning, do you have a preference?
14:43:01 <knesenko> dcaro: 10x
14:43:10 <knesenko> ewoud: we can start after a meeting
14:43:14 <ewoud> dcaro: I was thinking about that
14:43:22 <ewoud> knesenko: I have to work still
14:43:49 <knesenko> ewoud: when do u finish ?
14:43:52 <ewoud> and I tend to work a bit later because I'm doing this meeting during office hours
14:44:24 <knesenko> ewoud: Mon May  6 14:45:25 UTC 2013
14:44:50 * ewoud looks for a timezone tool
14:44:54 <knesenko> ewoud: :)
14:45:27 <knesenko> ewoud: when do you want to do it ....  ?
14:46:00 <ewoud> knesenko: 18:00 UTC?
14:46:26 <knesenko> ewoud: ok
14:46:34 <dneary> ewoud, I think I could take on doing piwik for ovirt.org, if you want
14:46:35 <knesenko> ewoud: I will be online
14:47:11 <dneary> ewoud, http://www.timeanddate.com/worldclock/meeting.html
14:47:38 <dneary> eedri, Not your team?
14:47:51 <eedri> dneary, maybe moran updated it
14:48:17 <eedri> dneary, he's leading effort for release managment for oVirt
14:48:41 <dneary> eedri, Moran, Danken, Alissa, Daniel Erez, Netbulae (?)
14:48:56 <dneary> Deepak
14:49:21 <dneary> mburns,
14:49:27 <dneary> Doron
14:49:47 <mburns> dneary: what?
14:49:53 <ewoud> dneary: if you want, no problem
14:50:02 <ewoud> knesenko: cool
14:50:12 <dneary> ewoud, Put it on me, then
14:50:35 <ewoud> #action dneary set up piwik
14:50:38 <dneary> It won't get done this week, probably not nexy, but should be done by end of May
14:50:53 <ewoud> dneary: ok
14:52:34 <ewoud> I'll do a meeting then so we get logs from setting it up and mail them afterwards
14:52:43 <ewoud> anything else about puppet?
14:53:43 <ewoud> #topic jenkins
14:54:02 <ewoud> anything that needs to be discussed?
14:54:09 <dcaro> ewoud: We will use git repo or a new repo on gerrit.ovirt.org?
14:54:18 <dcaro> ^puppet I mean
14:54:42 <knesenko> dcaro: I think that we should use a new repo for puppet
14:54:43 <eedri> ewoud, i updated jenkins server
14:54:45 <ewoud> dcaro: I'd like to eventually use gerrit, but while setting it up I prefer to use a git repo the foreman server itself
14:54:58 <eedri> ewoud, due to security alert released over the weekend
14:55:05 <ewoud> eedri: thanks :)
14:55:35 <eedri> ewoud, also updated some plugins. we should be carefull when updating the credentials plugin, there was a change in the way slaves are connecting to the master
14:55:49 <ewoud> knesenko: without a doubt a separate repo from the rest
14:55:50 <eedri> ewoud, so that plugin wasn't updated
14:56:33 <ewoud> #info jenkins master updated due to security issue; some plugins not updated
14:57:21 <ewoud> I'm afraid I don't have time to do a trac issue review so if someone else wants to pick that up, that would be cool
14:57:21 <knesenko> ewoud: so lets ask Itamar to create a puppet repo for us ?
14:57:45 <ewoud> knesenko: yes, but I'd like to use the git_repo = true option in the foreman installer
14:59:34 <ewoud> that has a nice hook that updates /etc/puppet/environments, including submodules
15:01:00 <ewoud> I'd like to close the meeting
15:01:32 <eedri> +!
15:01:33 <eedri> +1
15:02:38 <ewoud> thanks all
15:02:41 <ewoud> #endmeeting