14:04:53 <mburns> #startmeeting oVirt Weekly Meeting
14:04:53 <ovirtbot> Meeting started Wed May 15 14:04:53 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:53 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:06 <mburns> #topic agenda and roll call
14:05:24 <dneary> mburns, Suggestions for encouraging changes to be made to this page: http://www.ovirt.org/OVirt_3.3_release-management
14:05:34 <dneary> hi jb_netapp
14:05:41 <mburns> #info most of the maintainers aren't available today, so a slightly ad-hoc agenda...
14:06:12 <dneary> jb_netapp, mburns, I suggest we concentrate on improving the visibility on the arch list into the state of the release
14:06:12 <jb_netapp> hi dneary
14:06:37 <dneary> We're running towards a feature freeze/beta date with no idea what the status of things is
14:06:37 <mburns> dneary: do you have any update from the shanghai workshop?
14:06:43 <dneary> mburns, I was not there
14:06:46 <mburns> dneary: ok
14:06:51 <dneary> theron and cctrieloff were
14:07:58 <mburns> dneary: my minutes from the weekly meetings go out to the board and users list and include status of all the features that i know about
14:08:05 <mburns> i can expand that to the arch list as well
14:08:22 <mburns> dneary: though i am dependent on maintainers being here to talk about the features...
14:08:52 <dneary> Plus, it's confusing. Just to take one example: RAM snapshots has a feature page, it's in "Implementation started", but it's not listed as either a "Must" or "Should" feature higher on the page
14:09:30 <dneary> mburns, This is about more than the process of publishing minutes.
14:11:13 <dneary> mburns, I agree, it requires that developers and maintainers give visibility into what is being done, when, and when it's "ready"
14:11:13 <mburns> dneary: i agree the page needs an overhaul
14:12:08 <mburns> dneary: i'll try to take a pass at that page in the next couple days
14:12:16 <mburns> but i just don't know a lot of the info that you want
14:14:00 <mburns> #info need better status communication on features
14:14:12 <mburns> #info need to review features for must/should release criteria
14:14:34 <mburns> #action mburns to update the release management page with as many details as he knows
14:15:19 <mburns> #action mburns to reach out to other maintainers to make sure their pages are updated as well
14:15:37 <mburns> dneary: anything i missed in those #infos and #actions?
14:16:07 <dneary> mburns, Sounds good
14:16:14 <mburns> #topic
14:16:20 <mburns> #topic Other Topics
14:16:23 <mburns> anything else?
14:16:24 <dneary> I'm writing a follow up email to arch@ also - pointing out a lot of the issues I have with that page
14:16:42 <dneary> People seem to add new features freely, with no consideration for the MUST/SHOULD lists at the top
14:17:04 <dneary> They're essentially two independent things: what we said we'd do at the start of the release cycle, and what's getting done
14:17:25 <mburns> i think features and release criteria are separate
14:17:38 <mburns> though some features should be part of the release criteria, they don't all have to be
14:17:47 <dneary> Only if your release criteria do not include "Feature X should be done"
14:17:56 <dneary> Ah, I see what you mean
14:18:16 <dneary> Well, I would at least expect all of the "MUST" features to be linked to feature pages at this point
14:18:38 <mburns> dneary: example:  self-hosted engine feature -- that's something we're trying to get in this release
14:18:40 <dneary> jb_netapp, What do you think?
14:19:00 <mburns> but it's not really a blocker (and actually is likely to slip to 3.4, i think)
14:19:43 <dneary> mburns, I see
14:19:54 <mburns> dneary: but yes, the big features that are critical should be listed in the Must list
14:20:23 <mburns> i just don't think anyone went through and did the analysis of what features are release blockers and what ones are not
14:21:59 <mburns> dneary: given lack of people here (since jb_netapp dropped), i think continuing this on email is the right thing to do
14:22:08 <dneary> Yup
14:22:15 <mburns> #endmeeting