13:18:03 <quaid> #startmeeting linode01 details & transfer discussion
13:18:03 <ovirtbot> Meeting started Tue Oct 22 13:18:03 2013 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:18:03 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:18:22 <mskrivanek> apuimedo: well, if you can hear anything that's better than nothing...
13:18:37 <apuimedo> mskrivanek: indeed
13:18:51 <quaid> knesenko: so I thought we could talk about what is on the server, and that leads to what needs migrating
13:18:56 <knesenko> #chair knesenko
13:19:04 <knesenko> quaid: ^^
13:19:15 <quaid> #chair knesenko
13:19:15 <ovirtbot> Current chairs: knesenko quaid
13:19:21 <knesenko> quaid: k
13:20:28 <quaid> #info linode01 runs Mailman (lists.ovirt.org)
13:20:39 * quaid is ssh'ing in to check stuff
13:20:54 <knesenko> ok
13:21:41 <quaid> #info ovirtbot runs, an instance of supybot with a few standard plugins that aren't all working since MediaWiki moved
13:22:46 <quaid> #info Rydekull was working on fixing that because theoretically it could pick up the changes over http (iirc) but may have run in to something from OpenShift? I don't recall
13:23:33 <quaid> #info runs resources.ovirt.org, and associated repositories., and probably some scripts that build stuff for the repos?
13:24:17 <knesenko> need to ask mburns how he builds the repos there
13:24:45 <quaid> #action knesenko to ask mburns how repos are built on linode01
13:25:03 <mskrivanek> 2 people streaming Livnat's talk, join till it lasts! https://plus.google.com/107691536544094955898/posts/Z7y4xPEw6DG
13:25:40 <quaid> that's great, I couldn't be there in person
13:26:08 * quaid could but then he'd be doing this meeting at the same time, a bit rude :)
13:26:09 <ewoud> quaid: knesenko I think mburns actually builds them somewhere else and then uploads them
13:26:23 <ewoud> and then runs createrepo
13:26:28 <quaid> ewoud: there may be some scripting on the server side, i don't remember, that might have been old days
13:26:51 <ewoud> quaid: also, I think at some point openshift => linode with ovirtbot did work but then it broke
13:27:32 <ewoud> quaid: don't forget http://ovirt.org is redirected to https://www.ovirt.org by linode01 as well
13:27:39 <quaid> #info there is interesting stuff in /root - passwords file has all/most of the Infrastructure passwords; httpd log backups for eventual metrics work; mailman metrics
13:28:04 <quaid> #info ovirt.org is redirected to www.ovirt.org by Apache on linode01
13:28:36 <quaid> ewoud: or maybe people got tired of the noise in #ovirt? :)
13:28:52 <ewoud> quaid: I think it wasn't planned to turn it off :)
13:28:57 <quaid> #info there may be something in /root/git as well
13:29:11 <quaid> ewoud: yes, but the noise might be why it wasn't fixed :)
13:30:14 <quaid> question: are all the backups turned off this host now?
13:30:22 <quaid> it used to backup gerrit
13:30:35 <quaid> also, is it no longer being used by Jenkins for ... I forget, logs?
13:31:04 <quaid> #info root crontab is running active jobs:
13:31:07 <quaid> # Give root word about the backup
13:31:07 <quaid> MAILTO=root
13:31:07 <quaid> #
13:31:07 <quaid> # Run thirty minutes after 8 pm Eastern/Midnight UTC every day, to clean out older than 7 days
13:31:11 <quaid> 30 20 * * * /root/bin/backup-cleanup.sh
13:31:13 <quaid> # Run forty-five minutes after 8 pm Eastern/Midnight UTC every day, to track subscriber trends
13:31:16 <quaid> 45 20 * * * /root/bin/mailman-subscriber-count.sh
13:31:19 <quaid> # Run fifty-five minutes after 8 pm Eastern/Midnight UTC every day, to archve Apache logs
13:31:22 <quaid> 55 20 * * * /root/bin/httpd_log_backup.sh
13:31:24 <quaid> </flood>
13:31:29 <knesenko> quaid: afaik jenkins was moved to physical server ... so I don't think jenkins somehow related to linode01
13:31:46 <ewoud> knesenko: IIRC backups from jenkins to linode01
13:32:26 <mskrivanek> coming up next in 10 minutes - Kimchi: Simplified KVM Management - Adam Litke, IBM
13:33:10 <quaid> #info /home/gerritt-backup is the backup of gerrit done daily, may be redundant?
13:33:27 <quaid> #info jenkins did/used-to backup to linode01
13:33:30 <knesenko> ewoud: all backups from jenkins stored on alterway02.ovirt.org
13:33:38 <Rydekull> Hmm
13:33:41 <Rydekull> I was highlighted
13:33:54 * Rydekull tries to find it
13:34:35 <quaid> Rydekull: it was about fixing ovirbot mediawiki reporting, you fixed it then it broke iirc
13:35:11 <Rydekull> oh, well, its just something blocking ought to be simple enough to fix again
13:35:33 <mburns> knesenko: what's up?
13:36:14 <Rydekull> When its a "cloud", the cloud moves and changes IPs etc. And thus the "integration" from mediawiki's side has probably changed IP, and thus supybot is not recieving the info
13:36:17 <knesenko> mburns: hey how are you ? can you tell us please how do you create repos on resources.ovirt.org ? ar eyou using some scripts for that ?
13:36:18 <Rydekull> Im just assuming here :-)
13:36:24 <Rydekull> I think its in the ticket how I solved it
13:36:25 <quaid> Rydekull: we're talking about linode01 and migration, so we'll want to move ovirbot & look at it with fresh eyes
13:36:37 <mburns> knesenko: it's somewhat of a mess
13:36:41 <mburns> i have some scripts for most of it
13:36:46 <mburns> but a lot it manually done
13:36:53 <quaid> we can probably get ovirtbot running on openshift
13:37:06 * quaid goes to add everyone to openshift control now that we can do that
13:37:07 <Rydekull> I somewhat doubt that
13:37:17 <quaid> oh, bummer
13:37:20 <Rydekull> iirc correctly they have blocks against such
13:37:25 <quaid> ah, ok
13:37:29 <quaid> that's different
13:37:44 <quaid> we have other ways :)
13:37:53 <mskrivanek> Adam Litke's Kimchi talk live right now - https://plus.google.com/107691536544094955898/posts/bVxqs6qrrRA
13:38:03 <quaid> #info there are jenkins backup directories that seem empty, looks turned off
13:38:26 <knesenko> quaid: jenkins backups located on alterway02
13:38:50 <quaid> yeah, that looks migrated already :)
13:39:09 <Rydekull> Oh well, let me know if you need my help for something /me goes back to studying
13:39:19 <quaid> Rydekull: cheers, thanks
13:39:30 <mburns> 530508
13:39:36 <Rydekull> +1
13:39:38 <quaid> oh I hate when I do that
13:41:08 <knesenko> quaid: who manages mailman ?
13:41:47 <quaid> knesenko: I guess still me, mainly
13:41:58 <quaid> knesenko: things are well documented and others have access, though
13:42:18 <quaid> knesenko: it hasn't been much work :)
13:42:50 <quaid> http://www.ovirt.org/Creating_and_configuring_mailing_lists
13:43:38 <quaid> #info /var/www/html/meetings is the output directory for ovirtbot, and it needs to be run locally (afaik) from that directory to happen
13:43:42 <quaid> http://www.ovirt.org/Running_ovirtbot
13:44:15 <quaid> #info /var/www/html/releases is run by rel-eng
13:44:32 <quaid> #info /var/www/html/dbreports is a symlink to /home/jslave/dbreports and I have no idea what that is :)
13:44:57 <quaid> seems active
13:44:58 <quaid> http://resources.ovirt.org/dbreports/latest/engine/
13:45:04 <ewoud> quaid: there was a jenkins job that generated the database schemes
13:46:39 <eedri> quaid, that jenkins job is disabled
13:46:48 <eedri> quaid, if we talk about job that generates db reports.
13:46:53 <quaid> something's running, that's an updated directory
13:46:55 <quaid> http://resources.ovirt.org/dbreports/latest/engine/public/index.html
13:47:03 <eedri> quaid, the owner of the job installed locally something
13:47:07 <eedri> quaid, let me verify it
13:47:34 <quaid> yeah, that's probably it, an auto process, maybe it's still rerunning that last data dump
13:48:18 <quaid> #info /var/www/html/stats is possibly worth restoring in a new VM, it's not active but it's a place that _could_ be active and I hope will soon be active
13:51:33 <knesenko> quaid: there is a lot of things to migrate I see
13:53:04 <quaid> I think that's all :)
13:53:21 <quaid> knesenko: yeah, it's the kitchen sink server when we only had one for everything :)
13:53:45 <knesenko> quaid: there is a lot of work to be done here
13:57:34 <quaid> knesenko: if we recreate resources as a vm, it could be sort-of straightforward
13:58:49 <knesenko> quaid: where do we run this VM - amazon ?
13:59:19 <quaid> knesenko: linode.com
13:59:52 <knesenko> quaid: ok ..
14:00:11 <knesenko> quaid: do u want me to show how to handle openshift issues and mailman ?
14:04:39 <quaid> knesenko: you mean, migrating mailman to openshift?
14:05:23 <knesenko> quaid: do we want to migrate it ?
14:05:48 <knesenko> quaid: i am not familiar with the website migration to openshift
14:06:10 <knesenko> quaid: this was done before I became infra member
14:07:06 <knesenko> quaid: I meant how to maintain ovirt.org wesite when its down etc ...
14:08:10 <quaid> ok
14:08:41 <eedri> quaid, http://jenkins.ovirt.org/job/ovirt_db_report_engine/
14:08:45 <eedri> quaid, job is enabled
14:08:47 <quaid> knesenko: I know we couldn't move Mailman to OpenShift in the past because of iirc problems with blacklists and smtp on AWS
14:09:06 <quaid> eedri: ah-ha! is it redundant?
14:09:42 <eedri> quaid, i enabled it so people can have a look before i take down the slave
14:09:48 <eedri> quaid, i can disable it
14:09:49 <quaid> oic
14:10:23 <knesenko> quaid: k
14:10:49 <knesenko> quaid: I think we can end the meeting
14:10:56 <quaid> sounds good
14:11:21 <quaid> #action Infra team needs to discuss migration plan on mailing list
14:11:27 <quaid> anything more?
14:11:40 <knesenko> yes ... but not related to the meeting
14:11:52 <quaid> #endmeeting