14:00:43 <mburns> #startmeeting oVirt Weekly Meeting
14:00:43 <ovirtbot> Meeting started Wed Oct 30 14:00:43 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:43 <fabiand_> backblue, best is to raise your problems on the mailinglist ..
14:00:59 <mburns> #topic Agenda and roll call
14:01:06 <mburns> #info 3.3 update releases
14:01:11 <mburns> #info 3.4 planning
14:01:19 <mburns> #info conferences and workshops
14:01:23 <mburns> #info infra update
14:01:28 <mburns> #info other topics
14:01:35 <backblue> fabiand_, i'm assuming all my problems it's my fault... because it's all basic problems.
14:02:14 <mburns> backblue: with the vdsm image that fabiand_ just pointed to, there is an ovirt engine screen that will help with the registration/approval process
14:02:22 <fabiand_> backblue, well - it can still be that you run into bugs. And the mailinglist is friendly :)
14:02:29 <mburns> backblue: you can set a password there (if you want) or simply register
14:02:43 * sbonazzo here
14:02:43 <mburns> and then approve through the engine UI
14:03:06 * danken already said he's here.
14:06:45 <backblue> nodes with "ovirt-node-iso-3.0.1-1.0.2.vdsm.el6" installed save the network changes made from the engine interface, it's set's them in the boot processo (in the network init script) but somewhere in the rest of the boot it mess's up the config and lose them all again, every reboot the nodes comes up with "!networks unreachable"
14:07:09 <mburns> #topic oVirt 3.3 updates
14:07:18 <mburns> #info 3.3 beta was posted last week
14:07:22 <mburns> #undo
14:07:22 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9b9bcec>
14:07:26 <mburns> #info 3.3.1 beta was posted last week
14:08:08 <mburns> #info all pending bugs have patches that are merged
14:08:15 <mburns> #info new build coming today
14:08:16 <danken> is anyone our of new issues?
14:08:21 <danken> anyone testing it?
14:08:44 <danken> I'd like to ask ybronhei to build vdsm with an selinux hack.
14:08:52 <mburns> danken: ack
14:09:03 <mburns> #info ybronhei to build vdsm with one additional fix (for selinux issues)
14:09:15 <ybronhei> here
14:09:22 <mburns> #info fabiand_ to build new ovirt-node images once vdsm is ready
14:09:32 <mburns> #undo
14:09:32 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9b81acc>
14:09:35 <mburns> #undo
14:09:35 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9b9b08c>
14:09:41 <mburns> #action ybronhei to build vdsm with one additional fix (for selinux issues)
14:09:46 <mburns> #action fabiand_ to build new ovirt-node images once vdsm is ready
14:10:00 <mburns> #action sbonazzo to build new ovirt-engine
14:10:08 <sbonazzo> mburns: ok
14:10:29 * fabiand_ agrees
14:10:30 <fabiand_> :)
14:10:31 <mburns> #info tentative plan is to have some testing this week, and release early next week (assuming no issues)
14:12:08 <mburns> #action mburns to send notice of new packages out once they're available
14:12:17 <samppah> any info about using gluster storage domain with rhel 6.5 nodes?
14:12:33 <mburns> if anyone finds issues with the new packages, please let us know asap
14:12:53 <mburns> samppah: rhel 6.5 beta should work with gluster storage domains
14:13:19 <mburns> we're working on a solution for 6.4 based el6 distros
14:13:41 <samppah> mburns: we spoke about week ago that it's using fuse instead of qemu-gluster
14:13:49 <mburns> oh, that issue
14:14:04 <mburns> i'm not sure if there was a solution for that yet
14:14:17 <mburns> danken: do you know anything about this issue?
14:15:29 <danken> mburns: I am afraid I only have a vague memory of this.
14:15:34 <YamakasY> I have discovered that 3.3 has lots of issues with Foreman!
14:15:42 <danken> el6.5 is not yet out samppah.
14:15:55 <danken> do you see the problem with el6.4.z as well?
14:15:55 <mburns> samppah: probably best to follow up on users@ovirt.org
14:15:57 <samppah> danken: yeh, i have been testing with beta
14:16:11 <danken> with which version of vdsm? ovirt-3.3.1 beta?
14:16:16 <samppah> http://lists.ovirt.org/pipermail/users/2013-October/017263.html do you want me to do bug report for this?
14:16:25 <samppah> danken: 3.3.1 beta
14:17:02 <danken> sahina: do you have any idea?
14:17:31 <mburns> danken: it's a known issue, itamar was talking about this at the workshop last week
14:18:13 <danken> mburns: samppah but is it specific to el6.5, or does it show as well on 6.5.z?
14:18:18 <danken> 6.4.z, I mean.
14:18:34 <backblue> found out that installing ovirt-node in disks with pre-existing partitions fails...
14:18:35 <mburns> danken: native gluster domains don't work at all on 6.4.z
14:19:13 <sahina> danken, i know there was an issue - but not sure if it was resolved
14:19:32 <sahina> danken, will follow up on this
14:20:14 <mburns> #action sahina to follow up on gluster domains using fuse instead of native gluster
14:20:35 <mburns> anything else for 3.3.x?
14:20:48 <danken> samppah: would you reply to your own message ton users@ with a chunk of your vdsm.log?
14:20:50 <itamar> mburns: i thought this was fixed in 3.3.1?
14:21:11 <itamar> mburns: oh, but not on 6.4.
14:21:12 <danken> I find the connectStorageServer and connectStorageDomain logs most interesting
14:21:20 <mburns> itamar: i don't know -- i haven't followed exactly what is being fixed in 3.3.1
14:22:11 <samppah> danken: sure.. i'll need to leave soon, but i'll try to gather logs later today
14:22:17 <danken> samppah: but frakly,  everything from vmCreate till the the domxml is geenrated is interesting too.
14:24:20 <itamar> danken - is the libgfapi regression fixed in 3.3.1?
14:26:02 <danken> itamar: I'm afraid I am not even aware of the regression.
14:26:14 <danken> sahina might know ^^^
14:26:59 <mburns> it's all the same issue -- sahina is already going to followup on this
14:27:54 * lvernia here...
14:28:29 * mburns would like to move on
14:28:35 <mburns> #topic ovirt 3.4 release
14:28:49 <mburns> #info code freeze is at end of December
14:28:55 <itamar> danken: it was a one liner in one of eduardo's patches. could be it was only in master.
14:28:56 <mburns> #info Release set for end of January
14:29:33 <sbonazzo> mburns: do we have a release managmente page for it?
14:29:35 <mburns> #info still need to do some work to get a list of features committed for this release
14:29:44 <mburns> sbonazzo: i haven't created one yet
14:29:59 <itamar> sbonazzo: i sent a 3.4 planning google doc for feature planning.
14:30:18 <itamar> sbonazzo: but we do need a version feature page, even if linking for it.
14:30:34 <mburns> sbonazzo: can you create the page?
14:30:54 <sbonazzo> mburns: ok
14:31:00 <itamar> the google doc is public, idea is people can put themselves as owners, add more items, etc.
14:31:10 <danken> itamar: do you recall who worked on that? surely not edu.
14:31:13 <itamar> well, moderated public, they need to ask for read/write access.
14:31:27 <mburns> #action sbonazzo to create 3.4 release management page
14:31:33 <itamar> danken: allon mureinik found the regression in some specific build with eduardo's patches.
14:31:42 <itamar> I'm looking for the actual patch.
14:31:49 <mburns> #info with links to itamar's feature planning doc
14:33:31 <mburns> #info more details on exact dates, builds, beta, test days, etc to come in the next few weeks
14:34:19 <mburns> anything else for 3.4
14:34:20 <mburns> ?
14:35:24 <mburns> #topic Conferences and Workshops
14:35:41 <mburns> #info big developer meetup last week during KVM Forum/LinuxCon EU
14:35:59 <mburns> #info many talks, many sessions across all the conferences/workshops/meetings
14:36:22 <mburns> #info itamar sent a writeup already detailing the event
14:36:42 <mburns> #undo
14:36:42 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9abaecc>
14:36:42 <itamar> was a great event!
14:36:53 <mburns> #info itamar sent a writeup already detailing the event to the ovirt mailing lists
14:37:34 <mburns> #info planning for future presentations and workshops is underway, but no details just yet
14:37:55 <itamar> mburns: devroom in FOSDEM open for CFP
14:38:18 <mburns> #info there will be a devroom at FOSDEM and it's open for CFP now
14:38:42 <mburns> #info plan is to have at least a few oVirt related talks there
14:39:39 <itamar> mburns: and hopefully a booth
14:39:42 <mburns> any other upcoming events that we need to highlight?
14:39:48 <mburns> #info and hopefully a booth as well
14:40:52 <JosueDelgado> Hello all
14:41:02 <mburns> #topic Infra updates
14:41:04 <SvenKieske> Hi
14:41:07 <apuimedo> JosueDelgado: hi
14:41:13 <JosueDelgado> hi :)
14:41:21 <mburns> eedri_: ewoud any updates from the infra team?
14:42:00 <danken> samppah: the bug you report may be the same as BugĀ 1022961 -        Running a VM from a gluster domain uses mount instead of gluster URI
14:42:01 <danken> ?
14:42:36 <JosueDelgado> is there someone who can help me with an ovirt/gluster issue?
14:42:39 <SvenKieske> just a question regarding mailinglist behaviour: could you please send out a message to respect proper quoting? I see lots of mails where dozens of lines get quoted unnecessary, it's really hard to read those mails.
14:44:17 <danken> SvenKieske: what do you mean by "proper quoting"? (/me actually likes dozens of quoted lines for reference and context)
14:44:22 <mburns> #info no updates from infra team this week, please see their meeting minutes for updates
14:44:26 <mburns> #topic Other topics
14:44:33 <mburns> anything else for this weeking this week?
14:44:58 <itamar> mburns: bottom line on 3.3.1 - waiting on vdsm for a few last patches?
14:45:29 <SvenKieske> you really don't do full quoting, if you want context, switch your mail client to a threaded view. oO you just want to quote the stuff you reply to. at least filter out all those signatures, no reason to quote them.
14:45:32 <mburns> itamar: vdsm engine and node will all have rebuilds today (hopefully) with tentative release set for early next week
14:45:43 <mburns> obviously node will wait for vdsm
14:46:48 <itamar> mburns: vdsm will need to wait on the patches i think... sandro - can you send a daily status email on 3.3.1 status (engine -ready, vdsm - awaits BZ X, Y, node - pending vdsm, etc.)
14:47:02 <itamar> sbonazzo: --^
14:47:09 <sbonazzo> mburns: we need to improve jenkins monitoring
14:47:13 <SvenKieske> https://en.wikipedia.org/wiki/Posting_style#Choosing_the_proper_posting_style
14:47:26 <danken> SvenKieske I personally delete quoted signatures and general junk. But I don't think the mailing list can do it automatically.
14:47:28 <sbonazzo> itamar: do we have a tracker for vdsm pending patches / bugs?
14:47:44 <sbonazzo> mburns: it's more than a week that vdsm nightly are not built
14:48:02 <mburns> sbonazzo: should just be a single tracker for the release
14:48:07 <sbonazzo> mburns: just noted the issue and ohad already working on it
14:48:12 <mburns> vdsm issues should be included on the 3.3.1 tracker
14:48:16 <mburns> sbonazzo: ok, good to know
14:48:22 <mburns> and good that someone is on it already
14:49:23 <danken> mburns: why issues, with an "s"?
14:49:24 <sbonazzo> itamar: ok, I'll send a daily email, I just need to have vdsm bugs blocking the tracker
14:49:31 <danken> I am aware only of the glusterfs issue.
14:49:57 <itamar> danken: fsimonce mentioned one other bug.
14:50:00 <mburns> danken: was a general statement
14:50:19 <mburns> if there are issues (0 or more), they should be on the release tracker
14:51:08 <SvenKieske> danken: I know, you can't enfore some special quoting style on everyone, and I'm fine with that, but some quoting on the ML just gets horrible, it's just sad as I can't read through all the "context" to get to the actual message, this will lead to people not getting help because they quote 100 lines just to say: "I can reproduce this problem" etc.
14:51:50 <sbonazzo> itamar: we'll still build ovirt-engine 3.3.1 today?
14:52:09 <mburns> sbonazzo: no reason to wait, i don't think
14:52:15 <mburns> if everything is fixed
14:52:15 <itamar> sbonazzo: +1
14:52:37 <mburns> ok, if no other topics, let's close the meeting
14:52:41 <mburns> #endmeeting