15:05:28 <knesenko> #startmeeting oVirt Infra
15:05:28 <ovirtbot> Meeting started Mon Nov 25 15:05:28 2013 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:41 <knesenko> #chair obasan orc_orc ewoud dcaro
15:05:41 <ovirtbot> Current chairs: dcaro ewoud knesenko obasan orc_orc
15:05:46 <knesenko> eedri: here ?
15:07:29 <knesenko> #topic Hosting
15:07:37 <knesenko> dcaro: can you update us on rackspace
15:07:38 <knesenko> ?
15:08:47 <dcaro> knesenko: right now I have no connectivity to the server, but I have access to the iDRAC console, but the keyword does not work for me there :S (never has before), I'm right now messing with the options trying to get lucky
15:09:24 <knesenko> thanks dcaro
15:10:42 <knesenko> nothing else on hosting I think
15:11:21 <knesenko> #info still blocked on ovirt03 because iDRAC doesn't works for us
15:11:43 <knesenko> #action update a ticket on rackspace and raise its priority
15:11:56 <knesenko> #topic Foreman and Puppet
15:12:22 <knesenko> news ?
15:12:44 <ewoud> well, the r10k migration mostly went well
15:13:23 <dcaro> ewoud: mostly? ¬¬
15:13:30 <ewoud> had some issues I already fixed, but the master - production envs problem is still here
15:13:42 <knesenko> ewoud: which problem ?
15:14:12 <ewoud> with the current config we map a git branch to a puppet environment
15:14:29 <YamakasY> jvandewege: around ?
15:14:36 <knesenko> ewoud: ok ...
15:14:36 <ewoud> so master branch means master environment
15:14:50 <ewoud> we can solve it in a few ways
15:14:52 <dcaro> yeah, I preferred master -> production, but I'll adapt to anything
15:15:19 <ewoud> rename branch, rename environment or change deployment to be static
15:15:38 <knesenko> why not to use master as development and create a production branch for production ?
15:15:57 <ewoud> I suggested the first so when you are writing for production
15:16:28 <ewoud> that's possible as well, but right now we don't have a dev env
15:16:40 <knesenko> ewoud: yes correct
15:17:00 <ewoud> so it would create extra work for no benefit right now
15:17:08 <knesenko> ok
15:17:39 <ewoud> so any objections to renaming the branch? other alternatives I forgot?
15:17:55 <knesenko> ewoud: I don't care .... dcaro ?
15:19:43 <dcaro> I just prefer (it's a habit) to have the stable code in master, but as I said, I'll adapt
15:20:02 <knesenko> dcaro: usually stable is not master :)
15:20:08 <knesenko> dcaro: but nm
15:20:09 <knesenko> :)
15:20:27 <knesenko> #action ewoud rename the puppet branch
15:20:32 <knesenko> anything else here ?
15:20:50 <ewoud> I plan on upgrading foreman to 1.3 one of these days
15:20:55 <dcaro> knesenko: actually until I joined redhat all the repos I used had master as the stable branch
15:21:35 <knesenko> dcaro: :)
15:21:50 <knesenko> #info ewoud is planning to upgrade foreman to 1.3
15:21:52 <dcaro> knesenko: I supposed that based on this -> http://nvie.com/posts/a-successful-git-branching-model/
15:22:26 <ewoud> dcaro: yes, but we don't really have releases for our infra
15:22:28 <iggywig123> so what's best to run ovirt engine on F19 or Centos 6?
15:22:49 <ewoud> iggywig123: I think it depends on your preference
15:23:09 <knesenko> ok ...
15:23:13 <knesenko> what else here ?
15:23:26 <iggywig123> I prefer centos but I'm having major iscsi issues using centos/ovirt hypervisor
15:23:32 <iggywig123> I set up a F19 node and it works great
15:23:39 <apuimedo> knesenko: did you see that I replied about the pyinotify thing?
15:23:50 <ewoud> knesenko: yes
15:23:57 <knesenko> apuimedo: yes thanks !
15:24:01 <apuimedo> ;-)
15:24:04 <apuimedo> you're welcome
15:24:04 <ewoud> knesenko: we should still set up a job to automate the deployment after a merge
15:24:18 <knesenko> ewoud: jenkins one ?
15:24:36 <dcaro> knesenko: ewoud Yep, I prefer a jenkins job
15:24:39 <ewoud> knesenko: it's as simple as ssh puppet-repos@foreman.ovirt.org so jenkins should be fine
15:24:43 <dcaro> at least for the checks
15:25:06 <ewoud> sort of how I also designed it
15:25:18 <ewoud> but first the branch renaming should be fixed
15:25:28 <knesenko> #info ewoud open a ticket to create a jenkins job to automate the deployment after a merge on puppet
15:25:55 <knesenko> #action work on ticket to create a jenkins job to automate the deployment after a merge on puppet
15:25:57 <ewoud> knesenko: I think https://fedorahosted.org/ovirt/ticket/71 should do
15:27:05 * knesenko is looking
15:27:21 <knesenko> ewoud: ok I"ll handle it tomorrow
15:28:04 <knesenko> ok ... good
15:28:08 <ewoud> knesenko: I think that's it for foreman + puppet now
15:28:15 <knesenko> #topic Jenkins
15:28:17 <ewoud> some open patches, but working on them
15:28:47 <knesenko> #info finished with upgrade_params job for engine upgrade
15:28:55 <knesenko> so I think we can merge - http://gerrit.ovirt.org/#/c/21094/
15:29:12 <knesenko> BTW we catch 2 bugs with this job
15:29:22 <knesenko> once they will be fixed, job should be stable
15:29:29 <knesenko> who can merge - http://gerrit.ovirt.org/#/c/21094/ ?
15:29:45 * ewoud can't
15:29:50 <knesenko> dcaro: ?
15:30:12 <dcaro> knesenko: looking at the patch
15:30:52 <knesenko> dcaro: ok
15:31:07 <dcaro> knesenko: only eedri and fabian deutsh have privileges to merge it
15:31:19 <knesenko> I think we are going to disable f18 builds and upgrade them to f20
15:31:25 <knesenko> dcaro: am I right ?
15:31:43 <knesenko> #action eedri to merge http://gerrit.ovirt.org/#/c/21094/
15:31:54 <dcaro> knesenko: +1
15:32:14 <knesenko> #info we are going to disable f18 builds
15:32:37 <knesenko> #action upgrade/reinstall all f18 slaves to f20
15:33:31 <knesenko> ok ...
15:33:40 <knesenko> anything else on jenkins ?
15:34:24 <ewoud> I think there are quite a few tickets open on jenkins
15:34:43 <ewoud> can we walk through them and close where it's already fixed?
15:36:04 <ewoud> (doesn't have to happen now)
15:36:05 <knesenko> ewoud: I will work on tickets/jenkins/infra tickets tomorrow
15:36:08 <ewoud> brb
15:37:51 <ewoud> knesenko: ok
15:38:12 <knesenko> #topic Other Business
15:38:18 <knesenko> orc_orc: hello ... are you ok ?
15:38:21 <orc_orc> knesenko: a lot of them are space constrained -- would a phone call to solve the Rackspace issue be in order?
15:39:00 <knesenko> orc_orc: I think we are going to escalate this issue
15:39:00 <orc_orc> knesenko: fine and actually got a local F19 based ovirt test usint working in the local bench farm
15:39:10 <orc_orc> a centos based one eludes me
15:39:13 <knesenko> orc_orc: good !
15:39:27 <knesenko> orc_orc: did you managed to work on monitoring with obasan ?
15:39:31 <orc_orc> I sure felt better, as I wanted to write some auto-deploy and test integration
15:39:37 <knesenko> orc_orc: do you have permissions to access the machines?
15:39:56 <orc_orc> knesenko: U have the process down but wanted to test locally before sending my puppet crednetial upstream
15:40:17 <orc_orc> so I have no blockers atm
15:40:29 <knesenko> k
15:40:42 <knesenko> anything else guys ?
15:40:57 <ewoud> speaking of trac; can we improve it?
15:41:23 <ewoud> should our milestones be linked to oVirt releases? should we drop versions altogether?
15:41:34 * ewoud is looking at https://fedorahosted.org/ovirt/report/1
15:41:36 <dneary> ewoud, I like versions
15:42:03 <ewoud> dneary: but we don't really have a version other than production I think
15:42:39 <knesenko> #chair dneary
15:42:39 <ovirtbot> Current chairs: dcaro dneary ewoud knesenko obasan orc_orc
15:42:43 <dneary> ewoud, You're right
15:43:08 <ewoud> also, https://fedorahosted.org/ovirt/wiki should really mention that it's for oVirt infra
15:43:55 <knesenko> ewoud: can you update it ?
15:44:01 * ewoud is on that now
15:44:55 <knesenko> #info ewoud updating https://fedorahosted.org/ovirt/wiki to mention it's related to oVirt infra
15:45:16 <ewoud> knesenko: please check now to see if it's good enough
15:45:53 <ewoud> dneary: while you're here, didn't you or someone else fix https://fedorahosted.org/ovirt/ticket/12 (spam filtering for lists.ovirt.org)?
15:46:13 <knesenko> ewoud: great !
15:46:55 <knesenko> ewoud: dneary  i think its fixed
15:47:06 <Rydekull> o7
15:48:11 <knesenko> ok
15:48:18 <knesenko> so I think we are done
15:48:25 <Rydekull> Heh, just when I arrive :-P
15:48:32 <knesenko> Rydekull: hello :)
15:48:37 <Rydekull> hello hello
15:48:51 <knesenko> Rydekull: we started 50 min ago
15:49:14 <knesenko> Rydekull: you are more than welcomed to join us next meeting
15:49:16 <Rydekull> I know, but I've said for a long time that this is a very inconvenient time for me. Seeing as I have $work and $othermeetings :-)
15:49:37 <knesenko> Rydekull: :(
15:49:50 <Rydekull> I do what I can to get here though :-)
15:50:13 <knesenko> Rydekull: we appreciate your help !
15:50:47 <knesenko> #endmeeting