14:01:18 <fabiand> #startmeeting oVirt Node Weekly Meeting
14:01:18 <ovirtbot> Meeting started Tue Dec 10 14:01:18 2013 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:18 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:25 <fabiand> #chair jboggs mburns rbarry
14:01:25 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:01:30 <fabiand> #topic Agenda
14:01:30 * rbarry_ here
14:01:40 <fabiand> #info el6 ISO
14:01:46 <fabiand> #info Fedora 20 port
14:01:47 * jboggs here
14:01:57 <fabiand> #info Other items
14:02:04 <fabiand> #undo
14:02:04 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9bb898c>
14:02:04 <YamakasY> yo, me is here!
14:02:15 <fabiand> #info Image wrapper rpm
14:02:19 <fabiand> #info Other
14:02:23 <fabiand> #topic el6 ISO
14:02:34 <fabiand> Hey, rbarry, jboggs , YamakasY
14:02:44 <YamakasY> I have seen that my 3.3.1 install sometimes stops or suspends VM's... ade also told me that he had it on 3.3.0
14:02:48 * alitke is here
14:03:08 <fabiand> I planned to do the el6 respin over the last week - but I didn't find time to do it.
14:03:08 <YamakasY> fabiand: hellow
14:03:11 <fabiand> alitke, hey!
14:03:21 <fabiand> #info fabiand did not build el6 ISO
14:03:36 <jboggs> fabiand, there is an el6 bug I fiuxed yesterday
14:03:40 <jboggs> er fixed
14:03:50 <fabiand> There is also a thread on the users-ml discussing Node
14:04:00 <fabiand> jboggs, nice to know - in gerrit?
14:04:22 <jboggs> yep, its a bootloader issue so el6 installs would fail anyway
14:04:49 <fabiand> okay
14:05:04 <fabiand> I also did a fix to fix the el6 auto-builds
14:05:12 <fabiand> this brings us closer to a el6 build
14:05:21 <fabiand> #info jboggs fixed an el6 bootloader issues
14:05:32 <fabiand> #info fabiand fixed el6 auto-builds
14:05:51 <fabiand> I'd target a respin for the coming week again
14:06:00 <YamakasY> is btw the glusterfs issue resolved by the ovirt repo itself ?
14:06:07 <YamakasY> I was on that this week also
14:06:10 <fabiand> YamakasY, have you got a bugzilla link
14:06:12 <fabiand> ?
14:06:39 <YamakasY> fabiand: yap
14:06:43 <YamakasY> just a sec
14:06:46 <fabiand> So, basically we can be in a good shape, just needs a build and testing
14:06:57 <YamakasY> fabiand: yes we are
14:07:07 <fabiand> #info el6 ISO needs build and testing
14:07:11 <YamakasY> some hangs with VM's only on starting and running
14:07:24 <fabiand> okay
14:07:37 <fabiand> #action fabiand to do respin until Dec 17
14:07:49 <fabiand> #topic Fedora 20 port
14:07:57 <fabiand> rbarry, any update here?
14:08:12 <YamakasY> fabiand: https://bugzilla.redhat.com/show_bug.cgi?id=1033587
14:08:25 <rbarry> I got an image built, which is basically sane, but needs more testing and trimming
14:08:34 <rbarry> Something in the F20 build process is pulling in a lot of extraneous packages
14:08:55 <rbarry> And our specfile is going to get messier, but the amount o fchanges seems relatively low
14:09:05 <fabiand> YamakasY, seems as if that bugs is VERIFIED
14:09:11 <YamakasY> fabiand: yes but not fixed
14:09:17 <rbarry> Unversioned docs, requiring /usr/bin/hostname instead of /bin/hostname, and we get a 220MB image
14:09:22 <fabiand> YamakasY, just a matter of time
14:09:28 <fabiand> rbarry, okay ..
14:09:30 <YamakasY> fabiand: hurry hurry!
14:09:31 <YamakasY> :P
14:09:31 <rbarry> Still testing and tweaking, but it should easily be done by next week
14:09:37 <YamakasY> fabiand: it's confusing
14:09:42 <YamakasY> and very simple to solve
14:09:50 <fabiand> rbarry, okay - did you need any f20 related packages?
14:10:06 <fabiand> s/packages/patches/
14:10:38 <rbarry> We *might* need selinux-policy-doc, but that's not F20 specific. The only patch we need is related to BZ 999584, as far as I've discovered
14:11:33 <rbarry> But it's a pretty straightforward port
14:11:39 <fabiand> rbarry, okay - that doesn't sound to bad :)
14:12:48 <fabiand> #info Fedora 20 port seems to be straight forward, some adjustments and exlusions
14:13:10 <fabiand> rbarry, could you also drive the effort to setup a jenkins job for the fedora 20 builds?
14:13:31 <fabiand> Which might not be time critical ..
14:13:32 <rbarry> fabiand: That's the plan ;)
14:13:40 <fabiand> yey
14:13:42 <fabiand> :)
14:13:56 <fabiand> #action rbarry to drive Fedora 20 jenkins job for Node
14:14:16 <fabiand> okay
14:14:34 <fabiand> #topic Image wrapper rpm
14:15:04 <fabiand> #info fabiand got hands on creating wrapper rpm
14:15:29 <fabiand> I was about to build the wrapper rpms when I noted that the ISO name of the vdsm is different then previously
14:15:38 <fabiand> This could be a problem for oVirt Engine.
14:15:52 <fabiand> Especially beccause the RPM name differs from what is written in /etc/system-release
14:16:30 <fabiand> A solution is to rename the vdsm iso to the name of the base image iso, but I didn't want to follow that path to quick .
14:16:39 <fabiand> But we might not get around this.
14:16:51 <fabiand> jboggs, do you know if the /etc/system-release file in an edited iso is modified?
14:17:20 <jboggs> it adds an indicator if it was edited and or signed packages were used
14:17:28 <fabiand> okay ..
14:17:33 <fabiand> I think that is fine
14:17:47 <fabiand> There is still the problem that we will have to iso images having the same name
14:17:51 <fabiand> (vdsm iso and base image iso)
14:18:23 <fabiand> There is still a positive side: The vdsm iso will only be named like this within the wrapper rpm.
14:18:26 <fabiand> Still - this is not nice.
14:19:22 <fabiand> The idea: Rename ISO to match Engines naming expectations and add a README to wrapper rpm
14:19:30 <fabiand> Long term: Work with Engine to also accept other ISO names
14:20:26 <fabiand> Also: Add a hint to the filename of  a base image iso, to indicate that it's a base image
14:20:46 <fabiand> basically nvr-<type>.iso
14:20:52 <fabiand> nvr-bi.iso
14:20:54 <fabiand> nvr-vdsm.iso
14:20:57 <fabiand> something like this
14:21:25 <fabiand> #action fabiand to open bug to discuss with Engine people about the naming of isos and related constraints
14:21:44 <fabiand> #action fabiand to create wrapper rpm with renamed VDSM iso and README
14:21:50 <fabiand> #topic Other
14:21:59 <fabiand> anything else someone wants to bring up? :)
14:22:06 <fabiand> rbarry, jboggs, alitke, YamakasY ?
14:22:21 <alitke> nothing for me... Just lurking today.
14:22:33 <jboggs> nothing here
14:22:35 <fabiand> alitke, sounds good - keep lurking :)
14:22:35 <YamakasY> uhm, not yet, yes some good docs for spice setup would be good
14:22:39 <rbarry> Nothing here
14:22:48 <fabiand> right
14:22:59 <fabiand> # action YamaskY to write good docs for spice setup ;)
14:23:09 <fabiand> YamakasY, ^^
14:23:11 <fabiand> thanks
14:23:16 <fabiand> #endmeeting