13:06:34 <knesenko> #startmeeting oVirt Infra
13:06:34 <ovirtbot> Meeting started Mon May 12 13:06:34 2014 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:34 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:06:34 <dcaro> /19
13:06:42 <knesenko> #chair eedri|mtg dcaro
13:06:42 <ovirtbot> Current chairs: dcaro eedri|mtg knesenko
13:06:47 <knesenko> anyone else ?
13:08:34 * eedri|mtg here
13:08:42 <eedri|mtg> ewoud, orc_orc_ bkp ?
13:08:44 <ewoud> eedri|mtg: pong
13:08:56 <eedri|mtg> ewoud, we'd like to do the meeting now, if that's ok
13:09:17 <bkp> eedri|mtg Still here
13:09:31 <ewoud> eedri|mtg: I'll be here, but not sure if I can interact that much
13:09:31 <knesenko> #chair bkp
13:09:31 <ovirtbot> Current chairs: bkp dcaro eedri|mtg knesenko
13:09:40 <knesenko> #chair ewoud
13:09:40 <ovirtbot> Current chairs: bkp dcaro eedri|mtg ewoud knesenko
13:10:01 <knesenko> ok lets start
13:10:06 <xevilstar> hello world
13:10:14 <knesenko> first topic will be Hosting today
13:10:14 <ewoud> FYI: I'm quite busy at $dayjob finishing up before I change employer in about 2 weeks
13:10:29 <knesenko> ewoud: oh .. good luck then
13:10:41 <ewoud> when that settles down, I hope to have more time for oVirt again
13:11:10 <ewoud> knesenko: just ping me if you need me
13:11:15 <knesenko> ewoud: k
13:11:26 <knesenko> thanks
13:11:31 <knesenko> #topic Hosting
13:11:32 <ewoud> the same goes for out of meetings btw
13:11:42 <knesenko> eedri|mtg: want to update us ?
13:11:50 <eedri|mtg> knesenko, yes
13:12:05 <eedri|mtg> knesenko, got some good news, we finally have phx lab hosts setup in the rack
13:12:30 <eedri|mtg> knesenko,  next step is to install operating system and plan the new layout there
13:13:02 <knesenko> #info new lab in phx is ready
13:13:14 <eedri|mtg> knesenko, not quite ready... in terms of usaage
13:13:26 <eedri|mtg> knesenko, hardware is ready, there still much work to be done
13:14:11 <eedri|mtg> knesenko, we'll start working on installing base OS, and communicate the final layout to the list as soon as it's ready
13:14:28 <eedri|mtg> knesenko, plan is to have 2 DC's there, one for production and one for jenkins
13:14:34 <knesenko> eedri|mtg: yeah ... that's what i meant by saying ready
13:14:35 <knesenko> :)
13:14:52 <eedri|mtg> knesenko, we also have new storage server there, which holds around 14TB
13:15:23 <eedri|mtg> knesenko, dcaro probably can update on other hostsing issues, like os1
13:15:55 <knesenko> eedri|mtg: we want to apply some kind of mirroring for the storage right ?
13:17:15 <dcaro> eedri|mtg: os1 is still failing, some of the already existing servers have the root as ro, and I'm unable to get it rw, the new vms are in error status and I'm unable to start them, and happens something similar with 1 of each 2 volumes (as the default ephemeral dis has been shriked to 20GB, I'm trying to add an extra volume of 100GB for the workspaces)
13:18:26 <eedri|mtg> knesenko, yes, using DRBD
13:18:59 <eedri|mtg> dcaro, any insignt on the irc/mailing lists of thise?
13:19:26 <dcaro> eedri|mtg: no response yet, I sent an email to the list, let me check if the admin is on irc
13:19:27 <eedri|mtg> it means we can't run any critical infra on it if it's not relaiable enough..
13:19:41 <eedri|mtg> so we should limit thier usage to specific usage only
13:20:38 <knesenko|mtg> eedri|mtg: agree
13:20:58 <knesenko|mtg> what else do we have on hosting ?
13:21:09 <eedri|mtg> knesenko|mtg, dcaro can improve / add new slaves if we can enable foreman proxyu
13:21:16 <eedri|mtg> to reinstall some of the rackspace slaves
13:21:21 <knesenko|mtg> eedri|mtg: when do we plan starting the migration ?
13:21:37 <eedri|mtg> knesenko|mtg, let's hope that by early next week
13:21:47 <eedri|mtg> knesenko|mtg, we should finialize the layout this week and agree on it
13:21:57 <dcaro> ewoud: I'm stuck trying to get foreman-proxy to play along with dnsmasq from libvirt, do you have any experience on that?
13:22:00 <eedri|mtg> knesenko|mtg, not migration for phase 1
13:22:07 <eedri|mtg> knesenko|mtg, we'll start it in parallel for starts
13:22:13 <knesenko|mtg> eedri|mtg: ok
13:22:26 <ewoud> dcaro: I do not
13:23:37 <eedri|mtg> ewoud, anyone else can help from community?
13:23:47 <eedri|mtg> ewoud, maybe worth asking on theforeman irc?
13:24:26 <ewoud> eedri|mtg: dcaro I'd be willing to look into it
13:24:34 <eedri|mtg> ewoud, that'll be great
13:24:42 <eedri|mtg> ewoud, we really need that for the new lab
13:24:48 <dcaro> ewoud: thanks, in the works case a small vm with foreman proxy should be ok
13:24:50 <eedri|mtg> ewoud, especially if we're planning to run dhcp there as well
13:27:14 <knesenko|mtg> ok
13:27:27 <knesenko|mtg> so I assume nothing else on hosting
13:27:27 <ewoud> dcaro: let's have a look somewhere after the meeting
13:28:01 <knesenko|mtg> #action dcaro ewoud are going to take a look on foreman-proxy for a new lab
13:28:33 <eedri|mtg> fabiand, you want to join the meeting?
13:30:06 <knesenko|mtg> what next >/
13:30:06 <knesenko|mtg> ?
13:30:17 <eedri|mtg> knesenko|mtg, jenkins?
13:30:20 <knesenko|mtg> do we have something new on foreman or puppet ?
13:30:29 <knesenko|mtg> i assume we don't
13:30:36 <eedri|mtg> dcaro, ?
13:30:49 <knesenko|mtg> so I will skip this section if there is nothing new there
13:30:56 <knesenko|mtg> #topic Jenkins
13:31:03 <dcaro> nop, still waiting on the review for the puppet service patch
13:31:05 <knesekno> #topic Jenkins
13:31:18 <knesekno> eedri|mtg: try to change the topic
13:31:25 <eedri|mtg> #topic Jenkins
13:31:45 <knesekno> weird ... related to my nick
13:31:46 <knesekno> ok
13:31:51 <knesekno> can you char me ?
13:31:56 <knesekno> #chair knesekno
13:31:56 <eedri|mtg> #chair knesekno
13:31:56 <ovirtbot> Current chairs: bkp dcaro eedri|mtg ewoud knesekno knesenko
13:31:58 <knesekno> ok
13:32:13 <knesenko> ok
13:32:15 <knesenko> lets go
13:32:24 <knesenko> dcaro: we have new mock style jobs right ?
13:33:11 <dcaro> yes, it's been some weeks since we started using mock on a job, now we have a few using it to generate the rpms
13:33:36 <knesenko> dcaro: what a re the benefits of using mock ?
13:33:44 <knesenko> instead of regular jobs ?
13:33:47 <knesenko> we used to have
13:34:49 <dcaro> knesenko: mock allows you to install specific versions of packages when building the jobs and let's you 'mock' the architecture and flavour of the packages it builds for (they share kernel though)
13:35:10 <knesenko> dcaro: chroot env right ?
13:35:10 <dcaro> knesenko: so cenos slaves can build fedora packages for i686 or x86_64
13:35:19 <dcaro> knesenko: yes chroot, similar to cocker
13:35:24 <knesenko> dcaro: nice
13:35:38 <knesenko> #info dcaro applied new mock style jobs for building pkgs
13:35:50 <dcaro> knesenko: /7
13:36:23 <knesenko> we had some outage today with os1 slaves right ?
13:37:25 <knesenko> do we have something else on jenkins ?
13:37:28 <dcaro> knesenko: not just today, it's been affecting us since friday
13:37:37 <knesenko> eedri|mtg: something that should be done ?
13:37:41 <dcaro> knesenko: and it's not solved yet, we are not the only ones affected
13:37:42 <knesenko> urgent tasks etc ?
13:37:53 <knesenko> dcaro: yes yes ... heard that
13:37:58 <eedri|mtg> dcaro, any major updates?
13:38:07 <eedri|mtg> dcaro, docker/slaves/upgrades?
13:38:29 <dcaro> jenkins is using a custom build throttle plugin, don't update it if you see it on the available for update list
13:38:50 <dcaro> the maintainer is trying to get the patches merged into the plugin, but it's not there yet
13:39:37 <knesenko> #info do not update  build throttle plugin since we are using a custom one
13:39:40 <dcaro> eedri|mtg: knesenko also, we need fedora 19 slaves
13:39:55 <knesenko> dcaro: all of them are gone with os1 right ?
13:39:56 <knesenko> :\
13:41:25 <dcaro> knesenko: well, no, but the others are pinned for functional jobs or faling
13:41:56 <knesenko> dcaro: eedri|mtg how can we solve it /
13:41:56 <knesenko> ?
13:42:02 <knesenko> dcaro: any eta on os1 ?
13:42:07 <knesenko> dcaro: or nothing from their side
13:42:17 <dcaro> knesenko: they did not say anything yet
13:42:26 <knesenko> understood
13:43:03 <knesenko> ok lets move on then
13:43:39 <dcaro> knesenko: can I use rackspace03.ovirt.org as a normal fedora19 slave?
13:43:49 <knesenko> dcaro: I don't use it
13:43:55 <dcaro> (its a build-slave only right now)
13:44:02 <dcaro> who is using it then?
13:44:11 <dcaro> eedri|mtg: ?
13:44:24 <eedri|mtg> dcaro, i think no one is using it, we can take it
13:44:30 <eedri|mtg> dcaro, and leverage it as we please
13:44:33 <knesenko> dcaro: need to check if its used as hypervisor on rackpsace setup
13:44:35 <knesenko> if not - use it
13:44:38 <eedri|mtg> dcaro, until we'll setup the phx2 lab
13:45:44 <dcaro> knesenko: it's wehre I was trying to install the proxy, so it has vdsm and foreman-proxy on it (not sure if it's conncted to any engine)
13:46:11 <knesenko> dcaro: I don't think its connected
13:46:27 <knesenko> I don't reme,ber somebody intsalled it
13:46:28 <knesenko> :)
13:46:47 <knesenko> so we will have now one more fc19 slave
13:47:27 <knesenko> #action dcaro use rackspace03 as regular fc19 slave
13:47:35 <eedri|mtg> dcaro, can't you use mock on f18 to mock f19 ;)
13:47:39 <knesenko> ok anything else here ?
13:47:48 <knesenko> eedri|mtg: here ...
13:47:51 <knesenko> hehehe
13:47:54 <knesenko> ment hehehe
13:47:56 <ccowley> hi all, been unavailable for a few weeks. Will lurk and get up to date on what is going on
13:48:28 <dcaro> eedri|mtg: yes I can :), but ovirt-engine is not mocked yet (as some other jobs) and they require the different flavours :/
13:48:59 <eedri|mtg> dcaro, really? i was just kidding ;)
13:49:10 <eedri|mtg> dcaro, any other important jenkins issues?
13:50:00 <knesenko> eedri|mtg: what else do we want to discuss ?
13:50:19 <eedri|mtg> knesenko, i saw a request for power user on the list
13:51:16 <dcaro> eedri|mtg: knesenko http://etherpad.ovirt.org/p/build_discussion  <- I wanted to give some thought to this
13:51:39 <eedri|mtg> knesenko, topic build?
13:51:56 <eedri|mtg> knesenko, there were some updates no?
13:52:03 <eedri|mtg> knesenko, sign rpms and split release ..
13:52:19 <knesenko> mmmm ...
13:52:46 <knesenko> yes there are some updates
13:53:13 <knesenko> dcaro: ok ... this pad is new for me
13:54:27 <dcaro> knesenko: I sent a email to the list last week, to get some feedback on the issue and try to decide the way to go
13:54:29 <knesenko> eedri|mtg: dcaro want to discuss it ?
13:54:40 <knesenko> dcaro: sorry I missed that
13:55:25 <eedri|mtg> knesenko, yea
13:55:41 <eedri|mtg> knesenko, and you can also update on the lastest build system and requests for builds
13:55:46 <eedri|mtg> knesenko, like jrs also
13:56:15 <knesenko> eedri|mtg: dcaro i"ll put my comments in the pad
13:57:59 <knesenko> if nothing else here, I will update the build pad ....
13:58:05 <knesenko> and will continue next week
13:58:05 <knesenko> ?
13:58:06 <eedri|mtg> knesenko, other build topics?
13:58:10 <eedri|mtg> knesenko, or updates..
13:58:39 <knesenko> I don't remember if we already discussed that
13:58:45 <knesenko> but i will update
13:58:50 <eedri|mtg> knesenko, ok
13:59:23 <knesenko> #info all official releases will be signed, so users will be able to verify rpms are comming from oVirt team
13:59:48 <knesenko> #info ovirt-release rpms was splited into 2 rpms. ovirt-release33 and ovirt-release34
14:00:03 <knesenko> users should use a specific rpm to get a specific versio
14:00:04 <knesenko> n
14:00:34 <knesenko> #info we don't ship repo files for nightly repos, users should configure those repos amnually
14:00:43 <knesenko> that's all I think
14:02:27 <knesenko> ok thank you guys
14:02:31 <knesenko> have a nice week all
14:02:34 <knesenko> #endmeeting