13:01:47 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:01:47 <ovirtbot> Meeting started Tue Jun 10 13:01:47 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:47 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:01 <fabiand> #chairs jboggs rbarry
13:02:07 * jboggs here
13:02:10 <fabiand> #topic Agenda
13:02:18 * rbarry here
13:02:18 <fabiand> #info Build status (3.0.5)
13:02:31 <fabiand> #info Feature Status (3.5)
13:02:35 <fabiand> #info Other Items
13:03:03 <fabiand> morning jboggs and rbarry
13:03:13 <fabiand> #topic Build Status (3.0.5)
13:03:50 <fabiand> #info ovirt-node-3.0.5 has been build, available here: http://plain.resources.ovirt.org/pub/ovirt-node-base-3.0/
13:03:56 <fabiand> #info Release email pending
13:03:58 <bkp> fabiand: Here
13:04:03 <fabiand> bkp, hey!
13:04:16 <fabiand> bkp, nice to see you!
13:04:33 <fabiand> oVirt 3.5 alpha 2 will be based on 3.0.5
13:04:39 <fabiand> oVirt 3.4.2 will be based on 3.0.4
13:04:52 <fabiand> That's it from me on this item
13:05:22 <fabiand> #topic Feature Status for oVirt 3.5
13:05:45 <fabiand> rbarry, jboggs fabiand do you want to give an update on this, maybe in alphabetical order?
13:05:55 <jboggs> sure
13:06:13 <fabiand> #info oVirt Virtual Appliance - Plain image can be built, with all needed dependencies
13:06:31 <fabiand> Next steps, finish OVA build and push to gerrit
13:06:47 <fabiand> #action fabiand to finish OVA builds and push current state to gerrit
13:06:52 <fabiand> That's it from me
13:06:53 <jboggs> hosted engine plugin is awaiting review in its own repo, the needed support in ovirt-node side has already been merged
13:07:16 <fabiand> argh
13:07:29 * fabiand does not monitor other projetcs
13:07:36 <rbarry> I must not get emails about the new repo either, didnt' see it
13:07:45 <fabiand> #info HE plugin is awaiting review in gerrit, ovirt-node side part got merged
13:08:12 <rbarry> Generic registration has been submitted and merged
13:08:20 <fabiand> #undo
13:08:20 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8c6f92c>
13:08:25 <rbarry> Won't be used in plugin-vdsm until 3.6 probably, though
13:08:26 <fabiand> #info HE plugin - Awaiting review in gerrit, ovirt-node side part got merged
13:08:51 <fabiand> #info Generic registration - Node side implementation got merged, but is currently unused.
13:09:00 <fabiand> rbarry, well, it has time to mature through the whole 3.5 cycle
13:09:33 <fabiand> In general this look quite good
13:09:47 <fabiand> We now just need to put all the pieces together ..
13:10:27 <rbarry> I'm more concerned about running into incompatibilities with older versions of Engine which don't support the new registration protocol, since generic registration is much simpler than vdsm-reg and won't do much without support from the engine side
13:10:53 <fabiand> rbarry, sure
13:11:09 <fabiand> rbarry, it probably needs some sensible approach to sort out when the new mechanism is used
13:11:23 <fabiand> we have got a similar issue with Satellite
13:11:29 <fabiand> (3 different registration protocols IIRC)
13:11:36 <fabiand> jboggs might correct me here
13:11:56 <fabiand> rbarry, we might even consider it then only for 4.0
13:11:59 <jboggs> yeah just driven by a selection box
13:12:04 <fabiand> where we could introduce something disruptive
13:12:13 <fabiand> jboggs, yep
13:12:34 <fabiand> rbarry, did you express your concerns on some ml?
13:13:17 <rbarry> No, just a conversation with dougsland. I should probably compose an email to devel@
13:13:26 <fabiand> Yeah. I think that would make sense.
13:14:07 <fabiand> #action rbarry to drop an email to devel@ to discuss the introductio and compatability issues of the generic registration
13:15:40 <fabiand> Ok ..
13:16:08 <fabiand> Well, we'll need to do a release - banched off master, to land the new features in 3.5
13:16:56 <fabiand> Okay
13:17:03 <fabiand> the beta is scheduled to happen in ~2 weeks
13:17:06 <fabiand> #link http://www.ovirt.org/OVirt_3.5_release-management
13:17:38 <fabiand> oh well.
13:17:44 <fabiand> we could even do it different
13:17:48 <fabiand> HE is a plugin
13:17:50 <fabiand> so independent
13:18:03 <fabiand> and geneirc registration is also standalone
13:18:08 <fabiand> so we could backport it to 3.0
13:18:20 <fabiand> but otoh .. there ain't much keeping us from branching of 3.1
13:18:49 <fabiand> Let's keep that in sight for next week.
13:19:07 <fabiand> #topic Other Items
13:19:07 <rbarry> As long as we backport the node changes (NM_CONTROLLED.../etc) for HE
13:19:13 <fabiand> yep
13:19:29 <fabiand> We'd need to ackport the node side patch jboggs came up with
13:20:04 <fabiand> That actually reminds me to use merge commits :) - to better see what commits are bound logically together
13:20:10 <fabiand> but I think it was just one patch in this case.
13:20:31 <fabiand> #info Consider a new release for 3.1 to be fresh and deliver the features
13:20:31 <jboggs> yeah just one
13:20:34 <fabiand> ok
13:20:39 <fabiand> so it wouldn't be to bad.
13:20:49 <jboggs> and just a few oneliners
13:21:18 <fabiand> oh now it's getting messy :)
13:21:51 * fabiand tends more towards a release
13:21:57 <fabiand> anyhow
13:22:16 <fabiand> Anything else you'd like to bring up jboggs rbarry bkp ?
13:22:22 <rbarry> No, I'm good
13:22:29 <jboggs> im good
13:22:29 <bkp> Nope
13:22:35 <fabiand> There we go
13:22:38 <fabiand> Thanks
13:22:40 <fabiand> Going
13:22:41 <fabiand> Eins
13:22:43 <fabiand> Zwei
13:22:44 <fabiand> Drei
13:22:46 <fabiand> #endmeeting