14:01:33 <bkp> #startmeeting oVirt Weekly Sync
14:01:33 <ovirtbot> Meeting started Wed Jul  2 14:01:33 2014 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:33 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:47 <lvernia> bkp: We have different definitions for "party" :p
14:02:33 <bkp> #topic Agenda and Roll Call
14:02:33 <bkp> #info infra update
14:02:33 <bkp> #info 3.4.z updates
14:02:33 <bkp> #info 3.5 status
14:02:33 <bkp> #info conferences and workshops
14:02:34 <bkp> #info other topics
14:03:03 <bkp> #topic infra update
14:03:10 <bkp> dcaro, what's up?
14:03:12 * lvernia is here.
14:03:25 * amureini is here for storage, sorry for the tardiness - traffic
14:03:25 <clarkee> jvandewege: thanks.
14:03:45 <bkp> no worries, amureini, just started
14:05:21 <bkp> Anyone here from infra?
14:05:49 <bkp> dcaro?
14:06:02 * dcaro here
14:06:30 <bkp> What's the word from infra, dcaro?
14:07:02 <alonbl> SvenKieske: so have you tested it?
14:07:15 <alonbl> SvenKieske: maybe you can just take this away from me... :)
14:07:20 <dcaro> working on new jobs for the new projects and 3.5 branch,  still working on phx machines, and started yamlizing more and more jobs (22 right now)
14:07:27 <danken> amureini: you should install an irc client int your car's phone ;-)
14:08:08 <amureini> danken, have you ever seen my phone?
14:08:37 <bkp> #info infra working on new jobs for the new projects and 3.5 branch
14:08:48 <bkp> #info infra still working on phx machines
14:08:56 <bkp> #info infra started yamlizing more and more jobs (22 right now)
14:09:09 <bkp> Any other news from infra, dcaro?
14:09:33 <dcaro> that's all more or less (were working on the beta release most of the time)
14:09:46 <bkp> Coolness. Moving on...
14:09:53 <bkp> #topic 3.4.z updates
14:10:16 <bkp> sbonazzo, what do you have?
14:10:39 <bkp> Hold on, not here...
14:11:05 <bkp> #info Nothing to report for 3.4.z updates this week.
14:11:06 <tiraboschi> sbonazzo is on PTO
14:11:18 <bkp> So I just saw.
14:11:30 <bkp> #topic 3.5 status
14:12:01 <bkp> Is anyone else from integration here?
14:12:19 <tiraboschi> me
14:12:40 <bkp> What do you have tiraboschi?
14:13:07 <tiraboschi> no, nothing to add
14:13:57 <bkp> No blockers for integration to report? I see there are two exceptions granted... any word on status?
14:15:02 <tiraboschi> Didi is working on that
14:15:11 <didi> status is:
14:15:21 <SvenKieske> alonbl: no I have not tested this myself, I got no test setup with a second host in a second DC and no time, and my dev system is in maintenance anyway :(
14:15:36 <alonbl> SvenKieske: I have the same problem
14:15:37 <didi> all relevant changes verified on fedora 19, and somewhat-older versions reviewed,
14:15:54 <didi> still awaiting verification on fedora 20 (because some changes affect only it)
14:16:07 <didi> bkp: ^^
14:16:40 <bkp> didi Ack
14:17:19 <didi> bkp: hopefully will be finished tomorrow
14:17:31 <tiraboschi> as far as today no any blocker on other features from first test day
14:18:10 <bkp> #info 3.5 status integration all relevant changes verified on fedora 19, and somewhat-older versions reviewed
14:18:18 <bkp> #info 3.5 status integration still awaiting verification on fedora 20 (because some changes affect only it) hope to be finished by July 3
14:18:26 <bkp> #info 3.5 status integration No new blockers from first 3.5 test day
14:18:34 <bkp> Great, thanks!
14:18:52 <bkp> Let's move on to network. lvernia?
14:18:57 <lvernia> bkp: Hello.
14:19:17 <lvernia> bkp: There's the one blocker we talked about last week, which is on POST.
14:19:20 <bkp> Hey, lvernia
14:19:41 <lvernia> bkp: Haven't yet gone over all the new bugs from the test day, but at the moment no blocker candidate as far as I'm aware.
14:20:05 <bkp> Could you clarify POST for me?
14:20:11 <danken> lvernia: except for our previously-known ovirt-node issue
14:20:22 <lvernia> danken: Yes, see my first sentence.
14:20:32 <lvernia> bkp: Means some work is already up on gerrit.
14:20:36 <danken> bkp***
14:21:05 <danken> bkp but it depends on work by node (also posted)
14:21:18 <bkp> Right, missed the shorthand.
14:22:04 <lvernia> bkp: So other than that, I think there's no news from us.
14:22:23 <bkp> lvernia, Excellent, thanks.
14:22:25 <bkp> #info 3.5 status network ovirt-node blocker still in progress, in POST.
14:22:36 <bkp> #info 3.5 status network No new blockers found in 3.5 test day
14:23:12 <bkp> Moving on to virt...
14:23:39 <bkp> mskrivanek, anything to report?
14:23:44 <mskrivanek> hmm
14:23:52 <lvernia> bkp: None yet... Might be a differenty story next week after we'll have gone over all of them...
14:23:53 <mskrivanek> nothing comes to my mind
14:24:13 <mskrivanek> except the thing from last week about the hyper_v support. patches in progress
14:24:30 <mskrivanek> oh, and a cool video demonstrating live migration progress in UI!:)
14:24:39 <bkp> Yes, I saw that.
14:25:00 <bkp> Sure to be nominated for an award. :)
14:26:13 <bkp> mskrivanek, was that the discussion around virtio-rng?
14:26:28 <bkp> (Re: HyperV)
14:26:44 <bkp> lvernia: Noted.
14:26:55 <lvernia> bkp: Thanks :)
14:27:11 <bkp> #info 3.5 status network Amend: No new blockers found in 3.5 test day as of yet.
14:27:35 <bkp> #info 3.5 status virt Hyper_v support, patches in progress
14:27:36 <mskrivanek> no, not about virtio-rng...that's ready. last piece was merged this week (disabling it:)
14:28:01 <bkp> Awesome.
14:28:22 <bkp> #info 3.5 status virt virtio-rng ready, last piece merged this week
14:28:39 <bkp> Was that all, mskrivanek?
14:30:09 <bkp> I will assume so.
14:30:52 <mskrivanek> yes, i'm finished:)
14:31:12 <bkp> Okay, infra, who's on deck?
14:31:23 <bkp> oved, any news?
14:32:11 <bkp> Hm... not on.
14:32:29 <bkp> Anyone from infra have info on 3.5 status?
14:33:42 <bkp> Okay, will keep moving... how about node? fabiand?
14:34:56 <danken> bkp: for the record, I am aware of several infra issue
14:35:10 <bkp> I will take what you have.
14:35:14 <bkp> danken ^^^
14:35:24 <danken> there's several bugs reported on pkliczew's jsonrpc
14:35:54 <danken> and there's a bug in setting auth_sasl in libvirtd.conf
14:36:02 <amureini> danken, yup - was waiting for my turn to report them in storage's context `-) you beat me to it
14:36:36 <bkp> I wonder if we should wait, then.
14:36:43 <danken> and there's also two ioprcess  bugs (also reported by storage)
14:37:06 <danken> amureini: storage folks found them, but they should be solved by infra...
14:37:26 <amureini> danken, bkp ^^^ agtreed, +1.
14:37:38 <danken> moolit1: are you on top of the vdsm-tool sasl thingy?
14:37:53 <amureini> bkp, danken also there a several regression around the Command context recent refactoring. It showed up in storage flows, but I wouldn't be surprised if it appears in others too (especially virt flowS)
14:38:38 <amureini> just to give a full/fair picture, I'd like to not pkliczew and rnori's responsiveness and short-circle handling of these issues
14:38:39 <danken> amureini: that's in Engine. I do not know about that.
14:38:53 <amureini> danken, doesn't mean it doesn't happen `-)
14:39:10 <amureini> * like to note, of course
14:40:35 <bkp> So, these bugs were found... what is the status of getting them fixed, and are they to be classified as blockers?
14:40:55 <amureini> bkp command context is a blocker. jsonrpc is a blocker.
14:41:14 <amureini> bkp, ioprocess is a semi-blocker - it doesn't work, but can be removed via configuration.
14:42:35 <amureini> bkp to translate - state today: reconstruct master is broken. GetDeviceList is broken. Live Storage Migration is broken. All of these are due to infra work. They were reported and are being worked on, but I can't estimate an ETA of the fixes - oved will have to do that.
14:43:00 <bkp> Well, that's helpful.
14:44:16 <bkp> #info 3.5 status infra/storage several bugs reported on pkliczew's jsonrpc [Blocker]
14:44:24 <bkp> #info 3.5 status infra/storage there's a bug in setting auth_sasl in libvirtd.conf
14:44:24 <bkp> #info 3.5 status infra/storage two ioprcess  bugs (also reported by storage) [semi-blocker]
14:44:24 <bkp> #info 3.5 status infra/storage Several regressions around the Command context recent refactoring. It showed up in storage flows, but I wouldn't be surprised if it appears in others too (especially virt flowS) [Blocker]
14:44:24 <bkp> #info 3.5 status infra/storage Summary: Reconstruct master is broken. GetDeviceList is broken. Live Storage Migration is broken. All of these are due to infra work. They were reported and are being worked on, ETA unknown.
14:44:51 <bkp> danken: Was that all you had for infra issues?
14:46:08 <bkp> amureini: Anything else from storage?
14:46:59 <amureini> bkp, a couple of nits from the test day, but the major ones were included in the previous statement about infra work.
14:47:13 <bkp> Noted.
14:47:39 <bkp> Okay, swinging back to Node... fabiand or anyone from the node team?
14:48:53 <bkp> #info 3.5 status node Nothing reported this week
14:49:09 <bkp> Moving on to SLA... who's representing this week?
14:49:20 <msivak> I am
14:49:46 <bkp> msivak, what's the news from SLA?
14:50:31 <msivak> we have many patches stuck on review, there are some bugs from test day, but I haven't seen anything really serious
14:51:05 <msivak> basically we need virt and infra to help reviewing numa and cpu tune on the engine side
14:52:17 <msivak> I haven't seen any issues regarding hosted engine and iscsi so I assume we are good enough there
14:52:27 <bkp> #info 3.5 status sla Many patches stuck on review, there are some bugs from test day, but nothing really serious
14:52:35 <bkp> #info 3.5 status sla basically SLA needs virt and infra to help review numa and cpu tune on the engine side
14:52:43 <bkp> msivak, anything else?
14:52:52 <amureini> msivak, did anyone report that he+iscsi was tested successfully?
14:53:21 <gpadgett> amureini: I was working on it and ran into something else, will resume as soon as I get past that stumbling block
14:53:44 <amureini> gpadgett, thanks
14:54:00 <msivak> gpadgett: thanks, I was wondering about that
14:54:11 <bkp> Okay, let's move on to vdsm
14:54:38 <bkp> Who's here for vdsm?
14:54:49 <danken> everybody!
14:55:43 <bkp> Okay danken, what do all those voices in your head have to share about vdsm and 3.5?
14:55:44 <danken> bkp: do we need a specific vdsm review?
14:56:00 <bkp> danken: Not sure, just going down my list
14:56:19 <danken> we mentioned a lot of vdsm bugs (sla's log spam included)
14:56:32 <danken> so we are not ready
14:57:16 <danken> I hope that our blockers are solvable by next week
14:57:21 <danken> but I am not sure
14:57:33 <msivak> danken: patch posted for that, I need a machine to verify :/
14:58:13 <bkp> #info 3.5 status vdsm Still aiming for blockers to be solved by next week
14:58:21 <bkp> Thanks, danken
14:58:32 <bkp> Any thing from gluster?
14:59:55 <bkp> #info 3.5 status gluster Nothing to report this week.
15:00:14 <bkp> Last by not least, ux. News on 3.5?
15:00:29 <ecohen|mtg> bkp, sent you an e-mail with the status (in a different meeting)
15:01:18 <bkp> Ah, I see it now. Two secs...
15:02:14 <bkp> #info 3.5 status ux sorting infra: due to ongoing debates on the patches + maintainer's absence will be ready only by the end of this week, or early next week.
15:02:15 <bkp> #info 3.5 status ux PatternFly packaging: in good progress, will hopefully be ready by the end of this week or early next week.
15:02:15 <bkp> #info 3.5 status ux Italian translation: still in progress. ETA: depends on the translator (current Italian translation completion status is ~25%).
15:02:31 <bkp> Thanks, ecohen|mtg
15:02:35 <ecohen|mtg> bkp, np
15:03:29 <bkp> Moving on...
15:03:30 <bkp> #topic conferences and workshops
15:03:35 <SvenKieske> general info: I'm happy to see many new testers testing things, however I'm under the impression that most of the tests where rather quick and didn't test the whole feature, but encouraged the assumption the feature was tested..
15:03:54 <SvenKieske> I hope my assumption is wrong, sorry for interruption, bkp
15:04:21 <bkp> Let's table that after this topic. One minute, SvenKieske
15:04:32 <bkp> #info A number of oVirt team members have been accepted for Fossetcon in Orlando this September.
15:04:32 <bkp> #info There may be an opportunity to have a "Red Hat" track, where projects such as oVirt will get even more chances for presentation. Negotiation now.
15:04:32 <bkp> #info We *will* have a booth presence at USENIX LISA in November
15:04:42 <bkp> Now, moving on...
15:04:49 <bkp> #topic other topics
15:05:04 <amureini> bkp, re: USENIX - need a hand there?
15:05:36 <bkp> amureini: Yes, very much. gshereme will also be assisting
15:05:59 <amureini> bkp, nice. I assume the preference is for US residents?
15:06:19 <bkp> amureini: Nope, anyone who can get here.
15:07:00 <bkp> SvenKieske, can you send me an email detailing your concerns?
15:07:02 <amureini> bkp nice. will take it up with you off-list, no need to spam the meeting (more than I already have, that is)
15:07:19 <bkp> amureini Use your phone :)
15:07:23 <bkp> #info ECS has delivered mediawiki formatted documentation in the form of an administrator's guide, a user's guide, and an installation guide.
15:07:23 <bkp> #info bkp is working on converting from RHEL to oVirt, if anyone wants to help, let me know and I will send you the links to the draft documents
15:07:23 <bkp> #info bkp IRC availability will be sporadic this week due to power outage at his home. Email contact is best.
15:07:44 <bkp> Does anyone else have anything else to add?
15:07:52 <lvernia> bkp: Let's discuss the test day a little...
15:08:08 <bkp> Fire away.
15:08:21 <lvernia> SvenKieske: I think that's usually true for test days.
15:08:47 <lvernia> Not sure if devs make for good QA, especially when they're not deeply familiar with the features.
15:09:16 <lvernia> However, I do feel that a lot of the features this test day were kinda half-***ed.
15:09:33 <SvenKieske> bkp: I will, thanks for looking into it!
15:10:00 <amureini> lvernia, I submit the contrary. Being unfamiliar with a feature allows you to see the little things everyone else is blind to. Last test day I submitted over a dozen bugs on an area I never used. In retrospect, most of them have been there since 2.2
15:10:24 <amureini> lvernia, this isn't to say that the efforts of some testers weren't half-***ed, as you put it
15:10:31 <SvenKieske> suggestion as blocker for 3.5 release: https://bugzilla.redhat.com/show_bug.cgi?id=1115543 also the various other bugs that popped up during test day, I guess not all testers bothered to add them as blockers..
15:10:36 <lvernia> amureini: I'm not talking about testers really.
15:10:40 <lvernia> amureini: More about feature owners.
15:10:51 <lvernia> Not a lot of documentation on how to get things up and running for features.
15:10:51 <SvenKieske> following bugs@ovirt.org really pays off :)
15:11:29 <lvernia> Especially for features including integration with non-oVirt elements.
15:11:56 <amureini> SvenKieske, I concur. From a quick look, I'd say this is another aspect of the command context issue I addressed earlier
15:12:16 <SvenKieske> anyway, I really am impressed how many features got tested, no matter how deep they where tested, I guess this was the test day with the most testers so far for ovirt?
15:12:16 <bkp> lvernia: I feel the documentation pain.
15:13:07 <lvernia> bkp: But there was supposed to be preparation for the test day...
15:13:13 <SvenKieske> amureini: might very well be true, thanks for pointing it out and taking care of it :)
15:13:39 <lvernia> bkp: It was communicated well in advance, so I don't understand how there was no documentation on how to start testing some features.
15:14:39 <bkp> lvernia: I will investigate before the next test day. This may be on me.
15:14:55 <lvernia> bkp: I don't think it is.
15:15:04 <amureini> bkp, lvernia perhaps we were missing some followup? e.g., in the status meeting X weeks before each stake holder should report preparedness for his features being tested?
15:15:18 <bkp> #action bkp Discover status/process of test day documentation
15:15:22 <lvernia> amureini: Yes, that might have improved things.
15:15:41 <lvernia> amureini: And I can't remember, but was that the case in previous test days?
15:16:22 <amureini> lvernia, I don't think we ever did these status checks- doesn't mean it can't help `-)
15:16:28 <lvernia> Because I don't remember stumbling upon this kind of lack of documentation in the past (though that might have been circumstantial).
15:16:47 <lvernia> Maybe it's also an issue of having a lot of small features rather than a few big ones in 3.5.
15:16:57 <lvernia> But anyway, something to think about.
15:17:28 <amureini> lvernia, bkp  http://memegenerator.net/instance/52014177
15:17:33 <bkp> Noted. I would like to wrap the meeting, if I may, but let's keep going with the discussion.
15:17:46 <Netbulae> just to add my 2c, this one was nicely documented http://wiki.ovirt.org/Features/AdvancedForemanIntegration
15:17:53 <lvernia> bkp: Sure :)
15:17:56 <bkp> Thanks to all, see you next week!
15:17:59 <lvernia> amureini: :p
15:18:07 <bkp> Remember, the Force will be with you. Always.
15:18:14 <bkp> #endmeeting