14:03:28 <bkp> #startmeeting oVirt Weekly Sync
14:03:29 <ovirtbot> Meeting started Wed Jul  9 14:03:29 2014 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:29 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:50 * sbonazzo here for integration
14:03:53 <bkp> #topic Agenda and Roll Call
14:03:53 <bkp> #info infra update
14:03:53 <bkp> #info 3.4.z updates
14:03:53 <bkp> #info 3.5 status
14:03:53 <bkp> #info conferences and workshops
14:03:55 <bkp> #info other topics
14:04:05 * awels here for UX
14:04:16 <bkp> Good day to all, chime in for your group!
14:05:09 <bkp> Let's get the ball rolling.
14:05:10 <bkp> #info infra update
14:05:23 <bkp> Who's here for infra today?
14:05:23 * lvernia is here.
14:05:36 * misc is here but have not much to say
14:05:56 <misc> well, eedri managed to clean ressources.ovirt.org so the migration is less pressing
14:06:53 <dcaro> We also have the storage servers configured on PHX, and installing the hosted engine
14:07:06 <bkp> #info infra resources.ovirt.org cleaned so the migration is less pressing
14:07:08 <jvandewege> QuentinG: will be afk for a hour
14:07:14 * misc was looking for the minute
14:07:51 <bkp> #info infra storage servers configured on PHX, now installing the hosted engine
14:08:05 <bkp> Anything else, dcaro, misc?
14:08:37 * sbonazzo seen works started on jenkins jobs for 3.5 publisher
14:09:32 <bkp> #info infra work started on jenkins jobs for 3.5 publisher
14:10:03 <bkp> Is that it from infra this week?
14:11:11 <bkp> Okay, then, moving on...
14:11:36 <bkp> #topic 3.4.z updates
14:11:45 <sbonazzo> bkp: sent 3.4.3 status: http://lists.ovirt.org/pipermail/users/2014-July/025846.html this morning
14:11:53 <bkp> sbonazzo, welcome back, BTW
14:12:13 <sbonazzo> bkp thanks :-) no known blockers, some bugs proposed to be backported
14:12:46 <sbonazzo> bkp: rc scheduled for tomorrow, I've sent a few emails about issues found on jenkins jobs but we should be on track
14:13:19 <sbonazzo> danken: are you here? news about vdsm rpm build for 3.4?
14:13:19 <bkp> #info 3.4.z status oVirt 3.4.3 RC tomorrow *2014-07-10 08:00 UTC* from 3.4 branch.
14:14:15 <sbonazzo> fromani: ^^
14:15:28 <bkp> #info 3.4.z updates No known blockers, some bugs proposed to be backported
14:15:28 <bkp> #info 3.4.z updates RC scheduled for tomorrow, sbonazzo has sent a few emails about issues found on jenkins jobs but we should be on track
14:16:11 <sbonazzo> bkp I guess we'll have more updates on jenkins jobs later
14:16:21 <bkp> Okay.
14:16:44 <bkp> Is that it for 3.4.z, sbonazzo?
14:16:52 <sbonazzo> bkp: yes I think so
14:17:26 <bkp> #info 3.4.z updates More detailed status found at: http://lists.ovirt.org/pipermail/users/2014-July/025846.html
14:17:51 <bkp> Very well, moving along...
14:17:58 <bkp> #topic 3.5 status
14:18:03 <sbonazzo> bkp: sent 3.5 status this morning: http://lists.ovirt.org/pipermail/users/2014-July/025849.html
14:18:32 <sbonazzo> bkp due to increased number of bugs after test day, a new schedule has been proposed: http://lists.ovirt.org/pipermail/users/2014-July/025845.html
14:19:28 <danken> sbonazzo: I'm kinda here
14:19:43 <danken> sbonazzo: fromani found the problem you've mentioned
14:19:54 <danken> and yaniv promised me a backport and a build
14:20:03 <sbonazzo> danken: will the patch be available in tomorrow rc?
14:20:44 <sbonazzo> bkp: some blockers have been found for 3.5, detailed in the status email. I think it would be better review them
14:20:57 <danken> sbonazzo: I don't see it up, I'll backport it myself :-(
14:21:06 <sbonazzo> danken: +1
14:21:13 <bkp> sbonazzo: Review here?
14:21:21 <sbonazzo> bkp: I think so
14:22:17 <sbonazzo> bkp about the 3 on integration, they should be fixed before second beta
14:22:30 <bkp> Okay, well do for each group. I see integration has three blockers
14:22:35 <bkp> Whoops.
14:22:51 <bkp> #info 3.5 status integration Detailed status at http://lists.ovirt.org/pipermail/users/2014-July/025849.html
14:22:51 <bkp> #info 3.5 status integration New proposed schedule for 3.5 has been proposed. Shooting for a 8/26/14 GA  release of 3.5. See proposal here. http://lists.ovirt.org/pipermail/users/2014-July/025845.html
14:23:47 <bkp> #info 3.5 status integration Three blockers (1060198, 1073944, 1113974) to be fixed before second beta
14:23:56 <bkp> sbonazzo, anything else?
14:24:23 <sbonazzo> bkp: ovirt engine master is now on 3.6, 3.5 patches must be cherry picked to 3.5 branch
14:25:00 <sbonazzo> bkp, that's all on integration side
14:25:01 <bkp> #info 3.5 status integration ovirt engine master is now on 3.6, 3.5 patches must be cherry picked to 3.5 branch
14:25:16 <bkp> sbonazzo, thanks!
14:25:36 <bkp> Let's move things along...
14:25:43 <bkp> #topic 3.5 status ux
14:25:51 <bkp> awels, what do you have?
14:26:20 <awels> bkp: Hi, so the patternfly stuff was successfully removed from the source tree and is now available in separate rpm.
14:27:15 <awels> bkp: We have merged the remaining sorting infrastructure, and are in the process of merging the remaining patches that apply sorting to each individual tab. We are hoping to have them all merged by end of the week.
14:27:34 <awels> bkp: The Italian translation is about 30% done.
14:28:13 <awels> bkp: That is it from UX
14:28:25 <bkp> awels, Cool, thanks.
14:28:41 <lvernia> awels: All sorting patches will also have to be backported, won't they?
14:29:06 <awels> lvernia: All the ones that don't make it before the branch yes.
14:29:16 <lvernia> awels: The branch has been created.
14:29:28 <awels> lvernia: Then yes, they all have to be backported.
14:29:53 <lvernia> I presume they won't all be merged by the end of this week.
14:29:56 <bkp> awels: Timeline on that?
14:29:57 <lvernia> To the stable branch.
14:30:39 <awels> bkp: They first need to go into master, then each individual should backport them. Not sure on timeline but I would guess at least another week for that.
14:31:06 <bkp> Got it.
14:31:16 <bkp> #info 3.5 status ux patternfly code successfully removed from the source tree and is now available in separate rpm
14:31:16 <bkp> #info 3.5 status ux  merged the remaining sorting infrastructure, and are in the process of merging the remaining patches that apply sorting to each individual tab. We are hoping to have them all merged by end of the week.
14:31:16 <bkp> #info 3.5 status ux The Italian translation is about 30% done
14:31:16 <bkp> #info 3.5 status ux Sorting patches to be backported to the stable branch in a little over a week.
14:31:36 <bkp> #topic 3.5 status network
14:31:57 <lvernia> bkp: Hi!
14:31:58 <bkp> lvernia, what be the word?
14:33:03 <lvernia> bkp: No blockers yet.
14:33:18 <lvernia> bkp: A couple of bad ones from the test day though, which might be proposed as.
14:33:37 <bkp> lvernia: What about 1113091? sbonazzo had that on his list.
14:33:47 <bkp> (For network, that is)
14:34:00 <lvernia> Hang on, let me take a look.
14:34:06 <bkp> Ack
14:34:28 <lvernia> On POST already?
14:34:50 <bkp> That's what it says.
14:35:41 <lvernia> So not interesting to talk about, probably.
14:36:20 <lvernia> But danken, what about 1115001?
14:36:26 <bkp> #info 3.5 status network Bug 11133091 blocker in POST status.
14:36:27 <danken> sbonazzo: would you care to revew/test http://gerrit.ovirt.org/29786
14:36:27 <sbonazzo> lvernia: is on post since 2014-06-26 so maybe some hints on ETA will help :-)
14:36:35 <danken> it should silence your problem without solving it
14:37:16 <danken> lvernia: we did not make any advance on the BugĀ 1115001 -        Error code 23 when invoking Setup Networks front since yesterday
14:37:53 <lvernia> danken: Shouldn't it be considered a blocker?
14:38:11 <lvernia> danken: Or we haven't understood it enough to know?
14:39:41 <lvernia> bkp: At the moment no new blockers, to summarize.
14:40:01 <lvernia> sbonazzo: I'll see what's going on with 1113091.
14:40:12 <sbonazzo> lvernia: thanks
14:40:17 <bkp> lvernia: Slightly confused. ETA on 1113091?
14:40:38 <lvernia> bkp: Can't gauge at the moment, will update after the meeting.
14:41:26 <danken> lvernia: bkp: the patch is acked for 1113091
14:41:36 <danken> we just need to formally verify and backport
14:41:57 <danken> apuimedo can do it during his nap time
14:42:16 <apuimedo> danken: whose nap time?
14:42:19 <bkp> Cool, got it.
14:42:22 <bkp> #info 3.5 status network  BugĀ 1115001, Error code 23 when invoking Setup Network, being examined to see if it is a blocker
14:42:22 <bkp> #info 3.5 status network No *new* blockers to report.
14:42:22 <bkp> #info 3.5 status network Bug 1113091 fix ETA to be determined, patch acknowledged, just needs verification and backporting.
14:42:35 <bkp> Go back to sleep, apuimedo. :)
14:42:48 <apuimedo> bkp: sleeping is overrated
14:43:01 <bkp> I hear that. Moving on...
14:43:14 <bkp> #topic 3.5 status gluster
14:43:37 <bkp> There wasn't anything last week, but just to be sure...
14:44:28 <bkp> Any 3.5 news from the Gluster team?
14:45:53 <bkp> Okay, then, let's advance.
14:46:00 <bkp> #topic 3.5 status virt
14:46:16 <bkp> Virt team, what do you have?
14:48:57 <bkp> mskrivanek, 3.5 news for virt?
14:49:16 <bkp> #info 3.5 status gluster Nothing this week
14:50:29 <bkp> Fine, I will swing back to virt later.
14:50:42 <bkp> #topic 3.5 status storage
14:51:23 <bkp> Who's reporting for storage?
14:52:27 <bkp> amureini, 3.5 status?
14:52:53 <amureini> bkp, yikes, here, sorry.
14:53:49 <amureini> bkp - we're focusing on stabilization and bug fixes. Seems like /most/ of the infra issues we encountered last status will be solved once the master is rebased.
14:54:02 <amureini> bkp, basically on track with stabilization
14:55:22 <bkp> I have what may be a new blocker for storage? 1114057, uploaded iso is not visible in the engine. Status on that?
14:56:27 <ayates83> a couple of questions:  1. does anyone know if NetApp's virtual storage console will integrate with oVirt or just RHEV?  2- has there been a discussion yet about a RHEL7 / CentOS7 build of oVirt?  Thanks in advance!
14:56:58 <amureini> bkp, nothing new to report at this point, unfortunately.
14:57:06 <bkp> ayates83, Hang on a bit, conducting a meeting at the moment.
14:57:46 <bkp> amureini, thanks
14:57:56 <bkp> #info 3.5 status storage Bug 1114057, new blocker, no status to report
14:57:56 <bkp> #info 3.5 status storage focusing on stabilization and bug fixes. Seems like /most/ of the infra issues we encountered last status will be solved once the master is rebased.
14:58:16 <bkp> #topic 3.5 status infra
14:59:41 <bkp> Is anyone from infra team ready to report on 3.5 issues? I have three blockers listed on sbonazzo's 3.5 status email.
15:01:02 <sbonazzo> bazulay: here for infra?
15:01:25 <mskrivanek> bkp: sorry, not much news in virt
15:02:28 <bkp> I have one blocker listed, in POST status, for virt mskrivanek, 1110305. Status?
15:03:27 <mskrivanek> bkp: ah, yeah, still on review. maybe encourage reviewers:)
15:04:38 <bkp> #info 3.5 status virt Blocker bug 1110305 still in review. Reviewers, please advise status.
15:04:49 <bkp> Nothing from infra?
15:05:56 <bkp> Okay, let's get moving...
15:05:57 <bkp> #topic 3.5 status sla
15:06:23 <bkp> SLA, who's reporting?
15:06:50 <sbonazzo> msivak: here for sla?
15:07:27 <msivak> yep
15:08:06 <msivak> lets see.. there were couple of bugs from testday we need to fix (hosted engine, scheduling)
15:08:53 <msivak> two are important - 1114987 and 1093366
15:09:31 <bkp> msivak: Are they blockers, then?
15:09:33 <msivak> the features are getting there - we now have most of the patches verified and reviewed, final touches are being done
15:09:42 <msivak> the network one is test blocker
15:10:25 <msivak> the other one is quite serious, but I am not sure it is a blocker as it was there for some time and nobody complained too much
15:11:17 <msivak> + the log flood in vdsm is fixed and merged to master and submitted for 3.5 branch with verified flag already set
15:12:12 <bkp> Great, msivak, anything else?
15:12:20 <msivak> not at this moment
15:12:31 <bkp> Thanks!
15:12:34 <bkp> #info 3.5 status sla Fixing a couple of bugs from Test Day we need to fix (hosted engine, scheduling)
15:12:34 <bkp> #info 3.5 status sla 1114987 and 1093366 are high priority, as 1114987 is a test blocker and 1093366 is serious, but older and not generating a lot of complaints.
15:12:34 <bkp> #info 3.5 status sla features are getting there - we now have most of the patches verified and reviewed, final touches are being done
15:12:34 <bkp> #info 3.5 status sla The log flood in vdsm is fixed and merged to master and submitted for 3.5 branch with verified flag already set
15:12:48 <bkp> #topic 3.5 status node
15:12:58 <bkp> Node report? fabiand?
15:15:43 <bkp> Okay, moving on.
15:15:53 <bkp> #topic 3.5 status vdsm
15:16:05 <bkp> Anything from vdsm this week?
15:18:15 <bkp> Hm. Moving on.
15:18:24 <bkp> #info 3.5 status infra Nothing reported this week. Four blockers (1 new [1114994], 3 POST [1115044, 1115152, 1116009]) listed on bug tracker.
15:18:24 <bkp> #info 3.5 status node Nothing reported this week. No blockers listed.
15:18:24 <bkp> #info 3.5 status vdsm Nothing reported this week. No blockers listed.
15:18:38 <bkp> #topic conferences and workshops
15:18:47 <bkp> #info There will be a day-0 "Red Hat day" at Fossetcon in September. oVirt and other RH community projects will have a day to show off and give tech demos.
15:18:47 <bkp> #info we are all set for booth duty at OSCON in 2 weeks!
15:18:47 <bkp> #info Deadline for LinuxCon EU/CloudOpen/KVM Forum CfP is on July 11
15:18:59 <bkp> #topic other topics
15:19:08 <bkp> #info I will be opening up the new RHEV documentation on MediaWiki for everyone to help convert to oVirt documentation. This is a temporary solution, until we move ovirt.org to a GitHub-oriented solution.
15:19:08 <bkp> #info Thanks to Maor Lipchuck for putting together a Google Summer of Code blog for the Red Hat Community blog. Thanks to lots of folks for their input on the 3.5 preview blog that will be posted on the Community blog tomorrow. If anyone else has blog ideas (hint, hint)...
15:19:27 <bkp> Are there any other topics to go over?
15:19:59 <sbonazzo> bkp I think that's all
15:20:16 <bkp> Oh, there's one more thing...
15:20:24 <bkp> #action We need to get a little more coordinated on these weekly meetings. I know we are busy, but this should not take much more than one hour if everyone is set to go. Probably less.
15:21:38 <bkp> Let's keep in touch, and we'll see every team here next week, I hope.
15:21:46 <bkp> #endmeeting