14:01:10 <sbonazzo> #startmeeting oVirt Weekly Sync
14:01:10 <ovirtbot> Meeting started Wed Aug 13 14:01:10 2014 UTC.  The chair is sbonazzo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:21 <sbonazzo> #topic Agenda and roll Call
14:01:30 <sbonazzo> #info infra update
14:01:42 <sbonazzo> #info 3.4.z updates
14:01:49 <sbonazzo> #info 3.5 status
14:01:57 * awels is here for UX
14:02:01 <sbonazzo> #info conferences and workshop
14:02:12 <sbonazzo> #info other topics
14:02:18 * oved is here
14:02:24 * lvernia is here.
14:02:25 * amureini_ here for storage
14:02:32 <sbonazzo> #topic infra update
14:03:01 <sbonazzo> #chair awels oved lvernia amureini
14:03:01 <ovirtbot> Current chairs: amureini awels lvernia oved sbonazzo
14:03:39 <sbonazzo> dcaro orc_orc eedri news from infra?
14:03:52 * danken is here, too
14:04:05 * alitke is here
14:04:11 <sbonazzo> #chair danken alitke
14:04:11 <ovirtbot> Current chairs: alitke amureini awels danken lvernia oved sbonazzo
14:04:19 <dcaro> yep, we finally have everyrhing we need to start creating production vms on phx lab, starting today
14:04:40 <amureini_> dcaro, nice!
14:04:52 <dcaro> we will install the foreman-proxy that will help managing all of the machines in that network
14:05:00 <sbonazzo> #info infra has everything needed to start creating production vms on phx lab, starting today
14:05:44 <sbonazzo> #action infra to install foreman-proxy for managing all of the machines in that network
14:06:10 <sbonazzo> dcaro good, anything else?
14:06:35 <dcaro> nothing else appart from few failures and hiccups
14:06:54 <sbonazzo> dcaro ok, thanks. moving on
14:07:04 <sbonazzo> #topic 3.4.z updates
14:07:30 <sbonazzo> #link oVirt 3.4.4 status http://lists.ovirt.org/pipermail/users/2014-August/026685.html
14:07:51 <sbonazzo> #info still 10 bugs open
14:08:17 <sbonazzo> #info RC scheduled for 2014-09-09
14:08:47 <sbonazzo> #action maintainers to start filling release notes
14:09:06 <sbonazzo> anyone want to say something about 3.4.4 bugs still open?
14:09:14 <sbonazzo> #info no open blockers
14:09:18 <danken> the virt bug in your list is on the vrge of merge
14:09:33 <danken> sbonazzo: no idea why ybronhei did not merge it yet
14:10:06 <sbonazzo> danken: please ping him when he's back
14:10:13 <danken> now one actively works on the 3 network bugs, I'm afraid...
14:10:35 <danken> sbonazzo: I've been talking with him quite much today
14:11:01 <sbonazzo> fabiand: here?
14:11:54 <sbonazzo> ok, lets move on, we'll return on node for 3.5 later
14:12:05 <sbonazzo> #topic 3.5 status
14:12:26 <sbonazzo> #link oVirt 3.5.0 status http://lists.ovirt.org/pipermail/users/2014-August/026687.html
14:12:40 <sbonazzo> #info oVirt 3.5.0 RC2 postponed to monday
14:13:05 <sbonazzo> news about the blockers bug?
14:13:22 <oved> the infra one on the API will be solved by the end of the week.
14:13:22 <fabiand> sbonazzo, hey sorry, back now
14:13:42 <sbonazzo> #chair fabiand dcaro
14:13:42 <ovirtbot> Current chairs: alitke amureini awels danken dcaro fabiand lvernia oved sbonazzo
14:13:44 <oved> we're still checking the jsonrpc issue with connecting to the host.
14:14:00 <oved> (not in the bug list, as not sure whether it is an environmental issue or not).
14:14:25 <sbonazzo> fabiand: news about the node bugs for 3.4.4 ? (http://lists.ovirt.org/pipermail/users/2014-August/026685.html)
14:14:43 <fabiand> sbonazzo, no, we haven't anything critical from the node side
14:15:11 <sbonazzo> oved: ok, do you think you can get more info / a fix before monday build?
14:15:28 <sbonazzo> fabiand: thanks
14:15:28 <fabiand> sbonazzo, we moved those bugs out to 3.5
14:15:36 <oved> we'll do everything we can to find out the issue and have a fix if needed.
14:15:46 <oved> Ohad is helping us out with that.
14:15:52 <oved> Piotr as well.
14:15:59 <oved> and if needed Saggi will continue that on Sunday.
14:16:15 <sbonazzo> oved: ok
14:16:55 <sbonazzo> alitke: news about the other blockers?
14:17:28 <alitke> So, those two blockers for libvirt bugs should not be considered blockers for ovirt-3.5
14:17:34 <alitke> as mentioned in the email I sent
14:17:51 <alitke> I looked at them this morning and it seems we've removed the blocker for the release.
14:18:08 <alitke> I'll be managing those with the libvirt and qemu guys
14:18:35 <sbonazzo> alitke: I still see 2 blockers on you:
14:18:39 <alitke> I have a set of 6 vdsm patches (most are trivial) here http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:livemerge,n,z
14:18:40 <sbonazzo> alitke: Bug 1127294 -        Live Merge: Resolve unknown merge status in vdsm after host crash
14:18:51 <sbonazzo> alitke: Bug 1109920 -        Live Merge: Extend internal block volumes during merge
14:19:14 <alitke> yes, those will be resolved by committing changes at the above link to master and then backporting them to 3.5
14:19:15 <sbonazzo> alitke: will it make it for monday?
14:19:34 <alitke> as long as I can get appropriate attention from vdsm reviewers on those changes
14:19:54 <alitke> fromani has already begun to review, but still waiting for others
14:20:00 <sbonazzo> danken: can you help alitke gathering reviewrs attention?
14:20:15 <alitke> danken, fsimonce, nsoffer, et al
14:20:35 <nsoffer> alitke ?
14:21:07 <alitke> nsoffer, Hi, I am hoping you can take a look at http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:livemerge,n,z
14:21:12 <danken> and saggi, too, if he can
14:21:22 <sbonazzo> #action vdsm guys to review patch queue http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:livemerge,n,z
14:21:43 <nsoffer> alitke, sure
14:21:46 <alitke> That should clear the vdsm side of live merge for review
14:21:49 <alitke> for release
14:22:07 <alitke> I'll defer to gpadgett and rnori re the engine side.
14:22:35 <sbonazzo> ok. fsimonce fromani tal any other input on remaining blockers?
14:23:33 <fsimonce> sbonazzo, no, can you send out the list of the blockers after the meeting? thanks
14:23:57 <sbonazzo> fsimonce: see  http://lists.ovirt.org/pipermail/users/2014-August/026687.html
14:24:32 <fromani> sbonazzo: about https://bugzilla.redhat.com/show_bug.cgi?id=1127460 I agree with nsoffer, this is a very serious bug but not a VDSM regression. Evidence so far points to lower layers (qemu, lvm) and there is little room for a workaround in VDSM
14:24:49 <fromani> sbonazzo: so it should'nt be a blocker, IMO.
14:25:21 <sbonazzo> fromani: nsoffer: ok, so please remove it from blockers
14:25:22 <nsoffer> sbonazzo,  it is also happens on ovirt-3.4
14:25:28 <sbonazzo> #chair nsoffer fromani
14:25:28 <ovirtbot> Current chairs: alitke amureini awels danken dcaro fabiand fromani lvernia nsoffer oved sbonazzo
14:25:43 <danken> ykaplan: I see that Bug 1114499 -        refreshing iso list fails with: AttributeError: '_IOProcessFileUtils' object has no attribute 'validateQemuReadable'
14:25:43 <danken> got reopen
14:25:48 <danken> any idea why?
14:25:56 <fromani> sbonazzo: sure, will do.
14:26:01 <sbonazzo> fromani: thanks
14:26:09 <amureini_> sbonazzo,  wrt 1128776, there's another couple of them around the same area, unfortunately also in 3.4.z - working towards it, should be a blocker
14:26:24 <amureini_> (at least for the GA, if not for the rc ^^^)
14:27:02 <sbonazzo> amureini_: please add them to the tracker
14:27:11 <sbonazzo> #chair amureini_
14:27:11 <ovirtbot> Current chairs: alitke amureini amureini_ awels danken dcaro fabiand fromani lvernia nsoffer oved sbonazzo
14:27:45 <sbonazzo> ykaplan: around?
14:27:59 <sbonazzo> ok, moving on. We still have 418 bugs open for 3.5.0: http://red.ht/1q7SqNL
14:28:08 <ykaplan> danken, I was just looking at it
14:28:20 <sbonazzo> #action maintainers to review the remaining bugs for 3.5.0 and start retargeting them
14:28:28 <sbonazzo> #link http://red.ht/1q7SqNL
14:29:29 <amureini_> sbonazzo, is there any restriction of solving bugs between RC and GA?
14:29:31 <danken> ykaplan: could it be related to https://bugzilla.redhat.com/show_bug.cgi?id=1115123 ? (stat)
14:30:51 <sbonazzo> amureini_: according to http://www.ovirt.org/Release_process only blockers should be fixed between RC and GA. But I guess that severity urgent and high could be considered worth to be fixed too
14:30:57 <ykaplan> danken, very very possible. it does not look like the original bug anyway.
14:30:58 <danken> ykaplan: nah, false guess,
14:31:21 <danken> ykaplan: yeah, jiri states that he should open another bug (but he never has)
14:31:32 <amureini_> sbonazzo, thanks
14:31:52 <danken> ykaplan: my guess is wrong since in jiri's case, there as direct call to os.stats(), not via isdir().
14:32:06 <ykaplan> danken, he said that if it's a different isuue...
14:32:09 <sbonazzo> #info 3.5.0 GA is currently set to Aug 27th
14:32:16 <sbonazzo> 14 days left
14:33:21 <danken> ykaplan: for sure, getFileList is raceful. it first lists all files, than calls stat(), assuming that the files would stay there forever
14:33:52 <sbonazzo> ykaplan: any ETA on fixing it?
14:33:58 <sbonazzo> #chair ykaplan
14:33:58 <ovirtbot> Current chairs: alitke amureini amureini_ awels danken dcaro fabiand fromani lvernia nsoffer oved sbonazzo ykaplan
14:34:33 <danken> fsimonce: ykaplan: haven't we solved something like this getFileList race already?
14:35:06 <fsimonce> danken, what bz (now)?
14:36:22 <sbonazzo> fsimonce: Bug 1114499 -        refreshing iso list fails with: AttributeError: '_IOProcessFileUtils' object has no attribute 'validateQemuReadable'
14:36:43 <ykaplan> sbonazzo, not sure. taking a look
14:37:01 <sbonazzo> fsimonce: maybe related to https://bugzilla.redhat.com/show_bug.cgi?id=1115123
14:38:00 <ykaplan> danken, does look racey
14:38:13 <danken> https://bugzilla.redhat.com/show_bug.cgi?id=1114499, last traceback
14:38:17 <danken> fsimonce: ^^
14:38:28 <ykaplan> sbonazzo, fsimonce, danken not related to https://bugzilla.redhat.com/show_bug.cgi?id=1115123
14:38:42 <sbonazzo> ykaplan: ok
14:38:47 <danken> sbonazzo: that was my first guess, which I dismissed later
14:38:57 <sbonazzo> danken: ok
14:39:51 <danken> who's for infra here? I think mooli should be working on 1127877 (vdsm-tool configure --force does not configure qemu.conf)
14:39:56 <fsimonce> danken, I don't think he was trying to remove files at the same time... was he verifying the bz?
14:39:57 <ykaplan> sbonazzo, danken, anyway it's not the same bug. the original bug was fixed. it fails on something new.
14:40:11 <ykaplan> fsimonce, yes
14:40:45 <danken> fsimonce: I'm trying to think why he could get an ENOENT
14:40:46 <sbonazzo> ykaplan: ok. so better to close it and open a new one on the different issue, still a blocker, right?
14:40:59 <sbonazzo> Any other issue to be raised here about 3.5.0?
14:41:00 <danken> fsimonce: but in any case, the code should handle such races
14:41:19 <fsimonce> danken, do we have a log of the file name? it could be that the name in the file list was incorrect
14:41:21 <danken> ykaplan: you can nag mooli about 1127877
14:42:09 <sbonazzo> #chair fsimonce
14:42:09 <ovirtbot> Current chairs: alitke amureini amureini_ awels danken dcaro fabiand fromani fsimonce lvernia nsoffer oved sbonazzo ykaplan
14:42:50 <danken> sbonazzo: who collects infra actions items today?
14:42:56 <ykaplan> danken, about 1127877. I'll nag him when he's here
14:43:19 <sbonazzo> bazulay: around?
14:44:52 <sbonazzo> danken: oved needed to leave, I guess he'll report offline
14:45:21 <sbonazzo> any other around for infra?
14:46:15 <sbonazzo> awels1: about UX any news about italian translation?
14:46:34 <awels1> sbonazzo: No, no news on it
14:47:05 <sbonazzo> awels1: anything else from UX?
14:47:15 <awels1> sbonazzo: No updates this week
14:47:24 <sbonazzo> awels1: thanks
14:48:20 <sbonazzo> another thing I would like to rise, please review http://www.ovirt.org/OVirt_3.5_release-management#Release_Criteria_.28WIP.29 and http://www.ovirt.org/OVirt_3.5_TestDay for 3rd testday coming next week
14:49:16 <danken> fsimonce: the glob seems benign: Thread-127::DEBUG::2014-08-07 14:17:28,088::task::885::Storage.TaskManager.Task::(_run) Task=`95de7f78-5405-420b-b231-c62ff9be9c21`::Task._run: 95de7f78-5405-420b-b231-c62ff9be9c21 ('0c78b4d6-ba00-4d3e-9f9f-65c7d5899d71', '*.iso', False) {} failed - stopping task
14:49:27 <danken> unless there was nothing in the storage domain...
14:49:35 <sbonazzo> please ensure that release criteria are met
14:50:28 <sbonazzo> #action maintainers to review release criteria and ensure their packages met the criteria
14:51:13 <sbonazzo> danken: I guess we can continue offline with the debugging of that bug
14:51:27 <sbonazzo> anything else for 3.5.0?
14:51:28 <danken> sbonazzo: yeah, of course
14:51:30 <danken> go on
14:51:57 <sbonazzo> ok, moving on.
14:52:01 <sbonazzo> #topic conferences and workshops
14:52:20 <sbonazzo> bkp and dneary are not around
14:52:31 <sbonazzo> doron_afk: do you have news?
14:52:56 <doron> sbonazzo: kvm forum and linux con speeding up
14:53:19 <sbonazzo> #info kvm forum and linux con speeding up
14:53:20 <doron> other than that no news for this week.
14:53:29 <sbonazzo> doron: thanks
14:53:43 <sbonazzo> #topic other topics
14:53:57 <sbonazzo> any other topic to be discussed?
14:53:59 <danken> sbonazzo: somehow I got into http://lanyrd.com/2014/pyconie/sdcpkr/ so I have to prepare an presentation about pthreading (infra stuff)
14:54:46 <sbonazzo> #undo
14:54:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x87c416c>
14:55:04 <sbonazzo> #link http://lanyrd.com/2014/pyconie/sdcpkr/
14:55:21 <sbonazzo> #action danken to prepare an presentation about pthreading (infra stuff)
14:55:31 <sbonazzo> #topic other topics
14:55:44 <sbonazzo> any other topic?
14:56:23 <sbonazzo> going once
14:57:21 <sbonazzo> ok guys, have a nice evening
14:57:31 <amureini_> thanks sbonazzo
14:57:34 <sbonazzo> #endmeeting