14:08:29 <dcaro> #startmeeting
14:08:29 <ovirtbot> Meeting started Mon Nov 10 14:08:29 2014 UTC.  The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:29 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:39 <YamakasY> dcaro: cookies ?
14:08:45 <dcaro> #chair bkorren ewoud rbarry
14:08:45 <ovirtbot> Current chairs: bkorren dcaro ewoud rbarry
14:08:57 * YamakasY sits too
14:09:00 <yzaslavs> damn , and i was so happy to see a linux geek with the name of my daughter
14:09:06 <bkorren> hi snaftaly
14:09:08 <dcaro> #chai YamakasY
14:09:11 <dcaro> #chair YamakasY
14:09:11 <ovirtbot> Current chairs: YamakasY bkorren dcaro ewoud rbarry
14:09:17 <YamakasY> :D
14:09:38 <bkorren> dcaro, >> snaftaly
14:09:38 <YamakasY> yzaslavs: hehe, it's a beautiful name tho!
14:09:51 <dcaro> snaftaly: around?
14:09:54 <winfr34k> rgolan: see your msgs
14:09:59 <snaftaly> dcaro, hi
14:10:05 <dcaro> snaftaly: hello :)
14:10:09 <dcaro> #chair snaftaly
14:10:09 <ovirtbot> Current chairs: YamakasY bkorren dcaro ewoud rbarry snaftaly
14:10:12 * YamakasY brings in the tea
14:10:25 <yzaslavs> YamakasY: thanks
14:11:06 <dcaro> #info Centos 6.6 slaves rollout started
14:11:19 <YamakasY> nice, guys any news on the memleak ?
14:11:23 <dcaro> #action dcaro to finish the 6.6 setup
14:11:41 <dcaro> YamakasY: which memory leak?
14:12:10 <YamakasY> dcaro: I have 75% mem usage on a 32GB machine, multiple with 1 VM which has 4GB of less
14:12:17 <YamakasY> I have seen the mailinglist
14:12:27 <YamakasY> *or
14:12:48 <dcaro> YamakasY: mmm, does not sound good, but it'snot an infra issue, you should ask the devels
14:12:58 <YamakasY> oh! whoops
14:13:12 <YamakasY> dcaro: wednesday ?
14:14:21 <dcaro> YamakasY: yep :), you can also wait for the meeting to end and ask then, someone should be able to help
14:14:37 <YamakasY> yeah will come allright
14:15:05 <bkorren> dcaro, lets move on plz, busy day, sorry :)
14:15:22 <dcaro> #info Started creating the infra docs about the phoenix setup
14:15:38 <dcaro> #link http://www.ovirt.org/Infra/Phoenix_Lab_Overview
14:15:59 <dcaro> I've also started to push all the docs as markdown into the infra-docs repo (that was not being used)
14:17:13 <dcaro> anything else on hosting?
14:17:59 <dcaro> #link http://gerrit.ovirt.org/#/c/34984/1
14:18:19 <bkorren> well the wiki issue stalled, it seems, I'm not sure how decision to change infra there will be taken
14:18:40 <bkorren> I guess we need bkp input for that.
14:18:50 <dcaro> I asked about the system proposed by bkp-afk but had no answer yet
14:19:07 <dcaro> he does not seem to be around today, will wait for the ml response
14:19:18 <bkorren> yeah
14:19:27 <dcaro> #info Waiting to here omre about the wiki and docs organization
14:19:40 <dcaro> next topic then
14:19:44 <dcaro> #topic Jenkins
14:20:10 <dcaro> #info New cleanup job to free space in the slaves
14:20:32 <dcaro> #link http://jenkins.ovirt.org/job/system_cleanup-workspaces/
14:21:22 <dcaro> Let me know if you see anything strange, we already had an issue with it. It also has some issues with mock chroots that I have to debug (for now it just skips it if found)
14:21:35 <dcaro> #action dcaro to debug and fix the mock chroot cleanup
14:22:07 <dcaro> #info Issues with db based jobs - working on it
14:22:30 <bkorren> dcaro, is that YAMLed?
14:22:41 <dcaro> both of them yes
14:22:47 <dcaro> (cleanup and db jobs)
14:22:58 <dcaro> or at least the db jobs I'm fixing
14:23:15 <dcaro> bkorren: http://gerrit.ovirt.org/#/c/34686/
14:23:19 <dcaro> the cleanup ^
14:23:43 <dcaro> one of the db jobs http://gerrit.ovirt.org/#/c/34926/
14:23:44 <bkorren> dcaro, ok, so the solution is to add 'su ...postgres...' to the db jobs
14:23:51 <bkorren> dcaro, ?
14:24:12 <dcaro> bkorren: it's actually sudo -u postgres for the createdb/ create role/ dropdb and use the engine user for the scripts
14:24:50 <bkorren> dcaro, is jenkins running the jobs as root?
14:25:00 <dcaro> bkorren: no, as jenkins user
14:25:11 <bkorren> dcaro, so it was added to sodoers?
14:25:15 <dcaro> bkorren: but the sudo config is set by puppt
14:26:14 <bkorren> dcaro, hmm... so it might be possible to create 'jenkins' user in postgres in the future and avoid sudo
14:27:10 <YamakasY> !chair YamakasY
14:27:33 <dcaro> bkorren: maybe, patches are welcome ;). I used that user because it was used already by the first job that I yamlized and used as 'base'
14:27:51 <rgolan> winfr34k: I got disconnected. let me know if you got updates since 04:06
14:28:05 <winfr34k> rgolan: no.
14:28:20 <bkorren> dcaro, I might add wishlist ticket, but its lo-pri... I guess we have bigger fish to fry though...
14:29:01 <dcaro> bkorren: yep, but if it itches you fix is always welcome
14:29:55 <dcaro> Changing a bit the subject, I think we should start another round of service upgrades
14:30:19 <rgolan> winfr34k: as user postgres ; psql engine postgres -c "select vm_count from vds where vds_name = YOURHOST
14:30:21 <bkorren> sound like fun...
14:30:25 <dcaro> jenkins and gerrit mainly, but we might want to update some of the systems packages too (they are quite old)
14:30:38 <rgolan> winfr34k: and close with ":
14:30:45 <rgolan> winfr34k: arrrr just "
14:30:46 <dcaro> bkorren: yep :/, but the sooner the better
14:32:01 <dcaro> #action: plan jenkins and gerrit upgrade
14:32:47 <dcaro> anything else on jenkins?
14:33:42 <winfr34k> rgolan: vm_count: 0
14:33:48 <dcaro> okok, moving
14:33:52 <dcaro> #topic Puppet
14:34:27 <dcaro> #info Started separating ovirt_infra module into smaller ones
14:34:30 <rgolan> winfr34k: what does /var/log/ovirt-engine/engine.log say when you try to put the host to maintanance
14:34:52 <dcaro> rgolan: winfr34k can you take it to pm or wait 5 min? We are in a meeting
14:35:02 <winfr34k> ok
14:35:11 <rgolan> dcaro: sure
14:35:16 <dcaro> rgolan: winfr34k: thanks
14:35:42 <dcaro> I'd like to propose starting to use hiera to store configuration data
14:35:49 <bkorren> dcaro, +1
14:36:20 <dcaro> I've been playing with a private gerrit repo for the yaml files, that it's only viewable by allowed users
14:37:51 <dcaro> #action start planning hiera integration
14:38:52 <dcaro> okok, anything else?
14:39:07 <bkorren> dcaro, not from me :)
14:39:15 <dcaro> I forgot!!
14:39:21 <dcaro> #topic New members
14:39:59 <dcaro> there's a new name in the meetings :), snaftaly care to explain a bit about you? (experience, etc...)
14:42:06 <snaftaly> hi :) i'm a computer science student, new here :)
14:43:37 <bkorren> dcaro, ^^
14:43:47 <dcaro> snaftaly: welcome to ovirt infra :), hope to see you around often ;)
14:44:15 <snaftaly> dcaro, thanks :)
14:45:25 <dcaro> snaftaly: feel free to ask anything on the chat or the list, and don't hesitate to propose new things, always looking for improvement.
14:45:48 <dcaro> #info welcome snaftaly
14:46:12 <dcaro> okok, so if there are no more topics, I think we are done
14:46:38 <yzaslavs> emesika: ping
14:46:52 <bkorren> dcaro, yeah looks like it
14:47:01 <dcaro> #endmeeting