15:01:05 <ydary> #startmeeting oVirt Weekly Sync
15:01:05 <ovirtbot> Meeting started Wed Jan 28 15:01:05 2015 UTC.  The chair is ydary. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:22 <xyz> eedri: the jenkins link point to this: http://jenkins.ovirt.org/view/ovirt_node/
15:01:28 <ydary> #chair ydary
15:01:28 <ovirtbot> Current chairs: ydary
15:01:38 <xyz> eedri: which in my case I get a "HTTP ERROR 404"
15:01:47 <eedri> dcaro, rbarry can you look ^
15:01:54 * sbonazzo here for integration
15:02:05 * bkp-BRU here for community
15:02:12 <ydary> eedri: please move this to a different channel
15:02:15 <ydary> #topic Agenda and roll Call
15:02:15 <ydary> #info infra update
15:02:15 <ydary> #info 3.5.z updates
15:02:15 <ydary> #info 3.6.0 status
15:02:15 <ydary> #info conferences and workshops
15:02:16 <ydary> #info other topics
15:02:20 * lvernia is here.
15:02:35 <dcaro> eedri: looking
15:02:55 <fabiand> tlitovsk, ^^
15:03:19 <ydary> #topic infra update
15:03:30 <ydary> can help with infra update?
15:03:56 <ydary> dcaro: can you help with infra update?
15:04:21 <tlitovsk> fabiand, looking
15:04:54 <ydary> sbonazzo: do you know how things are going with infra?
15:05:23 <sbonazzo> ydary: not very much, I've seen several jobs failing and people already started fixing engine for them
15:05:35 <sbonazzo> ydary: other than that I've no news on infra
15:06:45 <eedri> ydary, i can update the the nigthly repos were refreshed and they should contain new rpms with 3.6 cluster level support
15:06:57 <eedri> dcaro, can you confirm^
15:07:02 <ydary> #info several engine jobs have been failing and they are being addressed
15:07:35 <dcaro> eedri: confirmed, the jobs are working again
15:07:43 <lvernia> eedri: I can confirm as well :)
15:07:53 <lvernia> eedri: mburman let me know earlier this week, thanks!
15:07:56 <ydary> #info Nightly repositories have been refreshed and should contain new rpms with 3.6 cluster level support
15:08:44 <ydary> eedri: dcaro: anything else for infra?
15:08:45 <eedri> dcaro, do you want to update on http://etherpad.ovirt.org/p/build-and-test-standards?
15:08:54 <dcaro> sure
15:09:08 <sbonazzo> lvernia: mburman not here. got report that vdsm 4.17 requires a new libvirt for allowing 3.6 capabilities on el7 and no libvirt rpm is available for el7 with such support level
15:09:15 <dcaro> sent a proposal for new standard build and test procedure, to generalize all the jobs
15:09:48 <dcaro> so far there were no replies or question on the subject, so I'll write a more specific document and start working with each project
15:10:28 <ydary> dcaro: do you have a link to that thread?
15:10:46 <dcaro> let me look (the summary is also in that etherpad, for easy editing)
15:11:05 <lvernia> sbonazzo: Indeed, he told me. Sounds like a packaging bug, isn't it?
15:11:30 <sbonazzo> lvernia: not sure.... it's vdsm requiring a package not available to run as expected
15:11:40 <sbonazzo> lvernia: no hard requirement
15:12:32 <dcaro> ydary: http://lists.ovirt.org/pipermail/devel/2015-January/009731.html
15:12:44 <ydary> #info dcaro has sent a proposal for new standard build and test procedure, to generalize all the CI jobs: http://etherpad.ovirt.org/p/build-and-test-standards. Please reply on the thread if you have any questions or replies: http://lists.ovirt.org/pipermail/devel/2015-January/009731.html
15:12:51 <lvernia> sbonazzo: Is the libvirt version available on some upstream repository for el7 and just not as a dependency of vdsm?
15:13:23 <ydary> lvernia: sbonazzo: is this relevant to the infra update?
15:13:55 <lvernia> ydary: Not sure if we have a more fitting spot during the meeting...
15:14:04 <sbonazzo> lvernia: the needed version is not available anywhere. there's a build for fedora 21 on libvirt repo
15:14:31 <sbonazzo> ydary: raised just after the 3.6 support in nightly for vdsm
15:14:42 <sbonazzo> ydary: package is there, but capability is still missing
15:14:56 <sbonazzo> ydary: due to lack of libvirt support for 3.6
15:15:20 <lvernia> sbonazzo: So still sounds like a packaging issue :) Why wouldn't it be available for el7? If it were available and installed vdsm reporting would probably work as expected.
15:15:27 <lvernia> danken: Could you comment? ^^^
15:16:17 <ydary> #info There is a chance 3.6 cluster level support is missing due to lack of libvirt support for 3.6 or due to packaging issue.
15:16:17 <sbonazzo> lvernia: for having libvirt in centos 7 either RHEL should provide it or we should build it in CentOS Virt SIG
15:16:36 <sbonazzo> lvernia: or we should build it as custom build in ovirt repo
15:17:10 <lvernia> sbonazzo: Hmmm, this is way above my level of understanding in how we distribute packages :)
15:17:37 <lvernia> sbonazzo: But I would expect this to be available *somewhere*.
15:17:38 <sbonazzo> lvernia: let's take this offline
15:17:42 <lvernia> sbonazzo: Ack.
15:18:03 <ydary> sbonazzo: lvernia: Let's table this and please provide more info next week on the threads
15:18:16 <lvernia> ydary: Cool.
15:18:19 <sbonazzo> ydary: +1
15:18:19 <apuimedo> sbonazzo: it should be in the CentOSVirt SIG
15:18:37 <ydary> #action sbonazzo to update on 3.6 cluster level support in nightly builds next week
15:18:38 <sbonazzo> apuimedo: +1, not there afaik
15:18:54 <lvernia> apuimedo: Welcome :)
15:19:00 <ydary> any other topic for infra?
15:19:04 <apuimedo> sbonazzo: didn't we have dcaro on or eedri on the SIG?
15:19:13 <apuimedo> lvernia: thanks ;-)
15:19:17 <sbonazzo> apuimedo: I'm there too
15:19:41 <sbonazzo> ydary: CentOS Virt SIG is infra?
15:19:56 <apuimedo> sbonazzo: so you'll have to push for it
15:20:03 <apuimedo> ;-)
15:20:04 <sbonazzo> ydary: here yesterday meeting minutes: http://lists.centos.org/pipermail/centos-virt/2015-January/004232.html
15:21:06 <ydary> sbonazzo: minutes for what?
15:21:16 <sbonazzo> ydary: CentOS Virt SIG meeting
15:23:13 <ydary> #info see discussion in CentOS Virt SIG meeting:  http://lists.centos.org/pipermail/centos-virt/2015-January/004232.html
15:23:32 <ydary> moving on to 3.5.z updates
15:23:33 <ydary> #topic 3.5.z updates
15:24:01 <ydary> sbonazzo: any updates?
15:24:12 <sbonazzo> ydary: sent 3.5.2 status this morning here:  http://lists.ovirt.org/pipermail/users/2015-January/030899.html
15:24:46 <sbonazzo> ydary: I got report of a serious regression introduced in 3.5.1 so gchaplik asked for an async release of ovirt-engine (will be 3.5.1.1)
15:24:57 <ydary> #info 3.5.2 status from this morning: http://lists.ovirt.org/pipermail/users/2015-January/030899.html
15:25:12 <sbonazzo> ydary: maybe gchaplik or amureini may spend a few words about the regression
15:25:16 <ydary> sbonazzo: do you have a bug number for that?
15:25:44 <gchaplik> ydary, https://bugzilla.redhat.com/1185615
15:26:05 <gchaplik> ydary, basically we fails to create ovf_store disk
15:26:41 <danken> sbonazzo: which version is missing? (sorry I got distracted)
15:27:05 <sbonazzo> danken: latest libvirt
15:27:50 <ydary> sbonazzo: will we be releasing a async release for this?
15:27:54 <danken> sbonazzo: no build thereof in el7?
15:28:22 <danken> dcaro: I know I've missed the "infra" spot, but can we discuss installing http://dl.fedoraproject.org/pub/epel/6/i386/python-nose1.1-1.1.2-4.el6.noarch.rpm on el6 slaves?
15:28:26 <sbonazzo> ydary: yes, as soon as we have the fix backported to 3.5.1 branch
15:28:44 <sbonazzo> danken: nobody provided it, libvirt guys just build for f21
15:29:15 <danken> sbonazzo: and there no virt-preview for el7...
15:29:24 <sbonazzo> danken: exactly
15:29:25 <ydary> #info A regression in 3.5.1 causes failure to create ovf_store disk, a async release to address this will be released as 3.5.1.1 once the fix is merged (https://bugzilla.redhat.com/1185615)
15:29:27 <danken> sbonazzo: why do you need it in el7, btw?
15:29:51 <lvernia> danken: For vdsm to report that it supports stuff! :p
15:30:03 <sbonazzo> danken: according to mburman, without latest libvirt, vdsm 4.17 is not providing 3.6 compatibility level
15:30:08 <ydary> sbonazzo: any other updates for 3.5.z?
15:30:23 <sbonazzo> ydary: we should schedule 3.5.2 release
15:30:34 <sbonazzo> ydary: is it ok to go with usual 1 month schedule?
15:30:48 <danken> lvernia: ah, on el7.
15:30:53 <lvernia> danken: Indeed.
15:30:55 <dcaro> danken: sure, is that an update?
15:31:02 <dcaro> danken: or something totally new?
15:31:14 <danken> dcaro: no, it's a nose version that support xunit
15:31:19 <danken> el6's nose does not
15:31:22 <ydary> sbonazzo: what is the bug count for 3.5.2?
15:31:44 <sbonazzo> ydary: 44 bugs. feb18 RC, feb25 ga?
15:31:48 <dcaro> danken: can you open a ticket on trac for it?
15:31:54 <dcaro> danken: assign it to me
15:32:06 <danken> dcaro: shortly
15:32:53 <dcaro> danken: thanks
15:32:58 <ydary> sbonazzo: can you provide a query for these bugs?
15:33:14 <sbonazzo> ydary: http://goo.gl/crVJPH
15:34:46 <ydary> sbonazzo: I would push it a week to give the bugs a bit more time to converge.
15:35:13 <sbonazzo> ydary: so rc feb25, ga mar4 ?
15:35:25 <ydary> sbonazzo: sounds good
15:35:29 <sbonazzo> ydary: +1
15:35:57 <danken> sbonazzo: fromani: have we asked libvirt to backport VIR_MIGRATE_COMPRESSED to el7?
15:36:25 <sbonazzo> danken: not on my side
15:36:26 <ydary> #info oVirt 3.5.2 release schedule to be publish this week, probably 25/02 RC and 04/03 GA
15:36:37 <ydary> sbonazzo: anything else for 3.5.z?
15:36:44 <sbonazzo> ydary: no, that's all for me on 3.5
15:36:51 <fromani> danken: nope, IIRC it should be available, checking
15:37:04 <ydary> moving on to 3.6
15:37:10 <ydary> #topic 3.6 status
15:37:24 <danken> fromani: it is.
15:37:27 <ydary> sbonazzo: any updates?
15:37:27 <sbonazzo> ydary: sent the status on 3.6: http://lists.ovirt.org/pipermail/users/2015-January/030911.html
15:37:36 <sbonazzo> ydary: not much news on releng
15:37:45 <danken> fromani: any other guess why we don't report 3.6 on el7?
15:37:48 <lvernia> ydary: I want to re-raise an issue from two weeks ago!
15:37:54 <sbonazzo> ydary: on integration side, f21 support feature as been dropped for f22 support
15:38:01 <ydary> #info Status of 3.6: http://lists.ovirt.org/pipermail/users/2015-January/030911.html
15:38:14 <fromani> danken: nope, will check.
15:38:22 <fromani> danken: I mean now
15:38:27 <lvernia> ydary: About vdsm 4.17 not reporting that it supports 3.6 clusters during early stages of development.
15:38:31 <ydary> sbonazzo: why was this decided?
15:38:43 <lvernia> ydary: There's a thread about it going stale on devel.
15:39:14 <lvernia> ydary: But danken, while unhappy about it, has expressed willingness to merge such a patch if one is pushed to vdsm...
15:39:17 <sbonazzo> ydary: 3.6 will go out after f22 so better to focus directly on that version. it will be branched on feb 10 so we can start early trying to support it
15:40:23 <lvernia> ydary: At the moment, this blocks users of the master branch from having operational hosts in a 3.6 cluster (so effectively not being able to use any 3.6 features), unless they manually meddle with what vdsm reports...
15:41:00 <ydary> #info integration update on 3.6.0: fc21 support feature has been dropped due to oVirt 3.6.0 timeline GAing after fc22 release.
15:41:46 <sbonazzo> ydary: that's all from integration for 36 right now
15:43:34 <ydary> #info update on 3.6.0: vdsm 4.17 not reporting that it supports 3.6 clusters during early stages of development, causing non-operational hosts in a 3.6 cluster. Users can no use any 3.6 feature. danken, to merge patch to resolve this in VDSM.t
15:43:57 <ydary> anyone can report for infra?
15:44:03 <danken> ydary: but mburman claims that this is not enough on el7
15:44:07 <lvernia> ydary: There's currently no such patch - should be an infra task... Maybe ybronhei.
15:44:17 <lvernia> danken: It's not enough, but it's a necessary condition :)
15:44:42 <lvernia> danken: And indeed there's that el7 libvirt package thing.
15:45:03 <ydary> lvernia: danken: please table this and discuss with sbonazzo for update on next week meeting.
15:45:05 <danken> lvernia: not necessary, since Engine can add a plaster instead of vdsm.
15:45:35 <lvernia> danken: Which would need to be removed later...
15:45:53 <ydary> who is covering for infra today?
15:46:02 <mburman> danken, i'm here
15:47:19 <ydary> #info infra updates 3.6.0: no one attended from the team.
15:47:26 <ydary> moving on the network
15:47:37 <ydary> lvernia: can you update on 3.6.0 status?
15:48:02 <lvernia> ydary: Sure thing.
15:48:27 <lvernia> ydary: I don't think there's any meaningful updates from last week.
15:48:40 <lvernia> ydary: Management network as a role is in very late review stages, might go in soon.
15:49:15 <ydary> #info Network updates for 3.6.0: Management network as a role is in very late review stages, might go in soon.
15:49:36 <ydary> lvernia: anything else?
15:49:41 <lvernia> ydary: Nah, I think that's it for us.
15:49:52 <ydary> lvernia: thanks
15:49:56 <lvernia> ydary: :)
15:50:08 <ydary> fabiand: can you update on node for 3.6.0?
15:50:25 <fabiand> ydary, I have no updates so far
15:50:38 <ydary> #info Node 3.6 updates: currently no updates
15:50:56 <ydary> awels: can you update on UX status for 3.6?
15:51:00 <ydary> fabiand: thanks
15:51:08 <fabiand> ydary, you are welcome
15:51:16 <awels> ydary: Nothing new on this end.
15:51:54 <ydary> #info UX 3.6 updates: currently no updates
15:52:06 <ydary> awels: thank you
15:52:13 <awels> ydary: np
15:52:23 <ydary> mskrivanek: can you update on virt?
15:52:34 <ydary> mskrivanek: 3.6 status
15:53:23 <ydary> anyone here for virt?
15:53:43 <mskrivanek> ha!
15:53:53 <mskrivanek> well...not sure, not much
15:54:38 <mskrivanek> working on features which are clear, slowly
15:55:17 <ydary> mskrivanek: anything that is pending merge? anything very interesting to note?
15:55:58 <mskrivanek> ydary: patches on virt-v2v integration posted, in progress.
15:56:31 <ydary> #info virt 3.6 updates: Working on feature with clear requirements, progress is slow. Patches on virt-v2v integration posted and are being reviewed.
15:56:38 <ydary> mskrivanek: anything else?
15:56:49 <mskrivanek> nope, that's it
15:56:57 <ydary> mskrivanek: thanks!
15:57:21 <ydary> tal: can you update on storage for 3.6?
15:57:48 <ydary> nsoffer: can you update on storage for 3.6?
15:58:20 <nsoffer> ydary, no
15:58:21 <nsoffer> :-)
15:59:13 <ydary> anyone here can update on storage status for 3.6?
15:59:28 <ydary> derez: ^^
15:59:51 <ydary> mlipchuk: ^^
16:00:46 <ydary> #info storage 3.6 updates: no one for storage team to update
16:00:58 <ydary> doron_afk: can you update on SLA for 3.6?
16:01:21 <doron_afk> ydary: no updates since last week- still planning.
16:01:43 <ydary> #info SLA 3.6 updates: SLA still in planning, no further updates.
16:02:06 <danken> mburman: the 3.6-on-el7 subject has withered away
16:02:19 <ydary> moving on to conferences and workshops
16:02:28 <ydary> #topic conferences and workshops
16:02:35 <ydary> bkp: can you update?
16:02:45 <ydary> bkp-BRU: can you update?
16:02:59 <bkp-BRU> Yes, hang on
16:03:15 <bkp-BRU> (Sorry, in mid-chat with fellow Brussels travelers)
16:03:30 <bkp-BRU> FOSDEM is this weekend, and I am in Brussels now. Booth schedules and talks are here at http://etherpad.ovirt.org/p/ovirt-fosdem-15
16:03:42 <bkp-BRU> A reminder: the FOSDEM oVirt social meetup will be Sat., Jan. 31, at 2030 in the Au Bon Vieux Temps,
16:03:44 <mburman> danken, ok
16:03:45 <bkp-BRU> Impasse Saint-Nicolas 4, 1000 Bruxelles. All oVirt community members are invited for excellent beer and socializing! https://plus.google.com/103481186631922352759/about?gl=us&hl=en
16:04:10 <danken> mburman: fromani_ just reported that it's the issue of VIR_MIGRATE_AUTO_CONVERGE missing from current libivrt in el7
16:04:19 <bkp-BRU> The half-day workshop for FOSSAsia in Singapore is getting planned. The Korea user group is very close to committing a speaker, which means we will need just one more speaker to fill the event schedule.
16:04:32 <ydary> #info FOSDEM is this weekend, Booth schedules and talks are here at http://etherpad.ovirt.org/p/ovirt-fosdem-15.
16:04:35 <bkp-BRU> Reminder: amureini will be giving a talk at DevConfCZ in Feb, after FOSDEM
16:04:42 <danken> mburman: fromani_ we need to see when it's planned in libvirt
16:04:48 <bkp-BRU> bkp and jbrooks will be among the speakers at SCALE in Los Angeles speaking about oVirt
16:05:09 <danken> and place an Engine-side hack to accept 4.17 as 2.6 ;-)
16:05:11 <fromani_> danken: mburman pardon my silly incoming question but can't find when 3.6 version was added to VDSM master
16:05:27 <danken> fromani_: it was not
16:05:34 <bkp-BRU> That's all from me, ydary
16:05:45 <ydary> #info The FOSDEM oVirt social meetup will be Saturday, Jan. 31 at 20:30 in the Au Bon Vieux Temps Impasse Saint-Nicolas 4, 1000 Bruxelles.
16:05:56 <danken> ydary: and oved and lvernia want vdsm to lie about supporting it, when it still does not.
16:05:57 <ydary> #info  All oVirt community members are invited for excellent beer and socializing! https://plus.google.com/103481186631922352759/about?gl=us&hl=en
16:06:18 <lvernia> danken: It supports it as much as the engine supports it.
16:06:33 <ydary> #info  The half-day workshop for FOSSAsia in Singapore is getting planned. The Korea user group is very close to committing a speaker, which means we will need just one more speaker to fill the event schedule.
16:06:53 <ydary> #info  amureini will be giving a talk at DevConfCZ in Feb, after FOSDEM.
16:06:56 <lvernia> danken: It already has some 3.6 functionality in. All functionality that's currently known to enter 3.6.
16:07:15 <ydary> #info bkp and jbrooks will be among the speakers at SCALE in Los Angeles speaking about oVirt.
16:07:28 <ydary> bkp-BRU: thanks
16:07:39 <ydary> #topic other topics
16:07:42 <danken> lvernia: yeah, but here's another example - on el7, should we lie about the culsterLevel, even though lbvirt does not support  VIR_MIGRATE_AUTO_CONVERGE ?
16:08:07 <lvernia> danken: Is this new for 3.6?
16:08:09 <bkp-BRU> I just have one thing...
16:08:14 <bkp-BRU> The moVirt subproject's wiki page is now up at http://www.ovirt.org/Project_moVirt. This will be used to start the voting process to admit moVirt as a formal subproject.
16:08:15 <ydary> bkp-BRU: In the last meeting you said you will look at getting a google play account for ovirt?
16:08:17 <danken> lvernia: yes.
16:08:33 <danken> lvernia: that's probably mburman's issue
16:08:47 <bkp-BRU> In answer to your specific question ydary, legal is still looking into setting up an oVirt account in the Google Play store now, as well as checking trademarks, if any, for moVirt.
16:08:53 <ydary> #info The moVirt subproject's wiki page is now up at http://www.ovirt.org/Project_moVirt. This will be used to start the voting process to admit moVirt as a formal subproject.
16:08:55 <lvernia> danken: But the needed libvirt version should be available, just wasn't packaged...
16:09:07 <lvernia> danken: So it's a theoretical issue... Should be solved in a matter of days, shouldn't it?
16:09:39 <ydary> #info Following up on last meeting action items, legal is still looking into setting up an oVirt account in the Google Play store now, as well as checking trademarks, if any, for moVirt.
16:09:43 <bkp-BRU> ydary: That's all from me, save see many of you this weekend!
16:09:50 <danken> lvernia: I don't know when centos 7.1 is due
16:10:00 <ydary> Does anyone want to raise an issue? discuss something?
16:10:18 <Telsin> can a random watch ask a q?
16:10:20 <lvernia> danken: It doesn't matter when it's due. You can report support for 3.6 if and only if the required libvirt functionality is there.
16:10:30 <lvernia> danken: On the relevant machine.
16:10:50 <lvernia> danken: Then no matter how mburman satisfies that requirement, everything's fine.
16:11:03 <ydary> 3...
16:11:07 <ydary> 2...
16:11:10 <ydary> 1...
16:11:19 <ydary> thanks to everyone for joining, talk to you next week!
16:11:24 <ydary> #endmeeting