#ovirt: oVirt Weekly Sync

Meeting started by ydary at 15:01:18 UTC (full logs).

Meeting summary

  1. Agenda and roll Call (ydary, 15:01:30)
    1. infra update (ydary, 15:01:30)
    2. 3.5.z updates (ydary, 15:01:30)
    3. 3.6.0 status (ydary, 15:01:30)
    4. conferences and workshops (ydary, 15:01:30)
    5. other topics (ydary, 15:01:30)

  2. infra update (ydary, 15:03:42)
    1. oVirt gerrit has been updated to version 2.10 and now uses SSL. (ydary, 15:06:00)
    2. Strict generic cleanup was added to some jobs and is planned for all jobs, this is to release as much disk space possible. (ydary, 15:07:41)
    3. Slaves have been losing network configuration (dhclient dying), troubleshooting done this week to resolve this. (ydary, 15:08:45)
    4. Some hosts of phx lab are a bit overloaded due to lack of RAM, workload has increased. (ydary, 15:13:21)
    5. ACTION: mvk to discuss how to balance the memory capacity automatically with SLA team (rgolan). (ydary, 15:14:06)
    6. there are plans to upgrade RAM on phx hosts, no schedule set. Memory usage is on average 70-80%~. (ydary, 15:15:38)

  3. 3.5.z updates (ydary, 15:16:46)
    1. Status update at: http://lists.ovirt.org/pipermail/users/2015-February/031551.html (ydary, 15:17:19)
    2. 3.5.2 RC postponed due to blockers. (ydary, 15:17:41)
    3. ACTION: please re-targeted 3.5.2 bugs that did not converge to 3.5.3. (ydary, 15:18:58)
    4. Blocker was about bad handling of zombie tasks while upgrading from previous versions. Taskclenaer util has been now changed by infra and setup must be updated for using the new command line options. (ydary, 15:19:58)

  4. 3.6 status (ydary, 15:21:22)
    1. Status update for 3.6.0: http://lists.ovirt.org/pipermail/users/2015-February/031587.html. (ydary, 15:21:55)
    2. Schedule for 3.6 published. (ydary, 15:22:04)
    3. https://hibernate.atlassian.net/browse/HV-861 (jhernand, 15:26:35)
    4. Integration 3.6.0 Update: Fedora >= 21 we have jdk 1.8 which doesn't work with jboss-as 7. fc21 doesn't have Java 7 rpms and will EOL in April. (ydary, 15:29:40)
    5. A suggestion was made to move to wildfly. A patch for packaging wildfly 8.2 binaries on EL was submitted. (ydary, 15:31:01)
    6. S bug in one of JBoss' packages is holding us back. That bug will be fixed in Hibernate validator 5.2. (ydary, 15:31:43)
    7. A bug in one of JBoss' packages is holding us back. That bug will be fixed in Hibernate validator 5.2. (ydary, 15:31:59)
    8. Link to issue: https://hibernate.atlassian.net/browse/HV-861 (ydary, 15:32:49)
    9. It was suggested to replace the hibernate validator included in WildFly 8.2 with version 5.2, where the bug will be fixed. (ydary, 15:33:56)
    10. This suggestion is only valid on fc22. On f21, el6 and el7 we can ship wildfly 8.2 binaries in our repositories. (ydary, 15:35:46)
    11. This is similar to the current approach on some platform aka ovirt-engine-jboss-as providing jboss. (ydary, 15:36:43)
    12. ACTION: If we plan to move to wildfly 8.2 we need to prepare the jenkins job for the packaging, spec file is already merged. (ydary, 15:37:21)
    13. ACTION: sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week. (ydary, 15:40:43)
    14. ACTION: sbonazzo rgolan1 jhernand to get commitment for this task from infra team. (ydary, 15:41:44)
    15. Moving to wildfly will have to come together with support for Java 8. (ydary, 15:44:09)
    16. Other integration topics: (ydary, 15:44:16)
    17. FC support for hosted engine now available for testing in master snapshot (ydary, 15:44:44)
    18. tiraboschi started porting vdsm to debian jessie. (ydary, 15:45:08)
    19. Debian support led to several patches and opened several bugs about vdsm, ioprocess and others. (ydary, 15:45:40)
    20. New RFEs on docker images for OpenStack services for oVirt 3.6.0. (ydary, 15:48:34)
    21. Node 3.6.0 Update: Progress on node automation and regular el6 and el7 builds in jenkins are available for download. Also continued planning fo 3.6 and will add a feature page for the installation through anaconda. (ydary, 15:50:44)
    22. UX 3.6.0 Update: No updates. Patches are pending for review\merge. (ydary, 15:52:55)
    23. Network 3.6.0 Update: Progress on SR-IOV, some functionality already working already. Other than that no updates. (ydary, 15:54:40)
    24. SLA 3.6.0 Update: ongoing effort for the REST API of quota. A Wiki with the progress will be up hopefully this week (ydary, 15:59:19)
    25. also rgolan started researching edit hosted engine ongoing with sbonazzo and mlipchuk from storage team. Technical gap analysis and initial design pending. (ydary, 16:00:34)
    26. Gluster update for 3.6.0: Sahina made progress on snapshot and geo-replication management - number of patches merged. Gluster storage network role patches posted. (ydary, 16:03:01)
    27. ACTION: network team needs to review gluster storage network role patches posted. (ydary, 16:03:21)
    28. Brick provisioning patches to be reviewed. (ydary, 16:05:06)
    29. Storage update for 3.6.0: SPM removal had good discussions with infra stakeholders. we have a clear path forward, although some infra work is required. (ydary, 16:07:01)
    30. Cinder-Ceph work had several good discussions with other stakeholders, seems on track. (ydary, 16:07:22)
    31. Several other minor RFEs converging. (ydary, 16:07:50)
    32. Storage integration work with EL7.1 being done and should be backported to 3.5.3. (ydary, 16:08:52)
    33. Virt update for 3.6.0: No one attended from the team. (ydary, 16:10:53)
    34. Infra update for 3.6.0: All the items are updated in the 3.6 planning wiki. Work in progress on most items that include: upgrade manager, uniform SSO support, fencing re-factoring, events mechanism, SPM removal action items, v2v action items, etc. (ydary, 16:12:25)

  5. conferences and workshops (ydary, 16:13:17)
    1. SCALE and LF Collab were a big success! *Lots* of new oVirt t-shirts and discussions were held at the booth. People definitely know more about oVirt now. (ydary, 16:14:37)
    2. mlipchuk and bkp will be attending FOSSAsia in a couple of weeks, and hosting the half-day workshop on March 14. (ydary, 16:15:06)
    3. ACTION: Push the workshop in FOSSAsia on social media as you can, and if you have colleagues in east Asia, ask them for some social media love, too, please! (ydary, 16:15:41)
    4. bkp will be on the planning board for KVM Forum this year, which will be in Seattle on Aug 19-21. (ydary, 16:16:19)
    5. Rene Koch will be speaking at Chemnitzer Linux Days on Sunday March, 22nd. gshereme will be speaking on "Using Bootstrap with Google Web Toolkit" as POSSCON in South Carolina on April 14-15. (ydary, 16:16:43)
    6. ACTION: if you have any local LUG or datacenter user group in your area, check in with bkp and we can get you set up for a mini-talk to spread the oVirt word. (ydary, 16:17:22)

  6. other topics (ydary, 16:17:46)
    1. CentOS Virt SIG Meeting Minutes at: http://www.centos.org/minutes/2015/february/centos-devel.2015-02-24-14.07.log.html (ydary, 16:18:16)
    2. Some packages have been built for virt sig, roadmap is still long. See link: http://wiki.centos.org/SpecialInterestGroup/Virtualization/Roadmap . (ydary, 16:20:04)
    3. ACTION: help needed to sbonazzo to provide missing packages for CentOS Virt SIG. (ydary, 16:20:51)
    4. A new case study is out (http://www.ovirt.org/Universidad_de_Sevilla_Case_Study). oVirt is helping to deploy virtual desktops for up to 3,000 students at the Universidad de Sevilla in Spain. Eventually, over 60,000 students wil be served as this program scales up. (ydary, 16:22:21)
    5. getting reports that oVirt is in use by LibreOffice, BP, Samsung and possibly even Apple. I am tracking those down for future case studies. If you have any knowledge of users running oVirt that could be interesting, let bkp know! (ydary, 16:22:49)
    6. because of their respective work on containers and NFV, Joe Brockmeier and Frank Zdarsky will be visiting TLV this Spring to meet with people. bkp will join as well. Exact schedule is still not set. (ydary, 16:23:39)


Meeting ended at 16:25:08 UTC (full logs).

Action items

  1. mvk to discuss how to balance the memory capacity automatically with SLA team (rgolan).
  2. please re-targeted 3.5.2 bugs that did not converge to 3.5.3.
  3. If we plan to move to wildfly 8.2 we need to prepare the jenkins job for the packaging, spec file is already merged.
  4. sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week.
  5. sbonazzo rgolan1 jhernand to get commitment for this task from infra team.
  6. network team needs to review gluster storage network role patches posted.
  7. Push the workshop in FOSSAsia on social media as you can, and if you have colleagues in east Asia, ask them for some social media love, too, please!
  8. if you have any local LUG or datacenter user group in your area, check in with bkp and we can get you set up for a mini-talk to spread the oVirt word.
  9. help needed to sbonazzo to provide missing packages for CentOS Virt SIG.


Action items, by person

  1. bkp
    1. if you have any local LUG or datacenter user group in your area, check in with bkp and we can get you set up for a mini-talk to spread the oVirt word.
  2. jhernand
    1. sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week.
    2. sbonazzo rgolan1 jhernand to get commitment for this task from infra team.
  3. mvk
    1. mvk to discuss how to balance the memory capacity automatically with SLA team (rgolan).
  4. rgolan
    1. mvk to discuss how to balance the memory capacity automatically with SLA team (rgolan).
    2. sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week.
    3. sbonazzo rgolan1 jhernand to get commitment for this task from infra team.
  5. rgolan1
    1. sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week.
    2. sbonazzo rgolan1 jhernand to get commitment for this task from infra team.
  6. sbonazzo
    1. sbonazzo rgolan1 jhernand to discuss who will push engine patches, create build job for engine ans so on and will update next week.
    2. sbonazzo rgolan1 jhernand to get commitment for this task from infra team.
    3. help needed to sbonazzo to provide missing packages for CentOS Virt SIG.
  7. UNASSIGNED
    1. please re-targeted 3.5.2 bugs that did not converge to 3.5.3.
    2. If we plan to move to wildfly 8.2 we need to prepare the jenkins job for the packaging, spec file is already merged.
    3. network team needs to review gluster storage network role patches posted.
    4. Push the workshop in FOSSAsia on social media as you can, and if you have colleagues in east Asia, ask them for some social media love, too, please!


People present (lines said)

  1. ydary (131)
  2. sbonazzo (59)
  3. rgolan1 (27)
  4. bkp (20)
  5. jhernand (18)
  6. lvernia (17)
  7. mvk (11)
  8. sahina (10)
  9. dcaro (10)
  10. amureini (9)
  11. rgolan (6)
  12. obelix (5)
  13. fabiand (5)
  14. awels (2)
  15. alonbl (2)
  16. saggi (2)
  17. ovirtbot (2)
  18. alitke (1)
  19. doron_afk (1)
  20. fkobzik (1)
  21. didi (1)
  22. ykaplan (1)


Generated by MeetBot 0.1.4.