14:02:24 <ydary> #startmeeting oVirt Weekly Sync
14:02:24 <ovirtbot> Meeting started Wed Apr  1 14:02:24 2015 UTC.  The chair is ydary. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:24 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:34 <ydary> #topic Agenda and roll Call
14:02:36 <ydary> #info infra update
14:02:37 <ydary> #info 3.5.z updates
14:02:39 <ydary> #info 3.6.0 status
14:02:40 <ydary> #info conferences and workshops
14:02:42 <ydary> #info other topics
14:02:43 <ydary> who is here for weekly?
14:02:50 * sbonazzo here
14:02:53 * awels here
14:03:24 <ydary> rgolan: fabiand: mskrivanek: amureini: weekly?
14:03:42 <ydary> bkp: weekly?
14:04:07 * lvernia is here.
14:04:24 <ydary> sahina: weekly?
14:04:39 * sahina here!
14:04:44 <fabiand> weekly!
14:04:53 <ydary> #topic infra update
14:05:06 <ydary> sbonazzo: dcaro: mvk: can you update on infra?
14:05:12 * vissree here
14:05:21 <sbonazzo> ydary: bkorren is infra owner this week
14:05:39 <ydary> bkorren:  can you update on infra?
14:05:45 <bkorren> ydary, sure
14:06:41 <bkorren> some engine build issues since yesterday, solved this morning. (turned out to not be infra issue)
14:07:14 <bkorren> working on upgrading slaves to centos 7.1 right now
14:07:30 <bkorren> (e.g. the centos 7.0 ones)
14:07:31 * bkp here, sorry was in another mtg
14:07:43 <bkorren> ydary, that all from me
14:08:10 <ydary> #info Jenkins slaves are being upgraded on centos 7.1.
14:08:20 <ydary> bkorren: any downtime expected?
14:08:33 <bkorren> ydary, probably no
14:08:59 <bkorren> ydary, not doing an in-place upgrade
14:09:08 <ydary> #info No downtime expected.
14:09:18 <ydary> bkorren: thanks!
14:09:40 <ydary> moving on to 3.5.z updates
14:09:55 <ydary> #info 3.5.z updates
14:10:00 <sbonazzo> ydary: released oVirt 3.5.2 RC3 this morning
14:10:12 <sbonazzo> ydary: announce is here: http://lists.ovirt.org/pipermail/announce/2015-April/000165.html
14:10:43 <sbonazzo> an oVirt Live iso has been created and is already available on ovirt site
14:10:57 <ydary> #info oVirt 3.5.2 RC3 released today. Announcement: http://lists.ovirt.org/pipermail/announce/2015-April/000165.html
14:11:16 <sbonazzo> sent a status update right after the release: http://lists.ovirt.org/pipermail/devel/2015-April/010200.html
14:11:30 <sbonazzo> we still have some issue to close so I think another RC is needed
14:11:44 <ydary> #info oVirt Live iso has been created and is already available on oVirt site.
14:12:04 <ydary> #info 3.5.2\3.5.2 status update: http://lists.ovirt.org/pipermail/devel/2015-April/010200.html
14:12:34 <sbonazzo> for 3.5.3 just sent a bug status note, no blockers for now
14:12:43 <ydary> #info oVirt 3.5.2\3.5.3 status update: http://lists.ovirt.org/pipermail/devel/2015-April/010200.html
14:13:04 <ydary> #info No blockers on 3.5.3 currently.
14:13:15 <ydary> sbonazzo: anything else?
14:13:35 <sbonazzo> ydary: due to upcoming holidays and bug count the GA date may slip a bit
14:14:01 <sbonazzo> ydary: but better to wait for the RC4 build
14:14:49 <ydary> #info oVirt 3.5.2 GA may slip due to bug count and holidays. RC4 is expected.
14:14:49 <sbonazzo> ydary: that's all for me on 3.5.z
14:14:55 <ydary> sbonazzo: thanks!
14:15:14 <ydary> moving on to 3.6.0 updates
14:15:23 <ydary> #topic 3.6 status
14:15:37 <ydary> sbonazzo: any 3.6 updates?
14:15:44 <sbonazzo> ydary: sent a general status update here: http://lists.ovirt.org/pipermail/devel/2015-April/010192.html
14:16:08 <sbonazzo> ydary: from integration point of view, qemu-kvm-ev hit master this morning thanks to centos 7.1 being released yesterday
14:16:17 <ydary> #info oVirt 3.6 status update: http://lists.ovirt.org/pipermail/devel/2015-April/010192.html
14:16:45 <sbonazzo> ydary: Debian Jessie GA date has been announced to be April 25th, no progress on supporting it for now
14:17:11 <ydary> #info Integration 3.6.0 Updates:  qemu-kvm-ev hit master this morning thanks to centos 7.1.
14:17:25 <ydary> #info Debian Jessie GA date has been announced to be April 25th, no progress on supporting it for now.
14:17:37 <ydary> sbonazzo: anything else?
14:17:46 <sbonazzo> ydary: not much progress since last sync meeting on the other features
14:18:18 <sbonazzo> ydary: that's it for integration
14:18:25 <ydary> sbonazzo: thanks!
14:18:42 <ydary> lvernia: can you update on network?
14:18:50 <lvernia> ydary: Yes, indeed.
14:18:58 <lvernia> ydary: So SR-IOV patches started being merged.
14:19:21 <lvernia> ydary: And also a smallish, very nice RFE was merged by elevi.
14:19:38 <ydary> #info Network 3.6.0 Updates: SR-IOV patches started being merged.
14:19:44 <ydary> lvernia: what feature?
14:19:51 <lvernia> ydary: About allowing to pass a CIDR-style prefix in addition to complete subnet mask format.
14:20:01 <lvernia> ydary: When configuring IP for a host network.
14:20:15 <lvernia> So instead of writing 255.255.0.0 you could just write 16.
14:20:38 <ydary> #info Also merged allowing to pass a CIDR-style prefix in addition to complete subnet mask format when configuring IP for a host network.
14:20:48 <lvernia> ydary: And hopefully next week more progress on SR-IOV will have been achieved.
14:20:52 <lvernia> ydary: That's mostly it.
14:21:01 <ydary> lvernia: thanks!
14:21:05 <lvernia> ydary: Sure :)
14:21:13 <ydary> fabiand: can you update on node?
14:21:57 <fabiand> hey
14:22:01 <fabiand> no, no updates for this week
14:22:15 <fabiand> we mainly spedn time on streamlining some build jobs
14:22:53 <ydary> #info Node 3.6.0 Updates: Worked on streamlining some build jobs, no progress other than that.
14:23:18 <ydary> awels: can you update on UX?
14:23:23 <ydary> fabiand: thanks!
14:24:03 <awels> ydary: Yes, the UI over REST api feature has been bumped from 3.6, to 4.0.
14:24:35 <awels> ydary: It is still in progress, but at a lower capacity since we have more time now.
14:24:49 <awels> ydary: Other than that nothing new to report.
14:24:54 <ydary> #info UI over REST api feature has been bumped from 3.6 to 4.0. It is still in progress, but at a lower capacity since we have more time now.
14:25:40 <ydary> #info UX 3.6.0 Updates: UI over REST api feature has been bumped from 3.6 to 4.0. It is still in progress, but at a lower capacity since we have more time now.
14:25:48 <ydary> awels: thanks!
14:25:57 <ydary> rgolan: can you update on sla?
14:26:10 <rgolan> ydary: yes
14:27:02 <rgolan> rgolan: 3.6 items: there is ongoing work on REST quota api.
14:27:13 <rgolan> ydary: 3.6 items: there is ongoing work on REST quota api.
14:27:47 <ydary> #info SLA 3.6.0 Updates: REST quota API is in progress.
14:27:49 <rgolan> ydary: initial design for numa aware KSM using MoM
14:28:25 <ydary> #info Started initial design for numa aware KSM using MoM.
14:28:31 <rgolan> ydary: both SLA and Integ are working on hosted engine enhancments
14:29:10 <ydary> #info SLA and Integ are also working on hosted engine enhancments.
14:29:31 <rgolan> ydary: Till end of this week we'll have partial working flow of starting hosted engine vm from shared storage
14:30:06 <rgolan> ydary: scheduling - patches for adding memory to load-balancing are in review
14:30:11 <rgolan> ydary: that's it at the moment
14:30:49 <ydary> #info Till end of this week SLA will have partial working flow of starting hosted engine vm from shared storage. Also patches for adding memory to load-balancing are in review.
14:31:06 <ydary> rgolan: thanks! sound like great progress
14:31:21 <ydary> sahina: can you update on Gluster?
14:31:38 <sahina> ydary, yes
14:31:44 <sahina> ydary, Not much changed from last week. We're still fixing bugs and tweaking features for 3.6
14:32:32 <ydary> sahina: what features?
14:33:14 <sahina> ydary, features planned for 3.6 - geo-replication management, volume snapshot, brick provisioning and gluster network role
14:34:17 <ydary> #info Gluster 3.6.0 updates: Geo-replication management, volume snapshot, brick provisioning and gluster network role still in the works. No big changes.
14:34:49 <ydary> mskrivanek: can you update on virt?
14:34:52 <ydary> ofrenkel: ^^
14:36:12 <ydary> can anyone update on storage?
14:36:57 <ydary> oved: ybronhei: can anyone update on infra?
14:37:15 <sbonazzo> laravot: ^^
14:37:25 <oved> we're progressing in all fronts. noting main to update.
14:37:26 <mskrivanek> ydary: yeah, 3.6 - discussing vdsm side of v2v; bulk stats/scale improvements on vdsm side; VNC+SPICE console almost finished
14:38:21 <ydary> #info Virt 3.6.0 updates: Discussing vdsm side of v2v. Also bulk stats/scale improvements on vdsm side and VNC+SPICE console almost finished.
14:39:17 <ydary> oved: nothing worth noting? the status on the last few meeting didn't have any details.
14:39:25 <ydary> mskrivanek: anything else?
14:42:07 <sbonazzo> ydary: I suggest to move on
14:42:35 <ydary> #info Infra 3.6.0 updates: No change from last week.
14:42:45 <amureini> ydary, sorry major connectiviry issues.
14:43:12 <mskrivanek> ydary: not much, some little rpogress with various other 3.6 items, nothing special
14:43:12 <ydary> amureini: np, can you update on storage work for 3.6?
14:43:42 <amureini> ydary, sure.
14:44:19 <amureini> ydary, cinder - first series of engine patches merged, support most positive flows with disks. vdsm still needs to be taken from the draft branch
14:44:38 <amureini> ydary, spm removal - first series of draft patches up for review/playing, nothing merged yet
14:45:03 <amureini> ydary, extending a domain - some uxd work, some patches pushed as drafts, not ready yet
14:45:23 <ydary> #info Storage 3.6.0 updates: Cinder support - first series of engine patches merged, support most positive flows with disks. vdsm still needs to be taken from the draft branch.
14:45:27 <amureini> ydary, also some minor fixes here and there, like always. that's it for me, i think
14:45:39 <ydary> #info SPM Removal - first series of draft patches up for review/playing, nothing merged yet.
14:46:07 <ydary> #info Extending SD - some ux work, some patches pushed as drafts, not ready yet.
14:46:15 <ydary> amureini: thanks!
14:46:35 <ydary> moving on to conferences and workshops
14:46:44 <ydary> #topic conferences and workshops
14:46:54 <ydary> bkp: can you update?
14:47:03 <bkp> Yup!
14:47:04 <bkp> Planning for KVM Forum is up and running. KVM- and oVirt-related talks should be submitted at http://events.linuxfoundation.org/events/kvm-forum/program/cfp
14:47:08 <bkp> before May 1.
14:47:19 <bkp> Reminder: CFP for All Things Open in Raleigh on Oct. 18-20. CfP for ATO closes on April 30 Details: http://bit.ly/1FUKYRv.
14:47:23 <ydary> #info Planning for KVM Forum is up and running. KVM- and oVirt-related talks should be submitted at http://events.linuxfoundation.org/events/kvm-forum/program/cfp before May 1.
14:47:30 <bkp> Reminder: LinuxCon EU, CfP for that event on Oct. 5-7 in Dublin, Ireland (and the co-located CloudOpen) is open. CfP closes on June 17. http://events.linuxfoundation.org//events/linuxcon-europe/program/cfp
14:47:40 <bkp> New: There will be a large community room at Red Hat Summit (June 23-26). oVirt will join projects such as Gluster, ManangeIQ, RDO, and Project Atomic to host booths and a mini-track of community-oriented sessions.
14:47:51 <ydary> #info Reminder: CFP for All Things Open in Raleigh on Oct. 18-20. CfP for ATO closes on April 30 Details: http://bit.ly/1FUKYRv.
14:47:53 <bkp> That's it from me for conferences/events
14:48:06 <ydary> #info Reminder: LinuxCon EU, CfP for that event on Oct. 5-7 in Dublin, Ireland (and the co-located CloudOpen) is open. CfP closes on June 17. http://events.linuxfoundation.org//events/linuxcon-europe/program/cfp
14:48:15 <ydary> #info New: There will be a large community room at Red Hat Summit (June 23-26). oVirt will join projects such as Gluster, ManangeIQ, RDO, and Project Atomic to host booths and a mini-track of community-oriented sessions.
14:48:18 <sbonazzo> bkp ydary and the usual oss2015 in florence on may 16 :-/
14:48:21 <sbonazzo> :-)
14:48:25 <ydary> bkp: thanks!
14:48:38 <bkp> Thanks, sbonazzo
14:48:51 <ydary> #info OSS2015 in florence on may 16.
14:49:13 <ydary> moving on to other topics.
14:49:20 <ydary> #topic other topics
14:49:25 <sbonazzo> ydary: Get involved in oVirt project! Spring Holidays / April edition:  http://lists.ovirt.org/pipermail/devel/2015-April/010199.html
14:49:26 <ydary> Does anyone want to raise an issue? discuss something?
14:49:29 <bkp> Got a few, then have to hit other meeting...
14:49:34 <bkp> We have nearly 500 people in our oVirt Facebook group, a nice milestone (thanks doron_mtg for pointing this out this morning)! There's 1,940 Twitter followers of @oVirt, in case anyone is asking.
14:49:43 <ydary> #action Get involved in oVirt project! Spring Holidays / April edition:  http://lists.ovirt.org/pipermail/devel/2015-April/010199.html
14:49:51 <bkp> The work on the web site conversion to MarkDown proceeds. Once that is done, we will work on the new site's organization/categorization, and then finalize the new features. So far, a blog platform, a live social media feed on the front page, an Ask/StackOverflow-like forum, and an interactive feature list are among the new features.
14:50:01 <ydary> #info We have nearly 500 people in our oVirt Facebook group, a nice milestone (thanks doron_mtg for pointing this out this morning)! There's 1,940 Twitter followers of @oVirt, in case anyone is asking.
14:50:17 <ydary> #info The work on the web site conversion to MarkDown proceeds. Once that is done, we will work on the new site's organization/categorization, and then finalize the new features. So far, a blog platform, a live social media feed on the front page, an Ask/StackOverflow-like forum, and an interactive feature list are among the new features.
14:50:18 <bkp> And finally, the decision on the Outreachy candidates will be made very soon. itamar has approved two candidates for this round, and we are finalizing the decision now. Look for an announcement this week.
14:50:41 <ydary> #info The decision on the Outreachy candidates will be made very soon. Itamar has approved two candidates for this round, and we are finalizing the decision now. Look for an announcement this week.
14:50:49 <bkp> That's all from me!
14:51:09 <ydary> any else? anything else?
14:51:22 <ydary> anyone*
14:51:36 <ydary> ok, so thank you for attending!
14:51:44 <ydary> #endmeeting