13:00:28 <mburns> #startmeeting ovirt node weekly meeting
13:00:28 <ovirtbot> Meeting started Tue Jun 19 13:00:28 2012 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:44 <mburns> #chair READ10 jboggs` fabiand pmyers
13:00:44 <ovirtbot> Current chairs: READ10 fabiand jboggs` mburns pmyers
13:00:51 <mburns> #topic agenda and roll call
13:00:53 <mburns> agenda:
13:01:00 <mburns> 1. action item review
13:01:01 <pmyers> here
13:01:02 <mburns> 2. release status
13:01:09 <mburns> 3. other topics
13:01:32 * fabiand is also listening carefully
13:01:55 * jboggs` here
13:02:14 * READ10 here
13:02:23 <mburns> #topic Action Item Review
13:02:27 <mburns> #link http://ovirt.org/meetings/ovirt/2012/ovirt.2012-06-12-13.02.html
13:02:52 <mburns> #info 2.4.0 released (and horribly broken)
13:03:34 <mburns> #info a couple major blockers patched and 2.4.0-1 pushed as well
13:03:55 <mburns> #info one major blocker left to push 2.4.0-2
13:04:31 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=832517
13:05:08 <mburns> #info mburns acks network manager design page
13:05:20 <mburns> feature not possible until F18 though
13:05:31 <mburns> when network manager gets support for bridges
13:05:44 <mburns> #action mburns to file stateless bzs
13:05:55 <fabiand> I've heard that bridge support will land during F17
13:06:13 <mburns> #info mburns added 2.6.0 release and moved a bunch of RFEs to it
13:06:26 <mburns> fabiand: if it does, all the better
13:06:42 * mburns didn't think even Fedora would rebase to that between releases
13:06:44 <READ10> mburns: we should confirm it's not already in F17, IIRC it is
13:07:04 <mburns> READ10: last i checked with F17, it wasn't there
13:07:23 <fabiand> I spoke to danw(or danp?), and he said that it wasn't in yet, but would follow
13:07:24 <mburns> and i saw others say that the can't setup bridges in f17 with network manager
13:07:30 <READ10> mburns: ok, I may be out of date
13:07:33 <fabiand> I didn't check it though ..
13:07:35 <mburns> fabiand: excellent
13:07:44 <mburns> once that's in, we can start actually developing the feature
13:08:43 <hostdream> itamar : errors are in the link I've posted http://pastebin.com/wxeW0g5V
13:08:46 <mburns> fabiand: probably more of a 2.6.0 or 2.7.0 feature anyway
13:08:55 <fabiand> mburns, yes
13:09:17 <itamar> hostdream - this is the engine log. i am asking for vdsm log from the source host of the migration
13:09:46 <mburns> #info network page issue solved by fabiand (problem with vlan entry, iirc)
13:10:01 <mburns> #info patch for ^^ included in 2.4.0
13:10:11 <hostdream> itamar : ha sorry ok I will check
13:10:25 <mburns> #topic release status
13:10:37 <mburns> #info 2.4.0 released into beta stream (as is 2.4.0-1
13:10:41 <mburns> #undo
13:10:41 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9c1392c>
13:10:43 <mburns> #info 2.4.0 released into beta stream (as is 2.4.0-1)
13:11:13 <mburns> #link http://goo.gl/DqyqZ
13:12:48 <mburns> jboggs`: fabiand: can you pick up a couple of the bugs on this list?
13:12:54 <jboggs`> sure
13:13:02 <fabiand> sure
13:14:19 <mburns> thanks
13:14:45 <mburns> as of now, we're still targeting June 27 for 3.1 GA, though that is very much at risk currently
13:14:56 <mburns> #info as of now, we're still targeting June 27 for 3.1 GA, though that is very much at risk currently
13:15:18 <mburns> i'd like to do 2.4.1 release at the same time as GA, so it would be good to get these fixed ASAP
13:15:42 <mburns> btw, the qe team will be picking up builds in the near future to begin testing
13:17:02 <mburns> any other comments on the release status?
13:17:27 <mburns> #topic other topics
13:17:43 <mburns> #info jenkins build failures are fixed by recently acked patch
13:17:51 <mburns> just needs rebase and merge
13:18:03 <fabiand> That is nice, because now I hope that we get some more nightly testing done.
13:18:13 <mburns> #info great work by fabiand getting automation running
13:18:36 <fabiand> It's not done yet - just the basics in place.
13:18:49 <mburns> fabiand: would be good to get something into a wiki page for how to develop new tests
13:19:16 <fabiand> mburns, yes, definetly - I need to document the whole testing a bit more
13:19:24 <fabiand> s/bit/a lot/
13:19:30 <mburns> ;-)
13:19:35 <mburns> jboggs`: how are plugins coming?
13:19:47 <mburns> i saw a few patches posted (hope to have them reviewed later today
13:19:48 <jboggs`> moving along nicely pushed out to gerrit my current patch set
13:20:00 <jboggs`> adding in normal rpm install shortly
13:20:20 <mburns> excellent
13:20:25 <jboggs`> fabiand, dont pull the dup checking patch just yet for automation testing
13:20:34 <hostdream> itamar : can be due to that ? http://pastebin.com/ZfeCTfWR
13:21:04 <fabiand> jboggs`, right. I'll just stick to what I've got right now, that seems to work.
13:21:15 <fabiand> (even if the tests are failing, but that's a node bug)
13:21:18 <mburns> jboggs`: btw, lets refer to dups as kmods
13:21:27 <mburns> dup is RH only term, afaik
13:21:35 <jboggs`> ok
13:21:54 <mburns> ok, that's all i have
13:21:57 <mburns> anyone have other topics
13:21:58 <mburns> ?
13:22:04 <jboggs> none from me
13:22:05 * fabiand want's to point out #831668
13:22:23 <fabiand> The problem is - iiuic - not only related to auto installs.
13:22:40 <fabiand> ah, but maybe just to vms.
13:22:45 <fabiand> sorry - for the noise
13:23:03 <mburns> fabiand: i'll see if i can look today
13:23:45 <fabiand> mburns, nic's are changing their names between reboots.
13:23:52 <fabiand> But this could be limited to VMs, as said
13:24:16 <mburns> well...biosdevname should help that in most cases
13:24:29 <mburns> but it doesn't apply in virtual machines
13:24:32 <fabiand> true, it's just deactiavted in vms :-/
13:24:35 <fabiand> yep
13:24:49 <fabiand> this is a problem for me w/ testing, but I suppose not out in the wild
13:24:51 <mburns> unless libvirt has a feature to simulate biosdevname somehow?
13:25:36 <fabiand> I don't even know why it was deactiavted for VMs.
13:25:43 <fabiand> I have to dig a bit further.
13:25:45 <READ10> mburns: I don't know if it does
13:26:26 <mburns> fabiand: it's more that the virtual devices don't have the right attributes for biosdevname to work on them
13:26:37 <mburns> so it falls back to standard eth* naming
13:26:47 <mburns> which apparently is much more unstable in f17 than previously
13:26:59 <fabiand> ah okay
13:27:06 <fabiand> mburns, well informed ..
13:27:25 <fabiand> I'd like to discuss this a bit more, but we don't need to do this in the meeting.
13:27:35 <mburns> fabiand: i'll think about it, but i'm not seeing a way other than the udev script and then persisting the file somehow
13:28:04 <fabiand> mburns, mh yes. or upstream helps to enable biosdevname :)
13:28:54 <mburns> fabiand: right
13:29:10 <mburns> ok, fabiand we can chat offline about that if you want
13:29:16 <mburns> anything else for this meeting?
13:29:35 <mburns> going once?
13:30:33 <mburns> gone
13:30:37 <mburns> #endmeeting