13:08:21 <oschreib> #startmeeting oVirt 3.3 Release go/no-go
13:08:21 <ovirtbot> Meeting started Tue Sep 3 13:08:21 2013 UTC. The chair is oschreib. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:08:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:08:28 <oschreib> #chair mburns
13:08:28 <ovirtbot> Current chairs: mburns oschreib
13:08:37 <oschreib> #topic Agenda and roll call
13:08:52 <oschreib> #info Open issues from last week
13:09:04 <oschreib> #Info blocker review
13:09:30 <oschreib> #info release communication
13:09:33 <oschreib> who is here?
13:09:52 * mskrivanek here
13:09:57 * firemanxbr here
13:10:19 * sahina here
13:10:50 * mburns here but not really here...
13:11:21 <sgotliv> sgotliv here
13:11:21 <Rydekull> mburns: here in spirit but not in mind? :-)
13:11:32 <oschreib> #topic open issues
13:11:47 <oschreib> I have two issues to raise here
13:12:18 <oschreib> 1. Bug 1002749 - AIO installer fails at local host installation with 3.3rc2 packages
13:12:31 <oschreib> 2. The missing spice-html from el6 repo
13:12:52 <oschreib> mburns: can you add spice-html to the el6 repo please?
13:13:01 <mburns> oschreib: yes, i will as soon as i can
13:13:06 <oschreib> mburns: thanks
13:13:11 <oschreib> about #1
13:13:21 <oschreib> we need new sdk build
13:13:34 <oschreib> mburns: what should we do with that? take them from nightly?
13:15:54 <oschreib> #action mburns to add the spice-html rpm to el6 build
13:16:56 <abaron> abaron here
13:18:03 <oschreib> #action mburns and oschreib to get new SDK build
13:18:05 <oschreib> next
13:18:17 <oschreib> #topic Release blockers
13:19:08 <oschreib> so, I'm pretty sure we need to delay the release as AIO doesn't work due to wronk SDK in repo, same goes for el6 builds
13:19:27 <oschreib> (that's before reviewing the list of blockers in bugzilla)
13:19:30 <oschreib> thoughts?
13:19:34 <dneary> oschreib, I think we need to get it out there
13:19:48 <dneary> oschreib, Are there bugs for AIO?
13:20:14 <oschreib> dneary: well, no, just the fact it doesn't work from our repo
13:20:38 <oschreib> dneary: what do we get from releasing it in that state?
13:20:39 <mburns> oschreib: not nightly, we need an official build
13:21:05 <oschreib> mburns: well, a nightly will be a good idea in the meanwhile
13:21:15 <dneary> oschreib, We get a release
13:21:26 <oschreib> mburns: I agree, I'm trying to get that for weeks now
13:22:01 <oschreib> bazulay: itamar: FYI - we're waiting for a SDK build, which blocks all-in-one
13:22:14 <oschreib> dneary: A release that doesn't have working all-in-one
13:22:33 <mburns> oschreib: perhaps, but i'd rather take a tarball and build it officially
13:23:04 <dneary> oschreib, Isn't it working for Fedora 19?
13:23:10 <oschreib> dneary: no.
13:23:17 <dneary> oschreib, I thought AIO was not working properly for EL6
13:23:25 <dneary> But that it was OK for F19
13:23:49 <oschreib> dneary: no, the whole engine is not installable on el6 due to missing rpm (spice-html)
13:24:34 <dneary> oschreib, That's a 15 minute issue, though
13:24:35 <mburns> does AIO work on el6 if we fix the spice-html issue?
13:24:56 <oschreib> wait.
13:25:06 <oschreib> mburns: no idea
13:25:20 <oschreib> there are two separate issues, the el6 break, and the sdk.
13:25:38 <mburns> waits the eta of a fix for AIO? or is it fixed, just needs a build?
13:25:44 <oschreib> dneary: 15 minutes indeed, but then we will release a version which probably wasn't tested
13:25:57 <oschreib> mburns: we just a build of SDK
13:27:52 <mburns> oschreib: ok
13:28:21 <oschreib> #info All-In-One is broken due to missing ovirt-engine-sdk-python build
13:28:41 <oschreib> #info el6 is broken due to missing spice-html build
13:29:54 <oschreib> I suggest delaying the build. my problem is that I don't have any ETA on SDK, and I HATE those recurring delays.
13:30:20 <dneary> How do we get an ETA for SDK?
13:30:36 <dneary> eedri, Any idea?
13:30:42 <mburns> dneary: just need a build from sdk people
13:30:49 <oschreib> I'll try to get them from their maintainer which isn't online
13:31:14 <eedri> dneary, we're talking about nightly repos?
13:31:20 * oschreib hides from TheCodeAssassin
13:31:37 <dneary> eedri, About what we need to get a working SDK
13:31:51 <dneary> I'd like to have more detail on what "broken" means here
13:31:54 <eedri> dneary, you can ask sdk maintainer
13:32:07 <TheCodeAssassin> hi all
13:32:10 <eedri> dneary, i can only check repos completeness in terms of buidling it in jenkins
13:32:13 <oschreib> dneary: broken means https://bugzilla.redhat.com/show_bug.cgi?id=1002749
13:32:34 <dneary> eedri, oschreib: Who is that? oourfali?
13:32:41 <oschreib> dneary: mpatern
13:32:48 <oschreib> dneary: mpastern
13:32:52 <TheCodeAssassin> we are using proxmox currently, but we are interested in using ovirt because proxmox is weird in a lot of different ways
13:32:53 <dneary> oschreib, Thanks
13:33:40 <oschreib> TheCodeAssassin: any chance you can wait with this issue? we're a bit in the middle of a release meeting. I'd love to help you afterwards though.
13:34:00 <TheCodeAssassin> oschreib: will do
13:34:00 <oschreib> mburns: dneary: so, one week delay?
13:34:17 <mskrivanek> do we need whole week to just build a thing?
13:34:21 <itamar> oschreib: maybe call/sms mpastern for ETA?
13:34:40 <itamar> its just a build, right. root cause already fixed
13:34:47 <mskrivanek> IIUC there's no code change needed anywhere, "just" a build
13:34:47 <mburns> oschreib: let do day-by-day slip
13:34:51 <oschreib> a whole week, since we need users to test it before release
13:34:58 <eedri> dneary, afaiu ovirt-engine-sdk old rpms caused AIO install to fail
13:35:02 <eedri> dneary, i removed them now from el6 repo
13:35:06 <mskrivanek> mburns: is it a problem with spice-html5 in el6?
13:35:51 <oschreib> mburns: It's an holiday here starting tomorrow, until Sunday
13:36:18 <oschreib> mburns: so a week is actually few working days over here.
13:37:49 <dneary> oschreib, Release day is tomorrow - the question is: is there anything which we can't address today which is blocking the build?
13:38:06 <dneary> Blocking for a week, if we can resolve the issues in an hour, is problematic
13:38:26 <oschreib> dneary: even if we build SDK today, which is possible, it means that no one tested it before we release
13:38:33 <oschreib> I'm hardly against that
13:41:40 <oschreib> thoughts?
13:42:22 <mburns> oschreib: let's try to get the sdk built today
13:42:34 <mburns> oschreib: can we get someone who is not in TLV to test it today?
13:42:59 <mburns> the spice-html issue is being fixed as we speak
13:44:04 <oschreib> mburns: no idea
13:44:17 <mburns> spice-html uploaded, createrepo running now
13:44:50 <mburns> oschreib: let's target getting it shipped out tomorrow if possible
13:44:54 <oschreib> mburns: you're the one not from TLV :)
13:45:15 <oschreib> mburns: how, what's the plan?
13:45:15 <mskrivanek> there are couple more;-)
13:45:24 <mburns> oschreib: i know, but i'll do the install if i have to, and do all the shipping tasks too
13:45:33 <jhernand> What needs to be tested in the SDK?
13:45:53 <oschreib> just normal install with All-In-One
13:46:14 <jhernand> Ok, I can do that.
13:46:48 <oschreib> jhernand: well, you are the best. the sad news is that I don't have eta on a build, I hope we will have one today
13:47:23 <jhernand> A build of an already tagged version?
13:47:34 <oschreib> jhernand: no idea
13:47:57 <oschreib> #info new ovirt-engine-sdk-python is needed before we can release
13:48:10 <oschreib> #action jhernand to test AIO once we have such build
13:48:21 <itamar> oschreib: please ping (via phone if needed) mpastern to get the build/etc. thanks
13:48:31 <oschreib> itamar: will do.
13:48:50 <oschreib> #action oschreib to get a new build from mpastern asap
13:49:02 <jhernand> If the bug is already fixed, and tagged, I can do the build.
13:49:27 <oschreib> jhernand: the "bug" is that the repo is broken, and we don't know the state of all-in-one.
13:49:44 <oschreib> jhernand: I don't know about tag
13:50:07 <oschreib> #info no other blockers from 3.3 tracker
13:50:20 <oschreib> #topic decision
13:50:29 <jhernand> I think that the issue with the repo won't be solved with any new build, what we need is to remove old versions: those named only ovirt-engine-sdk.
13:50:52 <jhernand> Otherwise yum gets confused and tries to install both ovirt-engine-sdk and ovirt-engine-sdk-python.
13:51:02 <oschreib> jhernand: this is the issue https://bugzilla.redhat.com/show_bug.cgi?id=1002749
13:51:36 <oschreib> dneary: mburns: lets say we have SDK today, and verification from jhernand tomorrow. are we sure we're ready to go?
13:51:51 <mburns> oschreib: i think
13:51:52 <mburns> so
13:52:10 <dneary> oschreib, Surely not 100% sure, but I will try out AIO tonight (I imagine others will too)
13:52:22 <jhernand> oschreib: Ok, that is a different issue than I was thinking about, will take a look.
13:53:10 <oschreib> I honestly feel uncomfortable with that, but it's mburns decision.
13:57:01 <peter_ovido1> hi
13:57:03 <oschreib> anyone?
13:57:12 <mburns> oschreib: i agree with that plan
13:57:33 <mskrivanek> oschreib: i'd go with a release once AIO works
13:57:48 <oschreib> ok, sounds like a plan
13:57:49 <oschreib> #info agreed to release tomorrow one AIO works
13:57:58 <oschreib> lets move to communication
13:58:06 <oschreib> #topic release communication
13:58:21 <oschreib> dneary: mburns jbrooks - are we ready with those?
13:59:25 <jbrooks> oschreib, I have a blog post mostly written on getting up and running w/ AIO and w/ gluster storage, got a bit blocked up by the missing sdk
14:00:01 <jbrooks> We've gathered material for an announce email, and plotted out some other promotion channel
14:00:02 <jbrooks> s
14:00:04 <itamar> well, one item on releasing "tomorrow" - please remember a lot of the ovirt developers are on new-year-holiday from tomorrow till end of the week, so way less people to help with any issues for people trying it out until sunday.
14:00:21 <jbrooks> that's a con, for sure
14:00:56 <dneary> oschreib, Sorry, jumping around phone calls
14:01:02 * mburns too
14:01:04 <oschreib> mburns: btw - I'll upload new engine rpms without those "rc2" tag
14:01:09 <dneary> We're in progress on the press ush, have a lot of material lined up
14:01:21 <dneary> I have a call starting now on AR & PR
14:01:22 <oschreib> itamar: yes, I raised that issue last week.
14:01:30 <dneary> I just need a release date & we're ready to go
14:01:58 <mburns> maybe i push everything to a temporary location, and then we can flip links on monday?
14:02:13 <mburns> dneary: jbrooks: can we adjust the PR stuff to be monday?
14:02:15 <dneary> itamar, re Israeli holidays: isn't there a partial week next week too?
14:02:19 <dneary> mburns, Yes
14:02:28 <oschreib> dneary: nope
14:02:30 <jbrooks> Sure
14:02:44 <oschreib> next week holiday is on Saturday and Friday.
14:03:07 <itamar> dneary. not next week, but the two after that are...
14:03:17 <itamar> lets focus on getting GA on 9/9...
14:03:36 <dneary> OK - then let's release next week, and do a release candidate today that we ask the community to test
14:03:47 <dneary> We need a RC tonight
14:03:55 <mburns> agreed
14:03:59 <jbrooks> +1
14:04:01 <mburns> oschreib: let me know when engine is uploaded
14:04:07 <mburns> i'll move it to the right place
14:04:16 <oschreib> mburns: it's the same engine, just different rpm naem
14:04:18 <oschreib> name*
14:04:46 <mburns> yep, but i'd like this to be the same packages we release
14:05:09 <mburns> and who is doing the sdk build?
14:05:28 <oschreib> mburns: we will have a build later on today
14:05:49 <mburns> oschreib: ok, just let me know when and where
14:05:54 <oschreib> will do
14:05:58 <oschreib> anything else?
14:06:07 <mburns> nothing from me
14:06:18 <mburns> did we capture the plan, though?
14:06:25 <oschreib> oh, we didnt
14:06:31 <oschreib> you can add it :)
14:06:36 <mburns> #info rebuild of engine and sdk today
14:06:53 <mburns> #action oschreib to update mburns with location of new rpms
14:07:04 <mburns> #info new engine is rpm version change only (remove rc2)
14:07:23 <mburns> #action mburns to upload new sdk and engine to stable location
14:07:35 <mburns> #action mburns to get everything prepped for 3.3 release on Monday 9-Sep
14:07:55 <mburns> #info dneary and others to test AIO install today and next couple days
14:08:01 <mburns> #info release to go out on Monday
14:08:12 <mburns> #action mburns to push release live on monday
14:08:33 <oschreib> superb
14:08:46 <mburns> anything i missed?
14:08:49 <oschreib> nope
14:08:57 <mburns> ok, then i think we're done
14:09:10 <oschreib> endmeeting in 3
14:09:36 <mburns> oschreib: if something comes up between now and monday, please send me an email directly
14:09:45 <mburns> so i know not to push
14:09:54 <oschreib> will do
14:09:55 <oschreib> 2
14:09:57 <sahina> oschreib, sorry , there's one thing
14:10:38 <oschreib> sahina: ?
14:10:47 <sahina> oschreib, there's a bug regarding installation in gluster only mode. doesn't work
14:10:56 <sahina> oschreib, would u consider this a blocker?
14:11:10 <sahina> http://gerrit.ovirt.org/#/c/18762/ - we had pushed to 3.3 branch
14:11:18 <oschreib> sahina: so please push it now
14:11:24 <oschreib> so I'll push it and test it today
14:11:37 <sahina> oschreib, i don't have permissions to merge.
14:12:06 <oschreib> sahina: please add verified and I'll merge
14:12:24 <sahina> sure thing
14:12:26 <sahina> thanks
14:12:27 <oschreib> cool
14:12:40 <oschreib> mburns: there will be a bugfix in this build
14:12:43 <oschreib> anything else?
14:12:49 <mburns> #info 1 bugfix included in engine build
14:13:00 <mburns> #info related to gluster-only mode installation of engine
14:13:18 <oschreib> ok, anything else?
14:13:40 <oschreib> thanks everyone
14:13:42 <mburns> oschreib: just the ovirt-node meeting that was supposed to start 15 min ago...
14:13:51 <oschreib> sorry :(
14:13:54 <oschreib> #endmeeting