14:01:12 <fabiand> #startmeeting oVirt Node Weekly Meeting
14:01:12 <ovirtbot> Meeting started Mon Apr 27 14:01:12 2015 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:12 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:21 <fabiand> #chairs rbarry dougsland tlitovsk
14:01:25 <fabiand> #topic Agenda
14:01:31 <fabiand> #info Other Items
14:01:31 * rbarry here
14:01:37 <fabiand> #topic Other Items
14:01:49 <fabiand> Good morning rbarry
14:02:36 * dougsland here
14:02:58 <fabiand> hey dougsland
14:02:59 <rbarry> Morning fa
14:03:10 <fabiand> :)
14:03:15 <fabiand> So, I don#t have a big agenda ..
14:03:19 <fabiand> The biggest item I still see is
14:03:23 <fabiand> #link https://gerrit.ovirt.org/#/c/39304/
14:03:25 * tlitovsk here
14:03:30 <fabiand> Review rbarry's dbus job
14:03:31 <fabiand> hey tlitovsk
14:04:12 <fabiand> Besides that I do not have items.
14:04:21 <fabiand> rbarry, dougsland tlitovsk -- do you have anything to discuss?
14:04:31 <rbarry> Nothing
14:04:32 <tlitovsk> nope
14:04:35 <fabiand> #action fabiand and tlitovsk  to review  https://gerrit.ovirt.org/#/c/39304/
14:04:50 <dougsland> nop
14:05:35 <fabiand> Perfect
14:05:39 <fabiand> Then thanks guys!
14:05:45 <fabiand> tlitovsk, please review that patch as well
14:05:50 <fabiand> If there is nothing else
14:05:51 <fabiand> going once
14:07:33 <fabiand> twice
14:09:39 <YamakasY> karimb: weird huh
16:03:54 <mr_chris> I have some confusion about qcow2 vs raw in ovirt. Is raw the base layer for all new VMs and qcow2 for snapshots?
16:03:54 <mr_chris> I don't see any option to tell a disk image to use qcow2 or raw. It just defaults to raw.
16:04:00 <mr_chris> Yet I'm still able to make snapshots even though it's using a raw disk image.
16:04:10 <mr_chris> I'm even able to make snapshots when using share iscsi volumes.
16:04:13 <mr_chris> How is it doing that?
17:49:19 <loganmc10> I'm doing some research into oVirt and have a question: what happens if the oVirt engine dies? DB corrupt, etc..
17:49:37 <loganmc10> Is there a way to just create a new Engine and re-add the hosts in 1 by 1 without any VM downtime?
22:04:41 <jflorian-local> Anyone here?
06:45:13 <tlitovsk_> fabiand, network problmes
06:45:21 <fabiand> tlitovsk, right
08:21:06 <alonbl_> fsimonce: hi!
08:21:15 <fsimonce> alonbl_, hi
08:21:34 <alonbl_> fsimonce: the openstack-java sdk was bumped only in fedora22 to 2.1
08:21:36 <alonbl_> fsimonce: the openstack-java sdk was bumped only in fedora22 to 3.1
08:21:47 <alonbl_> fsimonce: so does it mean that engine master cannot work in fc21?
08:22:01 <alonbl_> fsimonce: fc22 is not out yet... right?
08:23:20 <fsimonce> alonbl_, 3.1 introduces several new changes and we wanted to be cautious before releasing it in fedora... there was a thread with sbonazzo where we decided that to begin with we would have placed the rpms in the ovirt repo (for fc21) so that we could have pulled them in case of problems
08:23:50 <alonbl_> fsimonce: so it has not been done, what do we expect devs to do?
08:24:19 <fsimonce> alonbl_, then it has to be done
08:25:11 <fsimonce> alonbl, there were other problems earlier to run on f21 (e.g. java 8)
08:26:12 <alonbl> fsimonce: this can be overridden or use jeap-6.3, no?
08:26:13 <fsimonce> alonbl, if the other problems are all solved and this is the last obstacle... it should have been already fixed because as far as I know for fc21 the packages should have been in our ovirt repo
08:26:26 <alonbl> fsimonce: ok
08:26:30 <alonbl> fsimonce: thanks
08:30:32 <fsimonce> alonbl, http://lists.ovirt.org/pipermail/devel/2015-March/010082.html
08:31:40 <alonbl> fsimonce: sbonazzo|mtg: thanks! they should also be moved to fc21 static repo
08:32:55 <kripper> it seems like the DB update script didn't work and engine is broken
08:35:15 <sbonazzo|mtg> alonbl: fc21 is not supposed to be supported by master / 3.6  fsimonce do you have builds for fc21 ? If you  have it, I can add them to the f21 static repo
08:36:42 <kripper> Caused by: org.postgresql.util.PSQLException: The column name gluster_tuned_profile was not found in this ResultSet.
08:36:56 <alonbl> sbonazzo|mtg: fsimonce: I am building locally, btw: fsimonce you the prefix within tarball is %{name}-%{name}-%{version}, not sure how your fc22 spec works :)
08:37:22 <kripper> # cat 03_06_1260_add_tuned_profile_column_to_vds_groups.sql
08:37:22 <kripper> select fn_db_add_column('vds_groups', 'gluster_tuned_profile', 'VARCHAR(50)');[root
08:39:06 <fsimonce> alonbl, I am not seeing %{name}-%{name}-%{version}
08:39:37 <alonbl> fsimonce: strange...:
08:39:42 <alonbl> # tar -tf /root/rpmbuild/SOURCES/openstack-java-sdk-3.1.1.tar.gz | head
08:39:43 <alonbl> openstack-java-sdk-openstack-java-sdk-3.1.1/
08:39:45 <alonbl> openstack-java-sdk-openstack-java-sdk-3.1.1/.gitignore
08:39:46 <alonbl> openstack-java-sdk-openstack-java-sdk-3.1.1/.travis.yml
08:39:48 <alonbl> openstack-java-sdk-openstack-java-sdk-3.1.1/LICENSE.txt
08:39:55 <fsimonce> alonbl, cat sources
08:39:56 <alonbl> fsimonce: this is the tarball I downloaded from github
08:40:47 <alonbl> fsimonce: different sha1sum, have you created your own tarball?
08:41:02 <fsimonce> -2e798b6f329381a1b95e08f133d0a577  openstack-java-sdk-3.0.6.tar.gz
08:41:02 <fsimonce> +f2d7ac98356b6603c0fa4687d1409cc3  openstack-java-sdk-3.1.1.tar.gz
08:41:36 <alonbl> fsimonce: mine is 4b04c44944674db8cbfd2ebbb368447eb7dbae24, sec, downloading again
08:42:04 <fsimonce> alonbl, tags upstream are in the form "openstack-java-sdk-3.1.1" ...which means that the official tar from github has %{name}-%{name} if you take it from the automated github tar-gzer
08:42:58 <fsimonce> alonbl, you have to use koji where the tar.gz has the proper form
08:42:58 <alonbl> fsimonce: oh! they do not publish proper releases? I selected <Releases> not <Tags>
08:43:09 <fsimonce> alonbl, releases are built from tags
08:43:27 <fsimonce> alonbl, http://koji.fedoraproject.org/koji/taskinfo?taskID=9584795
08:43:42 <alonbl> fsimonce: github added (readded) the ability to store release files.
08:43:44 <fsimonce> alonbl, that's a scratch-build, when it's done I'll do a full build
08:43:50 <alonbl> fsimonce: there is no need for you to recrate the tarball
08:43:59 <alonbl> fsimonce: you can use: https://github.com/woorea/openstack-java-sdk/archive/openstack-java-sdk-3.1.1.tar.gz
08:44:41 <fsimonce> alonbl, I know... but it's the one that you see with the wrong double %{name}
08:45:00 <alonbl> fsimonce: but this is what upstream releases, it is not wrong it is the source
09:03:40 <danken> dcaro: sbonazzo|mtg: can you disable http://jenkins.ovirt.org/job/vdsm_master_install-rpm-sanity-fc22_created/ until it is ported to use dnf?
09:03:51 <danken> I've opened https://fedorahosted.org/ovirt/ticket/317 to track this task
09:04:42 <sbonazzo|mtg> danken: it's working with dnf / yum, error is : 09:34:27 Error: nothing provides libvirt-daemon >= 1.2.14 needed by vdsm-4.17.0-731.gitd7c9c97.fc22.x86_64.
09:06:40 <YamakasY> morning guys!
09:09:52 <bkorren> tee hee hee
09:14:38 <kripper> emesika: Hi Eli, I upgraded engine and missed 4 sql updates. Where is the script to update the DB?
09:25:32 <eedri|mtg> danken, disabled
09:26:22 <YamakasY> anyone knows why a vm with 50 characters does not start with  engine-config -g MaxVmNameLengthNonWindows set on 80 ?
09:33:22 <YamakasY> jvandewege: ping pong
09:33:55 <jvandewege> YamakasY: pong ping
09:34:19 <YamakasY> jvandewege: oh my friend, all well there ?
09:34:34 <jvandewege> YamakasY: yes
09:34:43 <YamakasY> jvandewege: that is good to hear!
09:34:59 <YamakasY> jvandewege: new ovirt/virtualization thingies ?
09:35:24 <jvandewege> YamakasY: no, just keeping up with updates
09:35:45 <danken> eedri|mtg: thanks.
09:35:55 <YamakasY> jvandewege: nice, same here... tho I see some weird MaxVmName Lenght issue
09:36:44 <jvandewege> YamakasY: I saw, don't have a solution. Only thing: did you set it for the right cluster version?
09:37:11 <YamakasY> jvandewege: wasn't it overall ?
09:37:25 <YamakasY> that is a good thing tho
09:37:54 <YamakasY> jvandewege: btw, about clusters and so on... we should improve the foreman templating part for ovirt
09:42:29 <jvandewege> YamakasY: what do you want to improve?
09:44:43 <YamakasY> jvandewege: let's say bootorder, the host you want it to start on and set the HA options for it
09:45:15 <YamakasY> It think that is great and saves you login on ovirt after creation
09:46:11 <jvandewege> YamakasY: think I saw a discussion about pxe boot and depending on which version/distro-version of seabios you had it either worked as expected or not.
09:47:29 <YamakasY> jvandewege: erm no that was something else
09:48:03 <YamakasY> jvandewege: it would be nice to set what you want to boot first, I still don't get why disk is first and no pxe... the HA part I think would be great too
09:52:26 <YamakasY> jvandewege: or are you doing twice management still ? like foreman and than ovirt ?
10:07:13 <jvandewege> YamakasY: yes because VM's need sometime an extra cpu or memory and we're not at a stage that we can rebuild from foreman with those extra settings, yet
10:10:55 <YamakasY> jvandewege: erm, foreman is capable of setting CPU's
10:11:10 <YamakasY> jvandewege: just make a profile for it ?
10:37:27 <eedri|lunch> bkp-pto, ping
10:53:10 <bkp> eedri|lunch: Pong
10:53:42 <eedri|lunch> bkp, hey.. just wondering if you got any emails from attaliasn
10:53:48 <eedri|lunch> bkp, i think our lic was approved
10:54:30 <bkp> eedri|lunch: I saw them in my inbox. Have not opened yet, still digging out from taking yesterday off.
10:55:14 <eedri|lunch> bkp, sure
10:56:24 <bkp> eedri|lunch: Just forwarded you the last (approval!) email from them. It looks good to go to me!
10:56:37 <bkp> eedri|lunch: Thanks for following up on that
10:56:41 <eedri|lunch> bkp, excellent, dcaro already logged in
10:56:48 <eedri|lunch> bkp, we'll add an alias for jira.ovirt.org also
10:56:55 <bkp> eedri|lunch: Noted
11:45:28 <sbonazzo> tal: pkliczew: Hi, can you please merge https://gerrit.ovirt.org/40323 ?
11:50:21 <tal> sbonazzo: Done
11:58:05 <sbonazzo> tal thanks
12:34:15 <alonbl> sbonazzo: hi, not sure what the problem is with fc21 and engine, I installed the jboss eap 6.4 and all seems to be working, any reason not to redistribute this one instead of 7.1.1?
12:39:34 <sbonazzo> alonbl: licensing issues, we can't re-distribute EAP 6.4
12:39:55 <sbonazzo> alonbl: not the binary one at least
12:39:57 <alonbl> sbonazzo: strange, why?
12:40:09 <alonbl> sbonazzo: they permit downloading the binaries
12:40:17 <alonbl> sbonazzo: I did not see any terms
12:41:26 <sbonazzo> alonbl, can't remember the full reason, please dig into devel mailing list, there was an open discussion about re-packaging eap 6.4
12:42:04 <alonbl> sbonazzo: worse case we can ask user to do this manually like fetch restriction in gentoo
12:42:27 <alonbl> sbonazzo: this does not mean user cannot use fc21
12:45:54 <sbonazzo> alonbl: ok, btw, on integration side, we're targeting f22 for 3.6 so we're not planning to commit working on F21 in 3.6 time frame
12:48:09 <alonbl> sbonazzo: still if we are to redistribute something, better to redistribute the eap
12:54:33 <sbonazzo> alonbl: did you checked devel list on the reason about not re-distributing eap?
12:55:27 <alonbl> sbonazzo: no, not that important anyway, I thought we can provide better service for users for 3.5 and maybe 3.4 as well. but you guys ties the distro version for some reason.
12:55:45 <alonbl> sbonazzo: not that important to me.
12:56:11 <sbonazzo> alonbl: we added support to el7 in 3.5.1
12:56:29 <sbonazzo> alonbl: and I started trying to get f21 support in 3.5.2 1 month before F21 has been released
12:56:57 <alonbl> sbonazzo: not sure I follow. jboss-7.1.1 has issues with java-8
12:56:58 <sbonazzo> alonbl: I'm not tied to nothing, I just don't have time to support everything
12:57:14 <sbonazzo> alonbl: ok, that's a known issue since december 2014
12:57:15 <alonbl> sbonazzo: the simplest solution is to use jboss-eap and all is working
12:57:25 <alonbl> sbonazzo: not sure why not provide that solution
12:57:29 <sbonazzo> alonbl: I already suggested that and got a nack
12:57:30 <alonbl> sbonazzo: as I wrote not that important to me.
12:57:55 <alonbl> sbonazzo: the question is how you suggested, if there is a problem in redistribute, then user can do this himself
12:58:10 <alonbl> sbonazzo: at least he will get service
12:59:41 <sbonazzo> alonbl: http://lists.ovirt.org/pipermail/devel/2015-February/009878.html
12:59:54 <sbonazzo> alonbl: google may help you on this things
13:00:33 <sbonazzo> alonbl: not sure that common user can get EAP binaries without violating license
13:00:52 <alonbl> sbonazzo: every one can download it
13:01:04 <alonbl> sbonazzo: there was no special approval
13:02:04 <sbonazzo> alonbl: feel free to reopen the discussion
13:02:25 <alonbl> sbonazzo: again, I do not intend to get involve.
13:02:41 <alonbl> sbonazzo: but if this is the only issue, you can present it differently so people can react differently
13:03:18 <alonbl> sbonazzo: "known issue: in order to run ovirt-enigne on fc21, one can download jbeap-6.4, extract it into /opt and use engine-setup --jboss-home=..."
13:03:36 <alonbl> sbonazzo: but this only my philosphoy of how to support customers.
13:05:00 <alonbl> sbonazzo: anyway, I am scared of the jboss-8 and issues that may follow if it is not fully integrated into fedora when we release
13:07:06 <sbonazzo> alonbl: I can then re-assure you, only 3 person replied to the poll using fedora as os for ovirt
13:07:15 <sbonazzo> alonbl: all the others are using centos
13:08:17 <sbonazzo> alonbl: and also if I'm willing to support also those 3 person I'm targeting to the latest available fedora on 3.6 release
13:08:28 <sbonazzo> alonbl: no capacity for supporting more than one
13:08:44 <alonbl> sbonazzo: once again, there is no really an action item
13:08:46 <alonbl> sbonazzo: but ok
13:58:36 <bkp> I figure Rich was slammed, but Gina and Jim?
13:58:45 <bkp> Whoops.
14:30:49 <sbonazzo> mskrivanek: jhernand: evilissimo2 : do we have a SDK / REST api call for forcing a refresh of the guest agent data?
14:31:10 <evilissimo2> sbonazzo: there's no such thing
14:31:15 <evilissimo2> sbonazzo: not even on the vdsm API
14:31:30 <evilissimo2> the only way to get that is to migrate the vm
14:31:44 <sbonazzo> evilissimo2: I mean on the engine side, not on the VM side
14:32:03 <sbonazzo> evilissimo2: suppose I've guest agent version x, reboot, update to version x +1
14:32:16 <sbonazzo> evilissimo2: and I wan't to refresh the data in the engine
14:32:26 <sbonazzo> by reading again the guest agent info
14:33:09 <evilissimo2> well it's currently read every 15 seconds
14:33:36 <sbonazzo> evilissimo2: thanks
14:33:42 <sbonazzo> evilissimo2: so maybe not an issue
14:34:50 <sbonazzo> evilissimo2: fqdn / ip address are refreshed too?
14:35:09 <evilissimo2> when the guest agent starts, it send all its information
14:35:34 <evilissimo2> if not, it's a bug
14:36:12 <sbonazzo> evilissimo2: thanks
15:46:47 <PA_dot> hello,   anu recommendation for master domain ?? ( eg. small one, replicated, .... ?? )  or "standard" size with data ?
15:47:31 <PA_dot> and how to change master domain to diff. volume ??
16:00:04 <PA_dot> hello,   anu recommendation for master domain ?? ( eg. small one, replicated, .... ?? )  or "standard" size with data ?
16:00:13 <PA_dot> and how to change master domain to diff. volume ??
16:04:59 <PA_dot> dobry den , muzu ??
17:31:50 <PA_dot> anybody for "journal: End of file while reading data: Input/output error "  on gluster ( XFS ) , managed by oVirt
17:49:03 <PA_dot> anybody for "journal: End of file while reading data: Input/output error "  on gluster ( XFS ) , managed by oVirt
18:14:01 <alonbl> nsoffer: can you help PA_dot?
18:22:33 <nsoffer> alonbl, I don't think so
18:23:01 <nsoffer> PA_dot, please contact glusterfs developers with such issues
18:25:46 <alonbl> nsoffer: who is online? shubhendu? shaharh?
18:26:31 <nsoffer> alonbl, I don't know
18:27:04 <alonbl> nsoffer: email address? something? even I do not know to contact "glusterfs developers"...
18:46:13 <nsoffer> alonbl, I don't know - I never got a reply on redhat #gluster channel
06:08:52 <kripper> hi
06:09:05 <kripper> setMasterDomain() is failing
06:09:15 <kripper> in /usr/share/vdsm/storage/sp.py
06:09:33 <kripper> sbonazzo: I sandro, is /usr/share/vdsm/storage/sp.py yours?
06:17:29 <sbonazzo> kripper: good morning :-) no, it's vdsm code under storage, maybe amureini or nsoffer
06:21:54 <kripper> sbonazzo: good morning. Ok, I found a problem VDSM not correctly detecting all storage pools
06:22:24 <kripper> [ vdsClient -s 0 getConnectedStoragePoolsList ] returns 1 storage pool
06:26:13 <sbonazzo> kripper: I suggest to open a BZ about it
06:47:02 <kripper> sbonazzo: do you know what the 'FilesystemBackend' storage domain is?
06:47:22 <kripper> hosted-engine's SD?
06:49:02 <sbonazzo> kripper: it's a class for accessing SD, it's in the ha package
06:49:48 <sbonazzo> kripper: msivak may help you with that
08:07:56 <mvk> ping jhernand
08:16:48 <kripper> msivak: Hi, I wonder if you can help me with the following issue: I'm getting "StoragePoolMasterNotFound"
08:17:07 <kripper> msivak: thus, I'm not able to create VMs
08:17:27 <kripper> msivak: maybe we can debug it together
08:18:16 <kripper> msivak: vsdClient is listing the storage domain
08:28:48 <mtayer> ykaplan: /etc/ovirt-engine/engine.conf.d/10-setup-database.conf
08:54:55 <kripper> what is the easisest way to install VDSM locally from a git clone to test some pulled patches?
08:56:17 <kripper> make install is not working out of the box or I'm missing some "configure" params?
08:57:20 <ewoud> kripper: does http://www.ovirt.org/Vdsm_Developers help?
08:58:02 <kripper> it only explains how to build a RPM
08:58:17 <kripper> I guess "make install" should work
08:58:25 <kripper> bug I'm missing some configurations
08:58:55 <kripper> OSError: No such file or directory: ${prefix}/etc/libvirt/libvirtd.conf
08:59:10 <kripper> ${prefix} is not replaced
09:04:43 <kripper> make clean did it
09:04:57 <kripper> and a chown
09:08:13 <YamakasY> morning all!
09:10:12 <kripper> morning
12:30:55 <danken> bazulay: hi!
12:31:04 <bazulay> mmucha:  https://url.corp.redhat.com/79ee8cd
12:56:56 <atkachuk> hi all !
13:06:52 <atkachuk> I have a little question : I use oVirt Engine Version: 3.5.1.1-1.el6 after delete host (name for ex. "testA") i cannot add this host second time : Error while executing action: Cannot add Host. The Host name is already in use, please choose a unique name and try again. Smb can help me . Where I must delete record
14:54:56 <wilsonwr> The last weekly sync mentioned challenges integrating with Debian due to an ancient libvirt version; I don't know if it's pertinent, but it looks like Debian Jessie has 1.2.9-9 (was 0.9.12.3-1+deb7u1 in wheezy)
15:29:09 <PA_dot> hello,
15:29:49 <PA_dot> how would I  run VM on dedicated hosts ?? ( eg. 2 from 4 )
16:01:57 <wilsonwr> When setting up a developer environment, are ovirt-host-deploy and otopi installed as root?
19:19:15 <prussell> anyone having live merge success after upgrading to 3.5.2? We're running engine on centos6, all our hypervisors are running 3.5.2 Node el7 and we're getting a failure with error code 52 in the engine logs
09:26:55 <Svedrin> is there any way to make a guest disk have a certain ID_SCSI_SERIAL? normally that value is simply missing, can I set it somehow?
09:51:35 <karimb> Svedrin, if libvirt supports it then you could write a hook
09:51:51 <Svedrin> karimb, how would I do that? :)
10:19:20 <Dw_Sn> hello, no way to enforce any VM to be created with VNC instead of SPICE ? like a default settings / option in the engine ?
11:14:06 <tools> Hey I need help
11:15:04 <tools> I am following this guide http://www.ovirt.org/Quick_Start_Guide#Install_Hosts but when I have installed the ovirt repo and run yum install -y ovirt-engine I get this: No package ovirt0engine available
12:28:34 <danken> dcaro: is glance.ovirt.org temporarily down?
12:29:03 <dcaro> danken: no idea who maintains that
12:30:09 <danken> dcaro: gahh
12:30:27 <danken> masayag: do you have an idea who owns glance.ovirt.org ?
12:30:43 <masayag> danken: Oved does
12:31:15 <danken> dcaro: (I'm surised that we don't have a liveliness test, as we have for gerrit.ovirt.org)
12:31:26 <danken> oved ? ^^^
12:31:27 <oved> danken, indeed. although haven't touched it in a while, and will be happy to pass ownership to someone else.
12:31:36 <oved> danken, any volunteers?
12:32:54 <dcaro> danken: I was not aware of it's creation or anything, you can open a task on infra track to hand it over to infra team
12:32:59 <dcaro> oved: ^^
12:33:20 <oved> dcaro, how do I do that?
12:33:33 <dcaro> oved: https://fedorahosted.org/ovirt/
12:35:22 <danken> oved: shouldn't it be ever-ready? it holds appliance images
12:35:49 <oved> danken, it should. Is it down?
12:37:29 <oved> dcaro|food, done.
12:37:34 <oved> dcaro|food, bon appetite.
12:46:42 <danken> oved: it does not answer pings or http...
12:47:32 <oved> danken, http://glance.ovirt.org:9292/
13:02:37 <ade> anyone know of ovirt works on F22 yet?
13:03:43 <ade> hmmm, maybe Centos 7,1 is a better bet
13:14:07 <kripper1> hi, how do I git push to my own branch?
13:14:13 <kripper1> on gerrit
13:14:38 <kripper1> I was pushing to github, but I guess I will need to create pull request, don't I?
14:00:32 <dyasny> lvernia, ping
14:01:05 <lvernia> dyasny: pong
14:05:48 <kripper1> morning
14:46:16 <z3d3> hello, is possible to use on dc with 2 nodes shared storage glusterfs when I installed node from ovirt-node-iso-3,5?
15:36:51 <YamakasY> does anyone recognize that the engine is handeling non responsive hosts where actually everything is running fine ?
15:41:28 <kripper1> can someone help me to debug a sanlock deadlock?
16:05:25 <glafouille> <YamakasY> : do you run centos 6?
16:06:01 <glafouille> <YamakasY> I met this issue with centos 6 & 7 + vdsm 4.14.10
16:07:13 <glafouille> <YamakasY> I upgraded to vdsm 4.14.16, I still meet the issue with 6.6, but 7.1 is stabilized.
16:08:13 <glafouille> sorry, I mean upgrade from vdsm 4.16.10 to 4.16.14
17:30:17 <YamakasY> glafouille: I see it in 2 cluster happening, one has C6 and C7 and the other one has only C7
20:49:30 <z3d3> hello, is possible to create glusterfs storage on ovirt-hypervisior ?
08:11:14 <YamakasY> glafouille: around?
08:33:50 <stefanlsd> Hi, im doing a hosted-engine --deploy and during setup it quits with Failed to execute stage 'Misc configuration': [Errno 22] Invalid argument: '/rhev/data-center/mnt/172.16.10.1:_volume1_HostedEngine/0bdd41c3-ccf 7-4c01-beb9-de4f1d2950f9/images/950d4194-9977-4e93-ba82-7f0aea7b84ea'   (it seems like from the log its during the sanlock stuff). Any ideas?
14:25:22 <feldspar> Hi. My ovirt-engine install claims all hosts are filtered out because they don't have the necessary networks. When I check the hosts, they do have all the networks they should have, but engine doesn't recognze it. Anyone know how ovirt-engine matches the networks of a host with the networks on record in the database?
14:54:15 <mr_chris> Forgive me but Google has failed me here. I have a guest instance in oVirt that will not shut down. Whether I shut it down from within the guest of forcefully power it off, it keeps automatically restarting.
14:54:25 <mr_chris> It does this regardless of if HA is enabled or not.
14:54:37 <mr_chris> What does this and how do I disable it?
15:59:03 <stefanlsd> Hi, im doing a hosted-engine --deploy and during setup it quits with Failed to execute stage 'Misc configuration': [Errno 22] Invalid argument: '/rhev/data-center/mnt/172.16.10.1:_volume1_HostedEngine/0bdd41c3-ccf 7-4c01-beb9-de4f1d2950f9/images/950d4194-9977-4e93-ba82-7f0aea7b84ea'   (it seems like from the log its during the sanlock stuff). Any ideas?
16:41:15 <mr_chris> Forgive me but Google has failed me here. I have a guest instance in oVirt that will not shut down. Whether I shut it down from within the guest of forcefully power it off, it keeps automatically restarting.
16:41:24 <mr_chris> It does this regardless of if HA is enabled or not. What does this and how do I disable it
17:33:04 <feldspar> mr_chris: have you checked the properties of the vm? does it happen on all of your hosts, or only on specific hosts? what did the vdsm log (or engine log) note at the time of shutdown/force restart?
17:38:54 <mr_chris> feldspar, Just that host. I'll check the logs.
17:51:18 <mr_chris> feldspar, And now I can't reproduce the problem. Oh well. Thanks anyways.
17:52:23 <feldspar> mr_chris: you're welcome, though I didn't do anything. :)  I've had similar problems, and some seem to stem from engine.
17:54:09 <feldspar> mr_chris: maybe you know something about ovirt logical networks? My engine thinks its hosts are all missing some networks, but refreshing the capabilities doesn't note anything. I can manually check that all networks are there.
17:54:50 <feldspar> still, engine is saying I can't start any VMs because there isn't a single host available with the right networks
17:55:08 <mr_chris> feldspar, I know how to copy the config I was taught. My network foo is pretty weak.
17:55:20 <mr_chris> *network-fu
17:56:07 <mr_chris> You're saying the you can ssh in and see the networks but the engine isn't recognizing it?
17:58:39 <feldspar> mr_chris: yes, that's what I usually do. checking the interfaces reveals everything is there, and up until recently engine didn't think much of it. now it won't let me start anything, or tell me why
17:59:54 <feldspar> mr_chris: what do you run on the vdsm hosts?
18:00:33 <mr_chris> feldspar, Centos 7 node.
18:01:57 <feldspar> mr_chris: mine is on centos 6 rpm.
18:02:24 <mr_chris> feldspar, I can say that one thing we've had no issue with is networking.
18:02:37 <mr_chris> Yet.
18:03:46 <feldspar> good to hear. I've had some trouble getting the network going, mostly that ovirtmgmt would show up to be a vm network even after unchecking that in the Networks tab of engine
18:09:29 <feldspar> mr_chris: do you use more than one network?
18:16:55 <mr_chris> feldspar, We use a few vlans.
18:17:07 <mr_chris> And bonding. If you want I can send you a screenshot of what it looks like to the node.
18:20:20 <feldspar> mr_chris: that'd be great
18:21:26 <mr_chris> feldspar, http://i.imgur.com/6e6yW8y.png
18:24:09 <feldspar> mr_chris: thanks, now I have a better understanding of how that works out
18:24:18 <mr_chris> Glad I could help.
18:24:20 <feldspar> that bond is 3x 1GB?
18:24:37 <mr_chris> 10 Gb/s
18:24:57 <mr_chris> It's running on an m1000e chassis.
18:25:13 <feldspar> nice.
18:26:54 <feldspar> I see your ovirtmgmt network is still marked as 'vm'. Maybe the problems with my ovirt-engine started when I deselected that.
18:37:23 <mr_chris> Maybe.
19:04:09 <mr_chris> A good way to kill a centos 7 node: Try to upgrade it from the engine web interface.
19:05:03 <mr_chris> ISO uploads, it begins to attempt to install it, claims to fail due to loss of SSH connectivity, then is left in a failed state.
19:05:40 <mr_chris> Wound up having to mount the ISO through the DRAC and upgrade that way.
19:09:30 <feldspar> mr_chris: that was all remote? maybe the ssh connectivity wasn't really gone
19:09:51 <mr_chris> Don't know. It's just a mess right now.
19:16:44 <feldspar> The same thing has happened to me with a CentOS 6 install.
19:45:53 <kripper> hi, is "add_lockspace fail result -5" normal?
19:51:04 <feldspar> kripper: don't think so. never even saw that message before, where did you find it?
19:54:21 <kripper> I see it all the time
19:54:26 <kripper> I thought it was normal
19:54:36 <kripper> Where are glusters statedumps?
19:54:39 <kripper> on CentOS?
19:58:01 <kripper> found it
13:34:54 <Atonaby> Hi all. I'm a seasoned admin, not a developer, and not accustomed with the Java world. I try to install ovirt on a Debian test machine (Jessie 8.0, the current stable) and I'm like a fish out of water with jBoss and patternfly. I don't find "easy" step-by-step procedure allowing me to solve the obstacle I encounter.
13:35:21 <Atonaby> Anyone has links or so ? I can provide ssh access to a test machine.
16:28:58 <sudoshred> Good day all
03:05:18 <gotgnu> is there a public mirror site for ovirt downloads that supports rsync and not just http or ftp?
09:23:03 * mvk is away: `
09:49:29 * mvk is back (gone 00:26:27)
12:18:33 <wakemaster> Hello all, I am in the process of installing ovirt on a OVH dedicated server using the hosted-engine setup. One problem I am having is getting the hosted VM to have internet access. No matter what I try I cannot seem to get it to ping even the gateway. Anyone have any experience or help with this?
13:07:15 <didi> wakemaster: is this nested kvm by any chance?
13:08:22 <wakemaster> @didi yes, it is in kvm
13:08:48 <didi> wakemaster: and you have control over the physical host?
13:09:28 <wakemaster> didi: yea, i have centos 7 installed on the bare metal system
13:10:07 <didi> wakemaster: and you run hosted-engine --deploy on these bare metal systems? Or on VMs inside them?
13:11:17 <wakemaster> didi: on the bare meal system. I am at the stage of the installed where i need to run the engine setup inside the VM. But I can't get network connection
13:11:55 <didi> wakemaster: ok, no idea then :-( For nested kvm (that is, hosts that are actually VMs themselves), you need vdsm-hook-macspoof)
13:12:17 <didi> wakemaster: do you use dhcp?
13:12:26 <didi> wakemaster: does the engine VM get an IP from your dhcp server?
13:12:30 <wakemaster> didi: no i am using static ip addresses
13:12:59 <wakemaster> didi: I think it is something weird with the OVH network and how it works.
13:13:11 <didi> wakemaster: that's probable of course
13:13:24 <didi> wakemaster: did they assign you just a single IP address for your hosts?
13:13:43 <wakemaster> didi: they assigned a single IP, and I bought a secondary one
13:13:58 <didi> wakemaster: did you verify that the secondary one works?
13:14:12 <wakemaster> didi: when I bind it to the bare metal system, yes it doe
13:14:17 <wakemaster> *does
13:14:51 <didi> wakemaster: perhaps they accept only a fixed mac address?
13:15:46 <wakemaster> didi: they do, which I was setting up inside of the VM. I am reinstalling it now and going to set that MAC to the bridge as well and see if that helps
13:16:28 <didi> wakemaster: you might find it easier to debug first with some live cd and virt-install, when this works try continuing with hosted-engine
13:17:26 <wakemaster> didi: alright, I will see if I can manage to try that out
13:17:55 <didi> wakemaster: good luck
13:18:19 <wakemaster> didi: thanks, this project turning into a longer one that expected lol
13:19:44 <didi> wakemaster: hosted-engine --deploy also asks you for the MAC address to use for the VM. Once something works, clean up and try again, and use the mac address that worked for you (and ip address that worked, inside the vm)
13:20:30 <didi> wakemaster: other than that, the vm created by hosted-engine --deploy should behave mostly the same as one created by virt-install
13:21:07 <didi> wakemaster: good luck, please report success/failure on the list if possible (and especially if it was interesting to solve)
13:21:16 <didi> wakemaster: thanks and good luck
13:37:11 <wakemaster> didi: the issue was that during the setup step the MAC address must be set to the given MAC from OVH. Using the MACADDR setting in the VM wasn
13:37:17 <wakemaster> 't overriding it
13:37:54 <didi> wakemaster: 'Using the MACADDR setting in the VM'? Where in the vm?
13:38:24 <didi> wakemaster: in /etc/sysconfig/network-scripts/ifcfg-* ?
13:38:43 <wakemaster> didi: yes
13:38:54 <wakemaster> didi: ifcfg-eth0
13:39:41 <didi> wakemaster: weird, it should have worked imo. Didn't check that recently though. You might want to file a bug against the OS (Centos?)...
13:39:47 <didi> wakemaster: anyway thanks for the report!
13:40:08 <didi> wakemaster: not sure what they do exactly or whther they'll consider it a bug, though
13:40:43 <wakemaster> didi: from all settings you can see it appears to work from inside the VM. I think it is more the OVH network. Something going on there with bridged connections
13:41:20 <didi> wakemaster: sounds so. But how does it work then, when you set on vm level? weird
13:41:47 <wakemaster> didi: it works when you set it at the bare metal system level. Not the VM
13:44:14 <didi> wakemaster: you mean just giving the correct mac address to hosted-egnine --deploy, when asked, was not enough?
13:44:36 <didi> wakemaster: so I don't think HA will work for you
13:44:55 <wakemaster> didi: sorry. That is where you have to set it. When the hosted-engine asks. If you don't set it there. Inside of the VM won't work
13:45:03 <didi> wakemaster: ok
13:45:16 <didi> wakemaster: so it's in vm level, but not inside it
13:45:28 <didi> wakemaster: ugly, but sounds good enough
13:46:07 <wakemaster> didi: yes. Still learning proper wording when it comes to virtualization if I confused you at all
13:46:18 <didi> wakemaster: np at all...
13:46:32 <didi> wakemaster: not sure there is even "proper wording"...
13:47:33 <wakemaster> didi: perfect. Well i will get there eventually to make my point clearer then
07:19:02 <YamakasY> morning
08:18:14 <pdangur> dcaro: https://gerrit.eng.lab.tlv.redhat.com/#/c/16038/
10:22:02 <nostradamuz> do you also have a slow ovirt mirror.., i am downloading with 120kB/s.. takes ages..
14:02:08 <ovirtbot> fabiand: Error: Can't start another meeting, one is in progress.
14:02:23 <fabiand> #endmeeting